[Solved] Booting recovery kernel 4.4 - Gave up waiting for root dev..

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
cartland
Level 1
Level 1
Posts: 11
Joined: Thu Nov 29, 2012 10:06 pm

[Solved] Booting recovery kernel 4.4 - Gave up waiting for root dev..

Post by cartland » Thu Jan 21, 2016 4:07 am

I installed Mint KDE 17.3 64 bit on a Dell XPS 13 9350 Skylake. I can dual boot Win 10 and Mint.

Under Mint, the Broadcom chip is not supported. I have no wireless or card reader support. These drivers are supported in kernel 4.4, so I installed it.

Booting into 4.4 gives "Gave up waiting for root device .... /dev/disk/bu-uuid/xxxxxxxxxxx does not exist. See attached screen shot.

Tried some things as summarised here http://askubuntu.com/questions/567730/g ... esnt-exist but before trying others e.g. IDE, I was wondering if it is not recommended to run 4.4 at all with mint 17.3.

Using kernel 3.19, it works perfectly and the grub menu entry for 4.4 is identical, apart from the kernel version reference of course. See attached screen shot.

So 3.19 can find the root device but 4.4 can't for some reason.

Assistance much appreciated.
Attachments
GrubEntry.jpg
GaveUpWaiting.jpg
Last edited by cartland on Sun Feb 28, 2016 6:27 am, edited 1 time in total.

cartland
Level 1
Level 1
Posts: 11
Joined: Thu Nov 29, 2012 10:06 pm

Re: Booting recovery kernel 4.4 - Gave up waiting for root dev..

Post by cartland » Sun Feb 28, 2016 6:21 am

Working using 4.4.3 based on bits and pieces around the internet. Key things seem to be:

updating gcc to 4.9.3

Installing
* skl_guc_ver4_3
* Skylake DMC - 1.26 (may not be required - not sure)
from https://01.org/linuxgraphics/downloads

and adding the following kernel parameter: idle=nomwait

and adding
nvme
i915
intel_agp

to /etc/initramfs-tools/modules

Apologies, but no longer sure where I got these tidbits from.

Wifi/Bluetooth working with Broadcom chip.

dmesg shows errors, apparently due to bug(s) in Dell BIOS (1.2.3). Mainly seems to affect power management. Can't hibernate.

Haven't tried external monitors. USB-C to ethernet works.

Otherwise, all good relative to 1.3.19 kernel. Looking forward to 16.04 and hopefully proper scaling support for the QHD+ screen.

Skaendo

Re: [Solved] Booting recovery kernel 4.4 - Gave up waiting for root dev..

Post by Skaendo » Sun Feb 28, 2016 2:37 pm

It seems that there is a bug in the kernel right now that affects some Dell laptops. I have read that it can also cause issues with hibernation and suspend.

Since you have it worked out that's great. If you didn't I would have recommended trying to drop back to a 4.1.x kernel since the issues started showing up around 4.2.x.

Nice work getting it fixed.

cartland
Level 1
Level 1
Posts: 11
Joined: Thu Nov 29, 2012 10:06 pm

Re: [Solved] Booting recovery kernel 4.4 - Gave up waiting for root dev..

Post by cartland » Tue Mar 01, 2016 5:34 am

Another thing. I was getting some window flicker artefacts (lines) when moving windows and particularly when playing videos. I use Mint Kde 17.3. I fixed this by changing Compositing type from XRender to OpenGL 3.1 and setting the Tearing Prevention (VSync) to None. (Qt graphics system is unchanged at Native.) Screen is rock solid now.

System Setting -> Desktop Effects -> Advanced.
:D

Edit:
1. Bluetooth dodgy, I really need the latest http://www.bluez.org/. I'll wait for Mint 18.

Post Reply

Return to “Installation & Boot”