Can't install LMDE repos to Debian

Archived topics about LMDE 1 and LMDE 2
Locked
vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Can't install LMDE repos to Debian

Post by vlad1777d »

I can't install LMDE repos to Debian unstable (sid).

1. I add repos from my LMDE2 installation, than comment all than refers to Debian stable, that refers to LMDE I uncomment:
https://pp.vk.me/c630220/v630220447/1d8 ... s772fo.jpg

2. Update cache, and got such error:
https://pp.vk.me/c630220/v630220447/1d9 ... 7xG2xo.jpg

3. Try to resolve this error with this method:
https://pp.vk.me/c630220/v630220447/1d9 ... kORvAk.jpg

4. After I had received such error:
https://pp.vk.me/c630220/v630220447/1d8 ... dwIG8s.jpg


Now I had removed all keys from apt, gpg, commented LMDE repos in sources.list.
And waiting for help, if you'll be gracious =)


Added after.
I have the same issue with Google Chrome repositories. In the Debian-next IRC people pointed me to this bug: https://bugs.debian.org/cgi-bin/bugrepo ... bug=818540
And said that developers of Chrome will fix their repos.

So I have thought that something is wrong with repos of LMDE too, not in the apt program.
Last edited by vlad1777d on Tue Mar 22, 2016 3:16 pm, edited 1 time in total.

mintor
Level 1
Level 1
Posts: 8
Joined: Mon Mar 14, 2016 2:19 pm

Re: Can't install LMDE repos to Debian

Post by mintor »

I add repos from my LMDE2 installation, than comment all than refers to Debian stable, that refers to LMDE I uncomment
Leave the jessie repos in, just set higher priority for betsy in apt preferences:

Code: Select all

$ cat /etc/apt/preferences
Package: *
Pin: release a=betsy
Pin-Priority: 700

Package: *
Pin: release a=stable
Pin-Priority: 500
3. Try to resolve this error with this method
Try this to import the keys:

Code: Select all

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0FF405B2

vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Re: Can't install LMDE repos to Debian

Post by vlad1777d »

Thank you, but this does not worked. I tried to receive key on both: Ubuntu and subkeys.pgp.net, but this does not helped:

Code: Select all

W: gpgv:/var/lib/apt/lists/partial/linux-mint.froonix.org_dists_betsy_Release.gpg: The repository is insufficiently signed by key E1A38B8F144675D060EA666F3EE67F3D0FF405B2 (weak digest)
W: gpgv:/var/lib/apt/lists/partial/extra.linuxmint.com_dists_betsy_Release.gpg: The repository is insufficiently signed by key E1A38B8F144675D060EA666F3EE67F3D0FF405B2 (weak digest)

User avatar
killer de bug
Level 14
Level 14
Posts: 5399
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Can't install LMDE repos to Debian

Post by killer de bug »

I don't really see the point in adding LMDE2 repos to a Sid install. LMDE is based on stable. You will face incompatibilities.
If it ain't broke, fix it until it is.

vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Re: Can't install LMDE repos to Debian

Post by vlad1777d »

If incompatibles will appear - I'll remove those packages.
Also Sid has a newer versions of packages, so I can solve dependencies from It's repos.

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4221
Joined: Sat Sep 13, 2014 11:12 am
Location: USA primarily

Re: Can't install LMDE repos to Debian

Post by Fred Barclay »

So when udev from Sid breaks Cinnamon from Betsy, what are your plans? :)
Will you pin an old version of udev, and risk security vulns? Or will you install Cinnamon from Sid, and therefore not have much use for the Betsy repos at all?

Don't get me wrong, it certainly sounds like a lot of fun (LMDE Betsy is boringly stable) and I wish you the best, but I wouldn't recommend doing this on a machine you actually need!
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Re: Can't install LMDE repos to Debian

Post by vlad1777d »

Thank you for answer.
I have already installed Cinnamon from Sid, and I need Betsy repos only for several packages: icon themes (they are absent at Sid's repos, but without them I can't mark folders with different colors), package with wallpapers, that's, maybe, all. I thought to download and install them from website, but it'll better to update them automatically. Every new Mint release new wallpapers are added to package.

It'll not hurt my machine - I'll pin those repos with 150 priority.

I want to know: where is the problem: in apt (maybe an error in it, maybe the newer format of authentication the repos), or, maybe in the Betsy repos: maybe there is some problem. If problem is in last, than I'll write a bugreport, or something like that.

User avatar
killer de bug
Level 14
Level 14
Posts: 5399
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Can't install LMDE repos to Debian

Post by killer de bug »

vlad1777d wrote: icon themes (they are absent at Sid's repos, but without them I can't mark folders with different colors), package with wallpapers
If it's only this, then you are safe.
vlad1777d wrote:Every new Mint release new wallpapers are added to package.
Nope! A new package is create for each release with the name of the release!
vlad1777d wrote:I want to know: where is the problem
We cannot help you without proper information. And you pictures are not helpful.
First of all, please post plain text and not picture.

Second, please post the full list of repo you are using:

Code: Select all

inxi -r
The picture you have given doesn't show the proper file.
If it ain't broke, fix it until it is.

Locked

Return to “LMDE Archive”