How to maximize Minecraft video performance in old system

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
sarc
Level 1
Level 1
Posts: 2
Joined: Fri Oct 16, 2015 12:36 am

How to maximize Minecraft video performance in old system

Post by sarc » Fri Oct 16, 2015 1:04 am

Hello

I have no experience on Mint but I just installed as follows without a hitch. The only issue is that Minecraft video is a little slow/choppy, so I'm looking for ideas on how to improve:
HP DV 2000 notebook with NVidia GeForce go 7200
2GB RAM
Mint 17.2 Mate
Video driver NVidia 304.128
Original Minecraft.jar from Minecraft website; using single player mode

I start Minecraft as java -jar [path]Minecraft.jar

Some ideas:
- Change the Minecraft launch settings? (I think there's a way to define the launch parameters)
- Add more RAM? (system monitor does not show RAM as maxed out...)
- Tweak the NVidia XServer settings? (don't know how)
- Change to NVidia 173 driver? Edit: NOPE, just tried it, X crashed
- Download Oracle Java instead of using Mint's own Java? EDIT: tried it, it runs about the same
- Tweak the Compiz settings? (don't know what they do)
Edit: I just noticed that the 2 processors are running around 95% with Minecraft... could it just be that the processor is too old? Intel T2050 x 2 cores at 1.6 GHz seems OK..ish...


Thanks for any suggestions!

User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: How to maximize Minecraft video performance in old syste

Post by edwardr » Fri Oct 16, 2015 2:02 pm

Try changing some of the settings within minecraft. Start minecraft, start playing, then press F3 to see your frame rate (it will be the second line, a number followed by fps for frames per second). Then escape back out to the title window and go to "Options" then "Video Settings". Change Graphics to Fast. Change Smooth Lighting to Off. Turn Clouds to Off. Drop the Render Distance down, try 8 chunks. Change Particles to Decreased. Start playing your game again and hit F3 to see your frame rate.

If the game is playable, you can go back and edit some of the settings to get some more eye candy and find the sweet spot on your system between cool graphics effects and performance. Note that Render Distance can make a big difference.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true

sarc
Level 1
Level 1
Posts: 2
Joined: Fri Oct 16, 2015 12:36 am

Re: How to maximize Minecraft video performance in old syste

Post by sarc » Sun Oct 18, 2015 8:19 pm

Than you for your suggestions! I tried the changes you recommended and I'm getting 30FPS dropping to 2FPS whenever something interesting happens in the game, so my conclusion is... need to bite the bullet and buy a new machine! Cheers!

uberdorf
Level 4
Level 4
Posts: 238
Joined: Tue Sep 01, 2015 10:15 am

Re: How to maximize Minecraft video performance in old syste

Post by uberdorf » Fri Oct 23, 2015 7:18 pm

I think there are two issues with your computer. You could use some more RAM, and a better video card. I run Minecraft fine with the multitude of mods that my son installs on his Mint profile, here are my specs on the computer he uses:

1.6 GHz dual core CPU
4 GB RAM
Radeon R5450 video card (650 Mhz, 1GB RAM)
Oracle Java
proprietary stable driver
Mint XFCE 17.2
MultiMC manager for multiple minecraft profiles

When he uses more than 15 mods or so, then sometimes he has to wait a few seconds for the world to load. Also I encourage him to allow faster computers to host multiplayer games, but otherwise it runs smoothly.

foxtreat
Level 2
Level 2
Posts: 64
Joined: Thu Mar 24, 2016 6:44 am
Location: sofia

Re: How to maximize Minecraft video performance in old system

Post by foxtreat » Mon Mar 28, 2016 11:55 am

you have 4 gigs of ram
minecraft is configured to use only 1
there are plenty of tuttorials on youtube how to increase ram in minecraft,they work for linux too(just turn on java arguments and increase the ram from 1 to 2 ,more isnt recomended)
the proccesor is pretty weak for today's standards(everything less that 2.0 ghz is bad especialy dual-core for gaming theese days)
first turn of open-gl(it speeds up for me)
dont use VBOs as they dont speed up(for me that is)
graphics set from fancy to fast
set render to about 8 or less chunks
seet mipmaps to 0(or 1)THIS WILL LAG AS yOU CHANGE IT!but gives 2-3 extra fps for me
disable parcticles to minimal other than all or decreased
tweak these settings in the graphics menu
if you run with over than 30 fps(use f3 of shift+f3) you might want to increase render or enable back some options
check in youtube as windows and linux mc are pretty much the same!
Steam and Gaming bröther

User avatar
GreyGeek
Level 4
Level 4
Posts: 232
Joined: Thu Jan 14, 2016 11:01 pm
Location: Lincoln, NE

Re: How to maximize Minecraft video performance in old system

Post by GreyGeek » Mon Mar 28, 2016 12:23 pm

If you can't find a better driver for your Nvidia card then I suggest installing optifine for the version release of Minecraft that you are using. The version of optifine for Minecraft 1.9 is out in beta. I am running it on my old Acer and it raises my fps from 10-15 to 30-50. Of course, you can hit the ESC key in Minecraft and go to the "Options" button. There you will find the "Video Settings" button. Set "Graphics" to FAST, "View Bobbing" OFF. On the Quality and Performance buttons you can hover over the button and explanatory text will inform you as to the effect of the button. Make your choices.

Regardless, the active object that are in the chunk you are in (mobs, flowing water or lava, clouds, generally anything that causes motion) the slower the rendering will be.

Post Reply

Return to “Gaming on Linux Mint”