Excessively long shut down times

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
McLovin

Re: Excessively long shut down times

Post by McLovin »

that is an upstream bug from Ubuntu, I have installed all level 3 updates, and one of them fixes this, you may want to give that a try. If that doesn't help, there is a hack that works, but it is a dirty hack, so give the level 3 updates a first.

Just so you know, level 3 updates are generally safe, i have never seen issues with them.

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

McLovin wrote:that is an upstream bug from Ubuntu, I have installed all level 3 updates, and one of them fixes this, you may want to give that a try. If that doesn't help, there is a hack that works, but it is a dirty hack, so give the level 3 updates a first.

Just so you know, level 3 updates are generally safe, i have never seen issues with them.
I am experiencing slow shutdowns also. This condition only shows up after I add mount commands in my fstab file for samba shares. Mint-5 did not have this problem. The message I see is as follows:

Code: Select all

acpid: exiting

[1667.040027] CIFS VFS:SERVER NOT RESPONDING
[1667.040072] CIFS VFS:NO RESPONSE FOR CMD 50 MID 2177
The instructions suggested Windows XP or better, so I installed Linux :)

nelamvr6
Level 4
Level 4
Posts: 327
Joined: Sun Jul 08, 2007 8:14 pm
Location: New London, CT USA

Re: Excessively long shut down times

Post by nelamvr6 »

When I first installed Felicia on my Dell I had problems with hanging on shutdown. I use the nosplash option so I was able to see that the problems had something to do with alsa shutting down.

I did some digging and discovered a fix, putting ifconfig wlan0 down at the beginning of stop in: /etc/init.d/alsa-utils.

Then I ran the updates and there was an update modifying that same file.

And so I guess what I'm saying is there appears to have been a bug in the alsa-utils file which has been addressed by an update.

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

Is this considered a bug? If so, is there an official post for bug fixes for Mint-6 final?
The instructions suggested Windows XP or better, so I installed Linux :)

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

Jace wrote:An update for everybody-

I installed all the level 3 updates and have not had a problem since.
Updating does not solve the problem I posted about. So is this a bug? Where can I report it?
The instructions suggested Windows XP or better, so I installed Linux :)

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

I would appreciate some feedback from the Mint team on this issue. This is a showstopper for me to upgrade to Mint-6.

Thanks.
The instructions suggested Windows XP or better, so I installed Linux :)

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

BUMP
The instructions suggested Windows XP or better, so I installed Linux :)

McLovin

Re: Excessively long shut down times

Post by McLovin »

On a samba share I really don't know, I have never tried to automount a samba share, only an nfs share. Is the samba share on your system, or a remote one?

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

McLovin wrote:On a samba share I really don't know, I have never tried to automount a samba share, only an nfs share. Is the samba share on your system, or a remote one?
It is on a different system on my local network. This works fine in previous versions of Mint. I did notice it when I tried Mint-5 KDE but it is not present in Mint-5 Gnome.
The instructions suggested Windows XP or better, so I installed Linux :)

McLovin

Re: Excessively long shut down times

Post by McLovin »

so, the remote drive is on a windows system, right? I am asking because if it is on a linux system, you should really use NFS, its alot faster, and native.

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

McLovin wrote:so, the remote drive is on a windows system, right? I am asking because if it is on a linux system, you should really use NFS, its alot faster, and native.
The server is a Mint-5 system. I have to use samba because I have a mixture of Linux & Windoze machines.
The instructions suggested Windows XP or better, so I installed Linux :)

McLovin

Re: Excessively long shut down times

Post by McLovin »

thats fine, but you do not need to mount samba shares in another linux distro, if you are doing linux to linux use nfs, it is much better for that purpose, you do not need to use samba on the host machine, only the server. I use samba on my server, as i have windows installed on one of my partitions, but in linux i use all nfs, so my server is running nfs, and samba, but my linux hosts are running only nfs. there are alot of great tutorials on how to set-up nfs so that your network, (nfs) shares automount on boot, and your shares also automount on windows with samba. if you need more help, I can help you out, as this is how my server is configured, just let me know.

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

McLovin wrote:thats fine, but you do not need to mount samba shares in another linux distro, if you are doing linux to linux use nfs, it is much better for that purpose, you do not need to use samba on the host machine, only the server. I use samba on my server, as i have windows installed on one of my partitions, but in linux i use all nfs, so my server is running nfs, and samba, but my linux hosts are running only nfs. there are alot of great tutorials on how to set-up nfs so that your network, (nfs) shares automount on boot, and your shares also automount on windows with samba. if you need more help, I can help you out, as this is how my server is configured, just let me know.
The point is that Mint-6 or Ubuntu has broken something that worked in the previous release. In fact I have been using Samba on my network in this manner since my first Linux install of Fedora-4 years ago. I wanted to bring this issue to the Mint team and was hoping for an explanation of the problem. If NFS is my only option then I will pursue it.
The instructions suggested Windows XP or better, so I installed Linux :)

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

Any comment from the developers would be appreciated.

Thanks
The instructions suggested Windows XP or better, so I installed Linux :)

kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Excessively long shut down times

Post by kwisher »

After digging around on the Ubuntu forum I believe I have found the solution to this problem. The thread is here:
http://ubuntuforums.org/showthread.php?t=293513

I guess it boils down to a blame game between the init dev's and the samba dev's at Debian. The cifs driver does not unmount the samba shares before the network shuts down. To fix the problem enter the following commands from a terminal as root:

Code: Select all

ln -s /etc/init.d/umountnfs.sh /etc/rc0.d/K15umountnfs.sh
ln -s /etc/init.d/umountnfs.sh /etc/rc6.d/K15umountnfs.sh
Hope this helps.
The instructions suggested Windows XP or better, so I installed Linux :)

User avatar
tawan
Level 4
Level 4
Posts: 401
Joined: Thu Apr 03, 2008 2:45 am
Contact:

Re: Excessively long shut down times

Post by tawan »

Jace wrote:Just booted Felicia and I have noticed that it takes a long time to shut down my system..

From the time I click "Shut Down," watch the splash screen and another blank screen with a blinking cursor in the top left; until my computer is completely off it's been 2 minutes. Just seems like a long time to shut down doesn't it?

Is it a Felicia thing, or is it just me?

BTW, I've updated all level 2 updates available and I am currently trying to install proprietary video card drivers.
Solution from here:

Code: Select all

gksudo gedit /etc/init.d/alsa-utils
The file opens in Gedit and around the line 353 you'll find the instruction "stop)". Below this instruction you should add these two instructions:

ifconfig wlan0 down
ifconfig eth0 down

So, the file should be this way:

stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

---

That fixed the problem for me and others.

...

Post Reply

Return to “Newbie Questions”