Prevent program from autostarting

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 7:43 am

I am running LInux MInt 17.3. I can find no startup folder in System Settings or anywhere else. I am trying to prevent PSensor from autostarting. Is there any way to do it other than uninstalling the program?

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Prevent program from autostarting

Post by Cosmo. » Wed Jul 06, 2016 7:47 am

Open the startup program settings and disable psensor. (It adds itself automatically there.)

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 8:00 am

I see no such settings. However, I think I may have found the autostart in ./etc/xdg/autostart. I did a find for anything called "autostart". About to reboot to try it.

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 8:13 am

Yep, removing the .desktop file from ./etc/xdg/autostart (as root) did the trick. It seems there should be a more straightforward way to add or remove programs from autostarting than to have to search the system. But anyway, it worked.

User avatar
Moem
Level 19
Level 19
Posts: 9350
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Prevent program from autostarting

Post by Moem » Wed Jul 06, 2016 8:18 am

It would be about 10 x easier to help you if you'd mentioned your desktop environment. There is very likely a more straightforward way to add or remove programs from autostart, but we can't direct you there without knowin that.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 8:25 am

Sorry, KDE 4.14.2. But in looking at System Settings I can find nothing related to autostart.

User avatar
Moem
Level 19
Level 19
Posts: 9350
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Prevent program from autostarting

Post by Moem » Wed Jul 06, 2016 8:28 am

Sorry, I know nothing about KDE. Apparently it's not in System Settings then, so it'll be somewhere else. Does KDE have a search box in the menu that you can type 'startup' in?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 8:35 am

Ah, yes. I had never thought to search there. I was just using find in konsole. Got it. Thanks.

altair4
Level 19
Level 19
Posts: 9715
Joined: Tue Feb 03, 2009 10:27 am

Re: Prevent program from autostarting

Post by altair4 » Wed Jul 06, 2016 8:41 am

Menu > System Settings > Startup and Shutdowwn:
KDE-AutoStart.png
Don't know if your particular application is in the Autostart subsection or in the Session Management section or if it's a system wide default.

I am not a KDE user and I would suspect that KDE users are in the minority in this forum as they are in the Ubuntu forum so what you might want to do is put the fact that you are in your signature so that when you ask a question the folks here know.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 9:20 am

I had looked in the Autostart subsection but didn't see the program listed. Maybe it should have been put there initially when autostart was desired, in which case removing it would probably have disabled autostart. Thanks for your help.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Prevent program from autostarting

Post by Cosmo. » Wed Jul 06, 2016 10:38 am

RVDowning wrote:I think I may have found the autostart in ./etc/xdg/autostart
This path - with the leading dot - does not make sense. In case you mean /etc/xdg/autostart (without the dot): This is not the place, where you should play with.

RVDowning
Level 1
Level 1
Posts: 34
Joined: Thu Oct 01, 2015 2:27 pm

Re: Prevent program from autostarting

Post by RVDowning » Wed Jul 06, 2016 2:39 pm

Well, it was the only autostart folder where I found the program, a .desktop file, so I removed it and all is well. I don't know what program puts stuff there.

Post Reply

Return to “Software & Applications”