How to disable GUI Network Manager?

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
mattlach
Level 3
Level 3
Posts: 135
Joined: Mon May 30, 2011 8:34 pm

How to disable GUI Network Manager?

Post by mattlach » Thu Jul 07, 2016 4:33 pm

Hey all,

I tried to uninstall the package, but it wants to remove all of Cinnamon if I do.

I always manually manage all my networking configurations manually in /etc/network/interfaces

In 17.x I could just do this. nm-applet would complain that I was not connected to the network, but other than that, once I defined my interfaces in /etc/network/interfaces it worked.

(I eventually created a script that ran on login and killed nm-applet so I didn't have to look at that disconnected icon all the time)

Now in 18 this does not appear to work right. I defined my complicated bonded setup in /etc/network/interfaces, and it appeared to work. Using ifenslave I had two interfaces up bonded using 802.3ad. Everything worked, EXCEPT, for whatever reason, it was not able to resolve DNS entries, despite the correct DNS being defined using the dns-nameservers line for the correct DNS server.

Eventually I got it working in the GUI configuration (apparently the network manager supports bonding with ifenslave now, which cool), but I would have much preferred to just use my config file. Is there any way I can just completely remove the network GUI setup features, and still keep Cinnamon, while using my old configuration files?


On a side note, I can understand why all this stuff is going GUI to help the beginners out there, but these GUI setups need to be 100% compatible with the old way of doing things with config files. For those who have enough experience to overcome the fear of the terminal that beginners often have, configuring things in a nice searchable text file in /etc/ will always be superior to hunting and pecking through an inefficient menu system in some desktop application.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon E5-2650v2, 256GB RAM, 120TB ZFS

mattlach
Level 3
Level 3
Posts: 135
Joined: Mon May 30, 2011 8:34 pm

Re: How to disable GUI Network Manager?

Post by mattlach » Thu Jul 07, 2016 6:10 pm

mattlach wrote: Eventually I got it working in the GUI configuration (apparently the network manager supports bonding with ifenslave now, which cool), but I would have much preferred to just use my config file.
Actually, let me take part of this back.

I can get it to work, but the bond defaults to "off" on every boot, meaning that I have to wait forever for the system to boot and when it finally boots, I have to mount all my NFS shares in /etc/fstab manually... This is an enormous pain in the butt, so I would not consider this to be "working" right now.

For some reason, although I set up the bond inside the GUI network manager, it insists it is "Unmanaged" and thus defaults to "off". Once I go in to network settings and click the "on/off" button, everything works though. I just can't get it to work on boot.

See below (click for larger)

Image

Does anyone know what might fix this? Ideally I'd just shut the whole GUI network manager completely off, and manage everything from /etc/network/interfaces, but if that doesn't work, I'd appreciate any other suggestions. If I can't find a fix for this, I may just stick with 17.3.

It's starting to feel like the Linux Mint 18 release has an unusually large number of issues. Maybe they should have waited longer before releasing...
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon E5-2650v2, 256GB RAM, 120TB ZFS

murdock72
Level 1
Level 1
Posts: 11
Joined: Sat Feb 01, 2014 4:06 am

Re: How to disable GUI Network Manager?

Post by murdock72 » Sun Jul 10, 2016 7:30 am

I follow this with interest, since I have a similar problem - conflict between cli config and the gui manager...

mattlach
Level 3
Level 3
Posts: 135
Joined: Mon May 30, 2011 8:34 pm

Re: How to disable GUI Network Manager?

Post by mattlach » Sun Jul 10, 2016 12:10 pm

Yeah,

For ifenslave I'm still having to choose between using the GUI and getting no network at boot, getting really long boot times and no network filesystem mounts at boot or using /etc/network/interfaces and not being able to resolve domain names.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon E5-2650v2, 256GB RAM, 120TB ZFS

JeremyB
Level 20
Level 20
Posts: 11121
Joined: Fri Feb 21, 2014 8:17 am

Re: How to disable GUI Network Manager?

Post by JeremyB » Sun Jul 10, 2016 12:36 pm

In LM 18 try the following to see if it will disable network manager

Code: Select all

systemctl disable NetworkManager.service
If it causes ill effects

Code: Select all

systemctl reenable NetworkManager.service

mattlach
Level 3
Level 3
Posts: 135
Joined: Mon May 30, 2011 8:34 pm

Re: How to disable GUI Network Manager?

Post by mattlach » Sun Jul 10, 2016 3:55 pm

JeremyB wrote:In LM 18 try the following to see if it will disable network manager

Code: Select all

systemctl disable NetworkManager.service
If it causes ill effects

Code: Select all

systemctl reenable NetworkManager.service
Thank you,

That did do the trick! Now networking works properly on boot with /etc/network/interfaces, AND I also have DNS resolution!

Now, if I could only figure out my intermittent "log in to black screen with mouse pointer and two CPU cores pinned" in Cinnamon, I could go from having Mint 18 installed side by side with 17.3, to actually using it as my primary OS.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon E5-2650v2, 256GB RAM, 120TB ZFS

JeremyB
Level 20
Level 20
Posts: 11121
Joined: Fri Feb 21, 2014 8:17 am

Re: How to disable GUI Network Manager?

Post by JeremyB » Sun Jul 10, 2016 4:08 pm

Your other problem will likely require a newer kernel to fix. Use the Update Manager, click View/Linux kernels and see if using 4.4.0-28 fixes that

For LM17, see if the following comman disables network manager

Code: Select all

sudo mv /etc/init/network-manager.conf /etc/init/network-manager.conf-disabled
sudo mv /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/nm-applet.desktop.disabled
It is from an older post but I think it should work from what I have read in the past
Last edited by JeremyB on Sun Jul 10, 2016 4:16 pm, edited 1 time in total.

mattlach
Level 3
Level 3
Posts: 135
Joined: Mon May 30, 2011 8:34 pm

Re: How to disable GUI Network Manager?

Post by mattlach » Sun Jul 10, 2016 4:16 pm

JeremyB wrote:Your other problem will likely require a newer kernel to fix. Use the Update Manager, click View/Linux kernels and see if using 4.4.0-28 fixes that

For LM17, see if the following comman disables network manager

Code: Select all

sudo mv /etc/init/network-manager.conf /etc/init/network-manager.conf-disabled
It is from an older post but I think it should work from what I have read in the past

Thank you. I'm already on the latest kernel (28), and still having the black screen issue.

In LM17 I didn't need to disable Network Manager, as it didn't interact with the manual configuration. Biggest issue I had in 17 was that the NM applet would cxonstantly show a red disabled symbol, which was annoying, so I just added a startup script that did a killall on the applet at login.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon E5-2650v2, 256GB RAM, 120TB ZFS

JeremyB
Level 20
Level 20
Posts: 11121
Joined: Fri Feb 21, 2014 8:17 am

Re: How to disable GUI Network Manager?

Post by JeremyB » Sun Jul 10, 2016 4:17 pm

mattlach wrote:
JeremyB wrote:Your other problem will likely require a newer kernel to fix. Use the Update Manager, click View/Linux kernels and see if using 4.4.0-28 fixes that

For LM17, see if the following comman disables network manager

Code: Select all

sudo mv /etc/init/network-manager.conf /etc/init/network-manager.conf-disabled
It is from an older post but I think it should work from what I have read in the past

Thank you. I'm already on the latest kernel (28), and still having the black screen issue.

In LM17 I didn't need to disable Network Manager, as it didn't interact with the manual configuration. Biggest issue I had in 17 was that the NM applet would cxonstantly show a red disabled symbol, which was annoying, so I just added a startup script that did a killall on the applet at login.
Murdoch is watching this thread and may be using LM17

User avatar
mik007san
Level 1
Level 1
Posts: 7
Joined: Sat Sep 29, 2018 4:11 pm
Location: Oklahoma

Re: How to disable GUI Network Manager?

Post by mik007san » Sun Nov 17, 2019 9:58 am

:D Just Finished a looooong day and it paid off! I got excellent results in bonding two (2) 1 Gib NICs on my MINIS FORUM U500-H Mini PC. It has been modifies with 16GB DDR3L 1600 SODIMM RAM. The mini PC comes with a 128GB SSD drive, 8GB (16GB Max) of expandable RAM, and an Intel Core i3-5005U Processor. I hand to hand wrestle/eradicate/fdisk/gpart the installed Win10 OS off the system before loading LMv19.2. In the following example, I use bonding mode "zero", which also known as round-robin. For me I like faster fault-tolerant through-put over redundancy. After all this is a home-office and not the FBI. These are the steps taken to bond these two NICs:

Preset: If you have an older release of Linux Mint, which is sans bonding, install "ifenslave" and install the bonding kernel module via 'modprobe bonding'. Later versions, including Linux Mint 19.2, do not require this step, since bonding is included. Continuing....

1. Check the Ethernet interface names you wish to using "sudo ifconfig -a". There must be at least two interfaces in order to create a bond (duh). Newer versions of Debian/Ubuntu/Linux Mint use 'enpXs0' (where X is a number) NIC identifiers instead of the old-timey 'ethX'. In this example, I'll use enp3s0 and enp4s0 as my two NIC identifiers.

2. Edit the "/etc/network/interfaces" file. Here, I use "sudo vim /etc/network/interfaces" - You may use your choice of editor.

3. I replace whatever exists with the following:
NOTE: Brackets '[......]' signify your environment - your choice. Just make sure that the
network/mask/gateway, your domain name and DNS are correct!


auto lo
iface lo inet loopback
#
# Network Bonding Interface
#
auto bond0
iface bond0 inet static
address [......]
netmask [......]
gateway [......]
dns-nameservers 64.6.64.6 8.8.8.8 [......]
dns-search [......].local
#
# Using 'Round Robin' (mode 0) for load-balancing and fault tolerance
#
slaves enp3s0 enp4s0
bond_mode 0
bond-miimon 100
bond_downdelay 200
bond_updelay 200
#
# Interface enp3s0
#
auto enp3s0
iface enp3s0 inet manual
bond-master bond0
#
# Interface enp4s0
#
auto enp4s0
iface enp4s0 inet manual
bond-master bond0

4. Save file - In vim's case, '<esc> wq!'

5. There is a bug in the operating system, in which the "GUI Network Manager service" (which provides the little network tray icon, et AL.) conflicts/prevents Ethernet NIC bonding. So run 'sudo systemctl disable NetworkManager.service' BEFORE....

.6. Reboot

And that's about it. I also have bash scripts for "persistent iptables" and switching between GUI and command prompt - but his is not the forum for that. I hope this helps someone same some hours of frustration and time implementing a bonded network interface. :wink:
God, make me the kind of person my dog thinks I am.

Post Reply

Return to “Ethernet”