Nvidia Geforce 7600 GS won't work with Glest

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Nvidia Geforce 7600 GS won't work with Glest

Post by Husse »

the monitor becomes "Out of Range".
This is well known in Windows as well (and I suspect Mac) It is because the game takes over the settings for video and is not handling them well
For starters as you only have one monitor you should do a bit of editing

Code: Select all

gksu gedit /etc/X11/xorg.conf

Code: Select all

Option "DynamicTwinView" "False"
to Section "Device"
There is only one section called that. This should give you 60 or 75 Hz which are the default for LCD monitors and hopefully make the risk for out of range smaller
And have you installed the proprietary driver for the card? If not that's the basic explanation - use envy to do it. In Felicia you have to start envy from the terminal.
Installed by envy you can use

Code: Select all

gksu nvidia-settings
The restricted drivers tool does not install nvidia-settings I think
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 13
Joined: Sun Feb 25, 2007 2:48 pm

Re: Nvidia Geforce 7600 GS won't work with Glest

Post by olefudd »

I'm having a similar problem trying to play Open Arena. Running a Geforce 7300 and a LG Flatron 1952TQ. This is on Mint 5, and I've been experiencing hard lockups. I installed the Nvidia drivers using Envy. I recently replaced my old analog monitor with this one and didn't have these problem before. Actually I'm having the same problem with most of the 3D games that used to run fine with my old monitor. I tried adding the line to my xorg.conf file suggested by Husse in a previous post but still no joy.

Post Reply

Return to “Graphics Cards & Monitors”