Mint 18 and time issue (Solved)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Locked
User avatar
Lumikki
Level 4
Level 4
Posts: 232
Joined: Wed Feb 01, 2012 5:21 pm

Mint 18 and time issue (Solved)

Post by Lumikki » Tue Aug 02, 2016 12:37 am

Hi!

I seem to have issue to get computer time correct when using networktime (internet). It seems that for some reason Mint 18 is using UTC time when it should use local time. If I choose my local timezone +3 and then use get time from internet, time is UTC after computer is rebooted. Only way to get correct time in my computer is use wrong timezone or not allow computer get time from internet. Of cause using wrong timezone then cause calendar issue as weeks first day doesn't work correctly. Meaning if local timezone has sunday as first day of week. If I chose monday for first, it has no affect at all.

Anyone know what's causing this or how to fix it?
Last edited by Lumikki on Thu Aug 04, 2016 2:00 am, edited 1 time in total.
Asus P7P55D, i5 750 2.6Ghz, 4GB DDR3, GeForce 750Ti, 80GB Intel SSD, Dell 1600x1200, Dual boot, Linux Mint 18 Cinnamon, Windows 7

User avatar
xenopeek
Level 24
Level 24
Posts: 24096
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 18 and time issue

Post by xenopeek » Tue Aug 02, 2016 1:46 am

Lumikki wrote:for some reason Mint 18 is using UTC time
That's the default and recommended to be used. But indeed Windows can't handle it/the truth. Your hardware clock will flip out every time you switch from Windows to Linux Mint or vice versa, as the one is using local time and the other is using UTC.

You'll have to switch Linux Mint to use local time. On Linux Mint 18 and above you do this with the command: timedatectl set-local-rtc 1 (on earlier version of Linux Mint you'd have to edit the file /etc/default/rcS but that won't work on Linux Mint 18). It will not reply anything unless there is a problem.

(If you're not an administrator you will need to prefix the command with sudo, so sudo timedatectl set-local-rtc 1 would be the command to use then.)

You can confirm the change was done by running grep LOCAL /etc/adjtime and that should reply "LOCAL".

With the system set to local time you should be aware (RTC = real-time clock, your hardware clock):
Warning: The system is configured to read the RTC time in the local time zone. This mode can not be fully supported. It will create various problems with time zone changes and daylight saving time adjustments. The RTC time is never updated, it relies on external facilities to maintain it. If at all possible, use RTC in UTC by calling 'timedatectl set-local-rtc 0'.
Image

blockhead47
Level 2
Level 2
Posts: 85
Joined: Wed Jun 15, 2016 4:50 pm
Location: Chicago, IL, USA

Re: Mint 18 and time issue

Post by blockhead47 » Tue Aug 02, 2016 11:34 am

To fix it on the Windows side see @Cosmo's reply to this issue:

viewtopic.php?f=90&t=224183&p=1181583&h ... l#p1181583

rene
Level 12
Level 12
Posts: 4152
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 and time issue

Post by rene » Tue Aug 02, 2016 12:27 pm

xenopeek wrote:It will ask for your password to authorize the change
But only if you not just leave out the "sudo" ...

Administrator-level users, such as the default and often one and only Mint user, are granted the set-local-rtc privilege through PolicyKit. I wondered if I was looking at a privilege escalation bug first time I noticed this working without sudo, and this comment added just to help future googlers not wonder similarly. It's by design.

User avatar
xenopeek
Level 24
Level 24
Posts: 24096
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 18 and time issue

Post by xenopeek » Tue Aug 02, 2016 12:33 pm

Thanks. Something new learned. Edited my post.
Image

mattlach
Level 3
Level 3
Posts: 133
Joined: Mon May 30, 2011 8:34 pm

Re: Mint 18 and time issue

Post by mattlach » Wed Aug 03, 2016 11:53 pm

xenopeek wrote: You'll have to switch Linux Mint to use local time. On Linux Mint 18 and above you do this with the command: timedatectl set-local-rtc 1 (on earlier version of Linux Mint you'd have to edit the file /etc/default/rcS but that won't work on Linux Mint 18). It will not reply anything unless there is a problem.
Thank you for this! I edited /etc/default/rcS and couldn't figure out why it wasn't working like before.

I don't understand why they have to keep changing things from the way they've always been...

Pretty soon we won't even be able to use /etc/fstab to mount stuff at boot anymore :p

I LIKE using:
/etc/fstab for file system mounts,
/etc/network/interfaces to configure my network settings
/etc/modules to define which modules load on boot
etc.
etc.


The best way to configure anything is via a commented editable text file, not some GUI junk or command line tool. I wish they'd just leave everything alone :p The best function is that of Ubuntu 12.04 and 14.04 server release ISO's, where everything can be configured this way.

It's bad enough that my NIC's are now eno1 and enp10s0 instead of eth0 and eth1...
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Laptop: Dell E7470, Core i7-6600u, 8GB
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon L5640, 192GB RAM, 120TB ZFS

Felim_Doyle
Level 1
Level 1
Posts: 11
Joined: Sat Dec 07, 2013 4:40 am
Location: Aylesbury, Buckinghamshire, UK
Contact:

Re: Mint 18 and time issue (Solved)

Post by Felim_Doyle » Mon Jul 02, 2018 9:20 am

Is there no GUI solution to this problem?

Can DST not be corrected from Date & Time (without selecting an incorrect locale)?

It's not very intuitive for newcomers to Linux and things like this which require editing system files and using root permissions are likely to put potential users off migrating to Linux. I built Linux Mint 17.2 Live on a USB stick yesterday only to discover that it didn't have Wi-Fi support built in. When I tried using Device/Driver Manager to install the missing drivers there were none present. At least I had a wired Ethernet connection to allow me to research the issue but non-technical users would have been stumped. In the end, I decided to go with 18.3 Sylvia but, if the process is not for the faint-hearted, the faint-hearted will drop Linux in despair!

P.S. I agree about network device naming. I was pleasantly surprised that Linux Mint 17.2 used eth0 just like the good old days :) but then it reverted to enp7s0 and wlp13s0 when I installed Linux Mint 18.3. :?
Félim Doyle
Wings Computer Services Ltd.
Aylesbury, Buckinghamshire, UK

rene
Level 12
Level 12
Posts: 4152
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 and time issue (Solved)

Post by rene » Mon Jul 02, 2018 10:03 am

Felim_Doyle wrote:
Mon Jul 02, 2018 9:20 am
It's not very intuitive for newcomers to Linux and things like this which require editing system files and using root permissions are likely to put potential users off migrating to Linux.
If this had been a forum for most any other Linux distribution the comment at this point would have been
No, it's likely to put potential wankers off migrating to Linux.
This is however not a forum for most any other Linux distribution...

User avatar
Pierre
Level 19
Level 19
Posts: 9049
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Mint 18 and time issue (Solved)

Post by Pierre » Mon Jul 02, 2018 10:20 am

Note that it's not just for that Windows System - either,
as I've struck the same issue when multi_booting various Linux Systems.
IE: they All have to use Local Time
:)
and LinuxMint is one of those that doesn't use Local Time.
:(
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Locked

Return to “Newbie Questions”