Problem with 367.57 nvidia driver [solved]

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
tygrysuav
Level 1
Level 1
Posts: 10
Joined: Thu Mar 31, 2016 1:57 pm

Problem with 367.57 nvidia driver [solved]

Post by tygrysuav » Sat Nov 05, 2016 5:28 am

I have installed new nvidia drivers (ver. 367.57) and now while booting I'm getting this notification:

failed to execute /bin/systemctl stop --no-block nvidia.persistenced.service no such file or directory

After that system starts normally and it seems that it uses drivers mentioned above. I still think that something isn't right but I don't know what exactly. It has something to do with graphic card right? Does anyone know how to fix this bug?

Linux Mint 17.3 Cinnamon NVidia GeForce GTX 960.
Last edited by tygrysuav on Sat Nov 05, 2016 8:51 am, edited 1 time in total.

User avatar
Pjotr
Level 21
Level 21
Posts: 13744
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Problem with 367.57 nvidia driver

Post by Pjotr » Sat Nov 05, 2016 5:36 am

Probably an innocent message. Linux is generally much more "honest" with reporting errors than some other operating systems: it reports them even when they have no negative impact.

As long as you can boot normally with the expected good end result, you're fine. :)

This should show whether the new driver is operational:

- Launch a terminal window (this is how to launch a terminal window);

- make the terminal window full screen, to avoid chopped lines;

- copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

tygrysuav
Level 1
Level 1
Posts: 10
Joined: Thu Mar 31, 2016 1:57 pm

Re: Problem with 367.57 nvidia driver

Post by tygrysuav » Sat Nov 05, 2016 7:19 am

Pjotr wrote:Probably an innocent message. Linux is generally much more "honest" with reporting errors than some other operating systems: it reports them even when they have no negative impact.

[...]

- copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
Well, it has worked for me as I scared. :)

I used the command You mentioned. Here are results (graphics only):

Code: Select all

Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 01:00.0
           Display Server: X.Org 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1680x1050@59.9hz
           GLX Renderer: GeForce GTX 960/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 367.57 Direct Rendering: Yes
Some services seems not to load but I'm not sure if those are really important.

User avatar
Pjotr
Level 21
Level 21
Posts: 13744
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Problem with 367.57 nvidia driver

Post by Pjotr » Sat Nov 05, 2016 7:33 am

This output is entirely OK. Such output is normal when the Nvidia driver has been installed.

This, for example, is the output on my machine:

Code: Select all

Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 210/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.98 Direct Rendering: Yes
So it's fine: your video card is running on the right driver. All looks well. :)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

tygrysuav
Level 1
Level 1
Posts: 10
Joined: Thu Mar 31, 2016 1:57 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by tygrysuav » Sat Nov 05, 2016 8:50 am

Thanks for the help. So the problem is solved and this topic can be closed.

jackcq
Level 2
Level 2
Posts: 52
Joined: Tue Oct 11, 2016 12:35 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by jackcq » Wed Nov 09, 2016 9:20 am

Hmm okay, I have the same issue, while the driver itself works fine,
I still wonder if the error message can turned off? Obviously, the driver wants
to run some persistence-service that's no longer included in the 367.57 driver?
systemd-udevd[859]: failed to execute '/bin/systemctl' '/bin/systemctl start --no-block nvidia-persistenced.service': No such file or directory
systemd-udevd[868]: failed to execute '/bin/systemctl' '/bin/systemctl stop --no-block nvidia-persistenced': No such file or directory
Perhaps it can be turned off via systemd?

tygrysuav
Level 1
Level 1
Posts: 10
Joined: Thu Mar 31, 2016 1:57 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by tygrysuav » Thu Nov 10, 2016 1:02 pm

Is it possible to run systemd in Mint? I've tried to run it and failed ("command not found"). It looks like there is no systemctl or systemd on my computer or I can't find it.

Atypical User
Level 1
Level 1
Posts: 25
Joined: Fri Nov 04, 2016 3:12 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by Atypical User » Fri Nov 11, 2016 7:10 am

jackcq wrote:I still wonder if the error message can turned off?
Are you also on LM 17.3 with Cinnamon? Have you tried sudo dpkg-reconfigure mdm yet?

You could look through the service startup folders for references to /bin/systemctl. I'd start with searching the /etc/init/*.conf files for systemctl: grep systemctl /etc/init/*.conf. I've looked through other folders like /etc/init.d/* and /etc/rc*.d/*. The only persistenced reference I've found after deleting the Nvidia driver was this:

Code: Select all

/etc/init/nvidia-prime.conf:        /usr/bin/start-nvidia-persistenced
tygrysuav wrote:Is it possible to run systemd in Mint?
As I understand things, there is a transition currently taking place moving from Upstart init to systemd in Linux Mint.
Linux Mint 18.2 x86_64, Cinnamon 3.4.6 on kernel 4.10

jackcq
Level 2
Level 2
Posts: 52
Joined: Tue Oct 11, 2016 12:35 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by jackcq » Fri Nov 11, 2016 12:17 pm

Atypical User wrote:Are you also on LM 17.3 with Cinnamon? Have you tried sudo dpkg-reconfigure mdm yet?
Yes and no, I'm on LM 17.3 with XFCE. I'm having no issues with mdm or the driver itself working,
it's just this error message during bootup.
Atypical User wrote: You could look through the service startup folders for references to /bin/systemctl. I'd start with searching the /etc/init/*.conf files for systemctl: grep systemctl /etc/init/*.conf. I've looked through other folders like /etc/init.d/* and /etc/rc*.d/*. The only persistenced reference I've found after deleting the Nvidia driver was this:

Code: Select all

/etc/init/nvidia-prime.conf:        /usr/bin/start-nvidia-persistenced
I think I misinterpreted the problem. I migrated from Fedora to Linux Mint relatively recently and
I kinda just assumed that Mint, like Fedora, had migrated to systemd long ago. I think the problem
is as follows: since the 367.x update the nvidia driver comes with a persistence-demon
(see http://docs.nvidia.com/deploy/driver-pe ... index.html ) and it looks like it's configured
to start via systemd, which does not work with Mint, because it doesn't use systemd (yet). I'm not
sure, if there's any performance impact when not running nvidia-persistenced, the driver itself seems
to work fine for me. I can run it manually by using the command in "/lib/systemd/system/nvidia-persistenced.service"
and running: "/usr/bin/nvidia-persistenced --user nvidia-persistenced --no-persistence-mode --verbose", so maybe the
sysinit script could be adjusted?

Atypical User
Level 1
Level 1
Posts: 25
Joined: Fri Nov 04, 2016 3:12 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by Atypical User » Sat Nov 12, 2016 3:43 am

jackcq wrote:I'm having no issues with mdm or the driver itself working
I probably had no (real) issues with mdm either. The driver was another matter. It might be that the 4.4 kernel I am now using is generally associated with systemd, so the driver installed routines that are unusable on my system. (Sound familiar?) And I wasn't even using the Nvidia drivers at all; I do not currently have a discrete video card installed, choosing to rely on the on-board Intel graphics. (The previous Nvidia 361 drivers caused no trouble just being there.)
jackcq wrote:so maybe the sysinit script could be adjusted?
The reason I suggested that you grep your services configuration files is that you might just see where it is being executed. The reason I suggested running sudo dpkg-reconfigure mdm (if your DE uses mdm) is that it can safely remove services cruft relating to the video support that should not be there. Run it in a terminal and see what it reports that it fixes. I did. Others did. Search this forum and see.

When I ran it, I was surprised when it actually found something amiss, a couple of irrelevant services. I can't be certain at this late date, but it might have been the same commands reported here.

If you don't want to run that command, you might be able to simply move/remove/rename the configuration files that reference systemctl. You don't even need to run as admin to see if any references are there.

Also: "--no-persistence-mode" suggests the service just starts and does some housekeeping, then quits.
Linux Mint 18.2 x86_64, Cinnamon 3.4.6 on kernel 4.10

User avatar
Pjotr
Level 21
Level 21
Posts: 13744
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Problem with 367.57 nvidia driver [solved]

Post by Pjotr » Sat Nov 12, 2016 5:48 am

Atypical User wrote:The reason I suggested that you grep your services configuration files is that you might just see where it is being executed. The reason I suggested running sudo dpkg-reconfigure mdm (if your DE uses mdm) is that it can safely remove services cruft relating to the video support that should not be there. Run it in a terminal and see what it reports that it fixes. I did. Others did. Search this forum and see.

When I ran it, I was surprised when it actually found something amiss, a couple of irrelevant services. I can't be certain at this late date, but it might have been the same commands reported here.
Interesting. :)

Out of sheer curiosity I ran that command on my test rig with Mint 18 Xfce (cleanly installed system), even though nothing is wrong with it and even though it has only an Intel video card. It's just a test rig, so no harm done in any case....

To my surprise, it reported something like "upstart detected" and that it removed some rc.d links. Also it mentioned that it shifted (from or to, can't remember) gdm-mdm (or something like that). That puzzled me, but apparently nothing was damaged: I rebooted and noticed no differences.

After the reboot I realized that of course I should have preserved the output before rebooting.... :P

I wonder if I can re-create the original situation by removing and re-installing mdm?

--- Edit: I took the plunge:

Code: Select all

sudo apt-get purge mdm && sudo apt-get install mdm
Then I rebooted. All was well, except that automatic login had to be re-enabled (previous setting disappeared in the purge).

Then I did the reconfiguring again:

Code: Select all

sudo dpkg-reconfigure mdm
This was the output:

Code: Select all

pjotr@Aspire-E3-111 ~ $ sudo dpkg-reconfigure mdm
[sudo] wachtwoord voor pjotr: 
Upstart detected. Removing rc.d links.
Linking /usr/bin/gdmflexiserver to /usr/bin/mdmflexiserver
pjotr@Aspire-E3-111 ~ $ 
Now that I have reproduced the exact outcome, I wonder what effects it has on the system (noticed nothing yet).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Atypical User
Level 1
Level 1
Posts: 25
Joined: Fri Nov 04, 2016 3:12 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by Atypical User » Sat Nov 12, 2016 6:23 pm

Pjotr wrote:To my surprise, it reported something like "upstart detected" and that it removed some rc.d links. Also it mentioned that it shifted (from or to, can't remember) gdm-mdm (or something like that). That puzzled me, but apparently nothing was damaged: I rebooted and noticed no differences.
Thanks for taking the trouble to extensively research this, Pjotr. It appears that the "fixes" might not have anything to do with the Nvidia changes to the service starts.

I didn't see any differences in operation either. I don't know if it actually removed any startup services, Nvidia or otherwise. My Xorg.0.log archive is not as extensive as my other /var/log/ files, and I didn't see anything in the syslog files mentioning systemctl. However, I did completely uninstall the unused (yet incompatible enough to break the desktop even so) 367 Nvidia drivers back when the bad-Nvidia-update problem started, so an uninstall likely removed any service start commands.

I'm still looking for ways to get some services to cut back on the verbose logging of normal operation -- I don't need to know that a service successfully loaded each and every one of 25 image files, four times a day...
Linux Mint 18.2 x86_64, Cinnamon 3.4.6 on kernel 4.10

jackcq
Level 2
Level 2
Posts: 52
Joined: Tue Oct 11, 2016 12:35 pm

Re: Problem with 367.57 nvidia driver [solved]

Post by jackcq » Tue Nov 22, 2016 12:44 pm

I didn't get to checking it out right away, but now I can confirm reconfiguring
mdm doesn't change anything on the nvidia drivers or the error message.
I still think, the problem is with a part of the nvidia package (the persistence service)
using systemd, while mint does not. I'm not sure if the persistence daemon
is needed, otherwise it would be cool if I could just remove it from startup to get rid
of the error message.

User avatar
void75
Level 1
Level 1
Posts: 3
Joined: Thu Sep 08, 2016 4:46 am

Re: Problem with 367.57 nvidia driver [solved]

Post by void75 » Sat Dec 16, 2017 10:32 am

I open this post again, as I finally found why I got the message " systemd-udevd[852]: failed to execute '/bin/systemctl' '/bin/systemctl start --no-block nvidia-persistenced.service': No such file or directory " at startup, and cleared the dmesg log. :)

First of all, if you are still using upstart as me, but with the systemd-shim package, to emulate the systemd structure for some reason, the message is caused by an unnecessary configuration file from Nvidia package (yes, unfortunately, at today, you have to do all this procedure, every time you upgrade the nvidia drivers).

Before proceding, check if you are correctly running the nvidia-persistenced from upstart call.
Run the command nvidia-smi from the shell, you must see somewhere on the left top "Persistence-M On".

If it's "off", even if is safe to run nvidia drivers without it on (I did for many months wiothout any glitch) best before proceding, to go to read nvidia-persistenced manuals and manage to have it started from upstart (I am sorry but I forgot the exact operations, still, I managed reading this official manual http://docs.nvidia.com/deploy/driver-pe ... stallation and this topic https://devtalk.nvidia.com/default/topi ... sistenced/ ).

Then, we are at the 'grand finale'!

Go to /lib/systemd/system/ . Here you will find a file called nvidia-persistenced.service.
Simply delete it with root privileges (best before, you move it somewhere, to test if it's going smoothly as for me! :-))

Last passage.
Go to /lib/udev/rules.d/
Open as root the config file 71-nvidia.rules
Comment as posted here below the lines:
# Start and stop nvidia-persistenced on power on and power off
# respectively
#ACTION=="add" DEVPATH=="/bus/acpi/drivers/NVIDIA ACPI Video Driver" SUBSYSTEM=="drivers" RUN+="/bin/systemctl start --no-block nvidia-persistenced.service"
#ACTION=="remove" DEVPATH=="/bus/acpi/drivers/NVIDIA ACPI Video Driver" SUBSYSTEM=="drivers" RUN+="/bin/systemctl stop --no-block nvidia-persistenced"

# Start and stop nvidia-persistenced when loading and unloading
# the driver
#ACTION=="add" DEVPATH=="/module/nvidia" SUBSYSTEM=="module" RUN+="/bin/systemctl start --no-block nvidia-persistenced.service"
#ACTION=="remove" DEVPATH=="/module/nvidia" SUBSYSTEM=="module" RUN+="/bin/systemctl stop --no-block nvidia-persistenced"

Now you can restart and check dmesg log file.

Tadaa!!! No more annoying message about.

Hope to be helpfull.

Cheers.

Post Reply

Return to “Graphics Cards & Monitors”