Intel h170 chipset not recognized during installation attempt?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Fri Dec 09, 2016 10:27 pm

I'm trying to install 64 bit mint 18 on a new machine with an intel h170 chipset mobo (Asrock H170M Pro4). Booting from the 64 bit DVD (I burned the iso to the dvd), I get an error message saying the chipset is not recognized. I do get a couple of TTY type prompt screens and also the "dots" display as it tries to load, but then all goes black and just sits there. 64 bit windows 7 installed fine. Ideas? - Elmar
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Sat Dec 10, 2016 5:22 pm

Are you trying for a dual install or overwrite Windows by Mint?
For either, please backup your Windows data and follow the process
Verify the integrity o the iso.
https://linuxmint.com/verify.php
Check the media too when you boot as you get the option to check it.

Install process

For a single Mint system without Windows please use this.
http://www.tecmint.com/linux-mint-18-in ... ion-guide/
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Mon Dec 12, 2016 2:30 pm

How do I do that in windows? gpg is not recognized by the command prompt window in win7
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Mon Dec 12, 2016 4:18 pm

[c[/c]
elmarts wrote:How do I do that in windows? gpg is not recognized by the command prompt window in win7
A google search goes a long way in finding the answer. i did the same tonfind the answer for you.

https://www.google.co.in/amp/www.howtog ... id-samsung
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Tue Dec 13, 2016 9:43 am

Great! thanks for the hunt effort. I'm a newbie in this as you might have guessed :) Now to work through the windows stuff to get this done. I'll post results ... btw, my signature shows that I used to have a 32 bit installation, but that vanished with this machine hardware upgrade.
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Thu Dec 15, 2016 12:00 pm

OK - I tried again with my known good 32 bit mint DVD - and got the same error: Unknown chipset 1360001. so it's not the ISO, it's the actual OS. Am I doomed?
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Thu Dec 15, 2016 3:24 pm

I can only sugest to upgrade your Bios, if an upgrade is available.Please note that it has to be done carefully otherwise your machine can be bricked.

http://www.drivethelife.com/windows-dri ... vista.html

Good luck.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Thu Dec 15, 2016 4:13 pm

I doubt I can get a newer bios that what this came with, since the mobo is brand spanking new - from windows system information:

BIOS Version/Date American Megatrends Inc. P2.20, 7/5/2016
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Thu Dec 15, 2016 5:01 pm

Please check if present macine is uefi, if yes then follow
viewtopic.php?t=209793?
Or try mint17.3
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Minterator
Level 5
Level 5
Posts: 596
Joined: Thu Jan 10, 2013 8:29 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by Minterator » Thu Dec 15, 2016 5:32 pm

I have Asus H170I and LM 17.3 and 18 work perfectly. You may need a BIOS update.
Mint 17.3 MATE, kernel 4.11.12

User avatar
Sgthawker
Level 4
Level 4
Posts: 214
Joined: Sun Apr 27, 2014 2:23 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by Sgthawker » Fri Dec 16, 2016 12:07 am

FWIW, there are 2 updated BIOS files on the ASRock website: 7.00 & 7.10

http://www.asrock.com/mb/Intel/H170M%20 ... ad&os=BIOS
LM 18.3 KDE/LM 19.1 Cinnamon/Peppermint 10 KDEneon UEFI on Sabertooth Z170 S, i6700K, Echelon GTX950, Samsung 970 Pro M.2 NVMe
LM 19.1 Cinnamon UEFI on Asus ROG STRIX laptop, i7700 HQ, GTX 1060, Samsung 970 Pro M.2 NVMe

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Fri Dec 16, 2016 1:02 pm

I did the UEFI BIOS UPdate - no change in the liveCD behavior (black screen and no activity).
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Fri Dec 16, 2016 1:04 pm

deepakdeshp wrote:Please check if present macine is uefi, if yes then follow
viewtopic.php?t=209793?
Or try mint17.3
OK - Off to download 17.3 then.
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Fri Dec 16, 2016 4:08 pm

And failure in the same way - unknown chipset from 17.3, 18 and 18.1; ah well - mobo is too bleeding edge for the current crop of Linux's,I guess.

Chipset
-------------------------------------------------------------------------
Northbridge Intel Skylake rev. 07
Southbridge Intel H170 rev. 31

Now to attempt to rescue my other machine whose 32 bit Mint seems to have flaked out -
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Fri Dec 16, 2016 5:25 pm

[quote="Sgthawker"]FWIW, there are 2 updated BIOS files on the ASRock website: 7.00 & 7.10

http://www.asrock.com/mb/Intel/H170M%20 ... ad&os=BIOS[/quotee] is your Bios updated to 7.10?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Sgthawker
Level 4
Level 4
Posts: 214
Joined: Sun Apr 27, 2014 2:23 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by Sgthawker » Fri Dec 16, 2016 7:13 pm

I don't have that motherboard, mine is listed in my signature. I just looked up yours and found those links.

I have seen that fedora tends to be on the bleeding edge, so they might support that chipset with a newer linux kernel. Most drivers are built into the kernel, so newer kernels are most likely to support newer hardware.
LM 18.3 KDE/LM 19.1 Cinnamon/Peppermint 10 KDEneon UEFI on Sabertooth Z170 S, i6700K, Echelon GTX950, Samsung 970 Pro M.2 NVMe
LM 19.1 Cinnamon UEFI on Asus ROG STRIX laptop, i7700 HQ, GTX 1060, Samsung 970 Pro M.2 NVMe

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Sat Dec 17, 2016 9:18 am

deepakdeshp wrote:
Sgthawker wrote:FWIW, there are 2 updated BIOS files on the ASRock website: 7.00 & 7.10
http://www.asrock.com/mb/Intel/H170M%20 ... ad&os=BIOS
is your Bios updated to 7.10?
Yes - I did that, and thank you for that pointer above.
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

elmarts
Level 3
Level 3
Posts: 137
Joined: Mon Aug 08, 2016 6:46 pm

Re: Intel h170 chipset not recognized during installation attempt?

Post by elmarts » Sat Dec 17, 2016 9:20 am

Sgthawker wrote:... newer kernels are most likely to support newer hardware.
So if I want to stay with Mint (which I really like btw), I will need to wait for version 19, which should have an updated kernal?
- Elmar
Dual boot win 7 & Linux Mint
Release Linux Mint 19.2 Tina 64-bit
Kernel Linux 5.0.0-20-generic x86_64
MATE 1.20.1

deepakdeshp
Level 16
Level 16
Posts: 6284
Joined: Sun Aug 09, 2015 10:00 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by deepakdeshp » Sat Dec 17, 2016 9:59 am

elmarts wrote:
Sgthagwker wrote:... newer kernels are most likely to support newer hardware.
So if I want to stay with Mint (which I really like btw), I will need to wait for version 19, which should have an updated kernal?
Version 18.1 can be downloaded. May be using same kernel as version 18.I am not sure.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Minterator
Level 5
Level 5
Posts: 596
Joined: Thu Jan 10, 2013 8:29 am

Re: Intel h170 chipset not recognized during installation attempt?

Post by Minterator » Sat Dec 17, 2016 10:55 am

elmarts wrote:
Sgthawker wrote:... newer kernels are most likely to support newer hardware.
So if I want to stay with Mint (which I really like btw), I will need to wait for version 19, which should have an updated kernal?
No, both Linux MInt 17.3 & 18 support the Intel H170/Z170 chipset. There is something wrong with your mobo or BIOS.
Mint 17.3 MATE, kernel 4.11.12

Post Reply

Return to “Installation & Boot”