Printer worked for months suddenly stopped[SOLVED]

Forum rules
Before you post please read this
Post Reply
enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Printer worked for months suddenly stopped[SOLVED]

Post by enfoprefect » Sat Jan 21, 2017 7:36 pm

I have a HP 1018 laser printer that Linux Mint 18, Mate immediately recognized upon installation of Linux. It worked fine for a couple of months then suddenly stopped. The only thing I changed was add another color printer. Both are physically connected by USB cables. I did find that submitted jobs go to its print queue for several seconds then disappear from the queue with no error message just as if the job had been printed. This is a dual boot machine and the printer still works on Windows. I tried removing it the adding it back but that didn't change anything. Any suggestions on how to get it working again?
Last edited by enfoprefect on Thu Mar 16, 2017 11:38 am, edited 1 time in total.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Printer worked for months suddenly stopped

Post by pdc_2 » Sun Jan 22, 2017 12:09 am

when one has a single printer connected by usb cable, it gets called lp0 (ie lp-zero);

if one plugs in another printer by usb, it gets called lp1 and the system assumes you will always turn on lp0 first of all, and then turn on lp1 ......... that is how it distinguishes the 2 ..... so could that be an issue, do you think?

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Sun Jan 22, 2017 11:39 am

Thanks for the answer. I tried your suggestion and still no love from the first printer.

deepakdeshp
Level 16
Level 16
Posts: 6292
Joined: Sun Aug 09, 2015 10:00 am

Re: Printer worked for months suddenly stopped

Post by deepakdeshp » Sun Jan 22, 2017 11:52 am

Please try installing cups and administer it from web interface
https://ubuntuforums.org/showthread.php?t=2326160
http://localhost:631/admin
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Sun Jan 22, 2017 7:01 pm

Cups was apparently already installed. I did try administering through the web page as suggested. I added the printer again although it was already recognized. Still no printing. As I said earlier, this printer has worked since I first installed Linux and just suddenly stopped although it still prints under Windows. The print job even shows up in the queue for a short period then goes away. thinking adding the second printer might be the problem, I even removed it but still my laser doesn't print. This is really frustrating as it is a lot faster and cheaper to print on the laser rather than the color printer.

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Wed Feb 01, 2017 11:15 pm

For some reason the printer suddenly started working again. The only steps I have taken was to switch back to Window to be sure it still printed there then back to Linux. But I had also done that before without success. Something here is flaky or at least emotional.

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Tue Mar 14, 2017 11:33 am

Sorry, I only thought it was working. Had other critical jobs to do so just got back on this problem. I just removed and reinstalled the printer and it still will not print also Mint thinks it has. When I reinstalled it, Mint discovered it almost immediately. Meanwhile I got the color printer working wireless last week and removed it from the USB connection before reinstalling the laser. Still no print. Also, it still prints fine under Windoze. Anyone have any more suggestions to try please?

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

HP1018 not working; other colour printer also quiet

Post by pdc_2 » Tue Mar 14, 2017 12:01 pm

1) with any printers that you have plugged in and turned on, can you type this command into a terminal, and give us the answer please?

Code: Select all

lpinfo -v
_____________

2) perhaps if you also open your PRINTERS folder; right-click on each of the icons for the 2? printers you have set up ......... and select "properties": if you enlarge the window sideways that you get; when you do this; you should be able to see what is in the MAKE AND MODEL section: could you copy and paste what is there please also

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Printer worked for months suddenly stopped

Post by turboscrew » Wed Mar 15, 2017 3:53 am

And from the CUPS you can set debug-level for logs. That might give some further info.
Under Administration/Server: Save debugging information for troubleshooting
and Administration/Server/Edit configuration file: LogLevel warn -> LogLevel debug
(Or the same changes in the /etc/cups/cupsd.conf)
The logs are in /var/log/cups

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Wed Mar 15, 2017 11:02 am

lpinfo -v gives

network ipps
network ipp
network http
network lpd
network ipp14
network https
serial serial:/dev/ttyS0?baud=115200
network beh
direct cnijusb:/dev/usb/lp0
network socket
network smb
direct hp:/usb/HP_LaserJet_1018?serial=KP2HH40
direct usb://HP/LaserJet%201018?serial=KP2HH40
direct hpfax

From the Printer window for the HP I get:

Device URI: hp:/usb/HP_Laserjet_1018?serial=KP2HH40
Make and Model: HP Laserjet 1018 Foomatic/foo2zjs-z1 (recommended)

and for the now working wireless Canon I get:

Device URI: cnijnet:/00-1E-8F-7F-12
Make and Model: Canon MG5200 series Ver 3.40

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Wed Mar 15, 2017 11:44 am

turboscrew I also did what you suggested then tried to print a small file. This produced an error log of 138433 bytes. I tried to look through it for something obvious but have to admit that it just overwhelmed me. I didn't see anything that looked like something fatal though.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Printer worked for months suddenly stopped

Post by pdc_2 » Wed Mar 15, 2017 5:49 pm

thanks very much for all this information; very good;

so trying to put it all together, I see

Code: Select all

direct cnijusb:/dev/usb/lp0
........and my interpretation is that your system thinks there is a CANON INKJET connected to the usb port that it calls LP_ZERO (or lp0 as it prints it ..)

....... cnijusb to me means Canon Ink Jet ..cn...ij......attached to usb ............. so you probably think there is an HP there ........ whereas and it assumes it is a Canon ...........

____________

for your HP, I see it is using the Foomatic driver

Code: Select all

Make and Model: HP Laserjet 1018 Foomatic/foo2zjs-z1 (recommended)
most HP enthusiasts would tell you HP printers work all the time; I guess many would assume hplip http://hplipopensource.com/hplip-web/index.html has leapt into action and configuring the printer ........ in your case, it has not

for the Canon, we get the device URI and

Code: Select all

Make and Model: Canon MG5200 series Ver 3.40
so you have got the Canon printers running: well done
____________
so for any printer, the format of "registering" .... or introducing the printer to the computer,in a very formal way, so they both get on well ...........

Code: Select all

sudo /usr/sbin/lpadmin -p [Printer Name] -P [PPD file path] -v usb:// [device file path] -E
which tells lpadmin (linux printing admin) that when it talks to MG5200 to use such_and_such-PPD file when it sends data to this location (eg dev/usb/lp0)

so you only have one usb printer now? ............ so a new registration for your usb printer (the HP?) would hopefully tell it to use lp0 and it should be happy;

________

I think I would suggest deleting the existing HP icon in your PRINTERS folder; (so foomatic goes ...) and aiming to use hplip http://hplipopensource.com/hplip-web/in ... setup.html

so they say (after deleting the existing profile), run this command

Code: Select all

sudo hp-setup
and then follow your nose as the instructions take you through;

______________

when all done, go to the PRINTERS folder; right-click on the new HP icon and look in MAKE & MODEL ....... do is say some version of HPLIP please? ..... maybe you copy and paste it back to us ..

we hope this all works

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Wed Mar 15, 2017 11:11 pm

When I could not get a driver for the Canon and the HP quit working, I connected the Canon by USB and it worked. I since got a driver for the Canon from Hong Kong and a required libtiff4 set from somewhere else and it now works wirelessly and is no longer connected by USB. In the printer manager I can't see the USB Canon so how do it delete it? BTW, I have already had a refreshing adult beverage tonight so should probably proceed with your other suggestions tomorrow instead to avoid completely mucking things up..

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Printer worked for months suddenly stopped

Post by pdc_2 » Thu Mar 16, 2017 3:35 am

"I have already had a refreshing adult beverage tonight so should probably proceed with your other suggestions tomorrow instead to avoid completely mucking things up.."

........... absolutely ............ leave well alone .... you deserve some more refreshments ........

when you read this tomorrow, I said .......

"I think I would suggest deleting the existing HP icon"

....... so leave the Canon alone!! ........... it seems fine

....... you have done very well with the Canon ....... libtiff4 is needed for those drivers ..... you got that installed ...... well done .......

.......... it is that LP_ADMIN seems to think there is a CANON at the end of the usb cable; instead you have an HP there; ....... so sending canon instructions to print ............ to an HP .......... may not be successful ........... as you seem to have shown ..

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped

Post by enfoprefect » Thu Mar 16, 2017 11:38 am

Well pdc_2, it seems you have solved my problem. I did as you suggested and removed the Laser from printers. After that, the Canon disappeared from lpinfo. I had done that before but let the system find and reinstall it automatically which got me right back in the same situation. This time I tried hp-setup instead but hplip was not installed. I then installed it and tried again. It found the printer and set it up properly. It now prints. One less problem to solve. Thank you very much for the advice. It looks like I still have a lot to learn about Linux. But it is so refreshing and logical after getting off of window$ that I will never go back.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Printer worked for months suddenly stopped[SOLVED]

Post by pdc_2 » Thu Mar 16, 2017 12:48 pm

well done to have the HP working; and I am curious hplip was not installed; I thought it was part of a standard mint install; good to have it established as lp0; "But it is so refreshing and logical" ..... great ..... enjoy

hplip should be a good resource; on the right is a link to troubleshooting http://hplipopensource.com/node/224 which is useful to have; and there are other things to check through

for the Canon, If lpinfo does not see it; ..... is there an icon for it in the printers folder; if it prints, perhaps just leave as is; if not printing, I would delete the icon; then go to the top left of the printers folder; look for the ADD button; click on that .. click on network printer ....... it should find the Canon; you have drivers already installed; it should set up a new icon for the Canon and all should be well; we hope

enfoprefect
Level 2
Level 2
Posts: 78
Joined: Mon Aug 01, 2016 11:02 am

Re: Printer worked for months suddenly stopped[SOLVED]

Post by enfoprefect » Fri Mar 17, 2017 6:33 pm

Both printers working perfectly thanks to your astute trouble-shooting. HP is usb and Canon is wireless.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Printer worked for months suddenly stopped[SOLVED]

Post by pdc_2 » Fri Mar 17, 2017 7:08 pm

great! You have done very well: enjoy!

Post Reply

Return to “Printers & Scanners”