Windows are invisible

Please post suggestions for improvement of Cinnamon here
Post Reply
Level 1
Level 1
Posts: 34
Joined: Mon Jul 30, 2012 6:25 pm

Windows are invisible

Post by tkocou » Mon May 01, 2017 7:51 am

Yesterday, I switched from the MATE desktop to the Cinnamon desktop while upgrading from Mint 17.3 to Mint 18.1. For the most part, I've been pleasantly surprised by the smoothness of Cinnamon. However, somehow the windows became invisible. I would start a program like the file manager and while the bottom task bar showed the program running, the window was not displayed. Just to be sure, I click on the task bar icon several time. I saw the expanding and contracting from the icon, just no window when expanded. I logged out and re-logged in. The problem was fixed. So, any suggestions as to what might cause this weird situation? Any suggestions on what to do besides logging out / logging in?

User avatar
Level 19
Level 19
Posts: 9506
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands

Re: Windows are invisible

Post by Moem » Mon May 01, 2017 8:20 am

How did you upgrade, and how did you switch desktop environments? Was this a clean installation?
Did the problem ever come back, after logging out and in fixed it?

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Level 1
Level 1
Posts: 34
Joined: Mon Jul 30, 2012 6:25 pm

Re: Windows are invisible

Post by tkocou » Tue May 02, 2017 11:17 pm

It was a clean install from a Linux Mint 18.1 Cinnamon DVD. And it has not manifest itself yet (again).I wish I could reproduce it so that a proper problem report could be filed. I was curious if anyone else experienced the problem.

When I started the project, I did the usual home directory data backup. I then "merged" the data onto the new home directory while being careful not to overwrite the "new" home directory configurations. That way the exisring firefox bookmarks were transferred, etc., etc. without breaking the important Cinnamon settings. The old MATE settings were discarded.

CNC Martin
Level 1
Level 1
Posts: 1
Joined: Wed Mar 14, 2018 7:00 am

Re: Windows are invisible

Post by CNC Martin » Wed Mar 14, 2018 7:10 am

I having the same problems. Mainly after using Firefox and jumping many times to different windows. The programs running and the window are seen just like a water mark at my desktop background picture. The visibilty is so bad that you can not controll anyting and shut down just with ctrl-alt-F2 and run the command sudo shutdown now. After reboot the computer is working normal until the next freeze.
Anybody can help?
System: Host: ............ Kernel: 4.4.0-116-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm Distro: Linux Mint 18.1 Serena
Machine: Mobo: ASUSTeK model: H110M-PLUS v: Rev X.0x Bios: American Megatrends v: 1802 date: 05/19/2016
CPU: Dual core Intel Core i3-6100 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14785
clock speeds: min/max: 800/3700 MHz 1: 1499 MHz 2: 1499 MHz 3: 1499 MHz 4: 1499 MHz
Graphics: Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0 chip-ID: 8086:1912
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@59.79hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio: Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
Sound: Advanced Linux Sound Architecture v: k4.4.0-116-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 1000.2GB (67.1% used)
ID-1: /dev/sda model: WDC_WD10EARS size: 1000.2GB serial: WD-WCAV5K888192
Partition: ID-1: / size: 14G used: 7.1G (55%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 902G used: 617G (73%) fs: ext4 dev: /dev/sda3
ID-3: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: 0
Repos: Active apt sources in file: /etc/apt/sources.list.d/librecad-dev-librecad-stable-xenial.list
deb http: // xenial main
deb-src http: // xenial main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: // serena main upstream import backport
deb http: // xenial main restricted universe multiverse
deb http: // xenial-updates main restricted universe multiverse
deb http: // xenial-backports main restricted universe multiverse
deb http: // xenial-security main restricted universe multiverse
deb http: // xenial partner
Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
deb [arch=amd64] https: // stable main
Info: Processes: 178 Uptime: 46 min Memory: 1596.4/3845.7MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Unknown python2.7 client inxi: 2.2.35

Post Reply

Return to “Cinnamon”