Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
Doruletz
Level 4
Level 4
Posts: 224
Joined: Sun Aug 15, 2010 1:00 am

Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by Doruletz » Sat Sep 24, 2016 10:53 pm

I have this little Intel NUC, with an Intel Celeron N2820.
https://en.wikipedia.org/wiki/Next_Unit_of_Computing
http://www.intel.com/content/www/us/en/ ... 0fykh.html
I run Linux Mint 17LTS Qiana MATE 64bit, and the graphic driver is Intel 3.0 Mesa 11.0.4
I hooked it up to a Philips 1080p TV. The TV does not have any menu option for overscan, fit pixel, etc (cheap $300 piece of crap)
Can somebody try to help me with overscan compensation?
The Intel driver, when I run

Code: Select all

xrandr --output HDMI-1 --set underscan on &
xrandr --output HDMI1 --set "underscan hborder" 50 --set "underscan vborder" 50
returns an error message

also the other method I found does not work either.

Code: Select all

xrandr --output HDMI1 --transform 0.95,0-50,0,0,97,-50,0,0,1
while it does fix the top left corner of the display, it does not do the same thing for the top right corner, which is still out of bounds of the TV screen, thus with any maximized window (displayed on the whole desktop space) I cannot see the titlebar buttons (the "X" for close window, maximize/restore and minimize buttons).

PLEASE HELP ME with this ovescan compensation problem.
Thanks
What do I think about Window$??? Just take a look at my AVATAR...

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Sun Sep 25, 2016 9:44 am

What is the model number of the Philips TV?

User avatar
Doruletz
Level 4
Level 4
Posts: 224
Joined: Sun Aug 15, 2010 1:00 am

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by Doruletz » Sun Sep 25, 2016 3:31 pm

I don't think that the TV Model matters in any way, fact is it DOES NOT have any menu option to compensate for overscan.
But to answer your question, it's a Philips 32PFL3504D/F7, which I got some 4-5 years ago for under $300 at Walmart.
roblm wrote:What is the model number of the Philips TV?
What do I think about Window$??? Just take a look at my AVATAR...

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Sun Sep 25, 2016 4:18 pm

I looked at the TV user manual for the Philips 32PFL3514D / 32PFL3504D / 42PFL3704D. I don't know if the F7 at the end makes any difference. There is a Horizontal/Vertical Position setting but no Horizontal/Vertical Size setting.

There are 3 types of display modes that can be selected for a PC input signal: Normal, Full and Dot by Dot. Use the Dot by Dotsetting.

User avatar
runSPOTrun
Level 1
Level 1
Posts: 8
Joined: Thu Oct 13, 2016 3:01 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by runSPOTrun » Thu Oct 13, 2016 5:05 pm

I have the same isue with an old westinghouse. The main problem being the tv wont recognize the vga signal, only the hdmi. Without being able to use the vga input, there is no way to shut off overscan, and no way to pad the output to compensate as far as I can tell. This is one of those crank up the font and taskbar size moments to make it work for now, moments. Good Luck!

piso mojado
Level 1
Level 1
Posts: 43
Joined: Wed May 17, 2017 6:35 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics [SOLVED]

Post by piso mojado » Thu May 18, 2017 7:40 pm

I'm having the same problem. I bought an Intel NUC6CAYH for use with an old Samsung SP-R4232. When I plug in HDMI, I get severe overscan issues. The TV settings are no help (I read the manual thoroughly). The PC setting is only available if I use VGA. However, when I use a VGA cable, the NUC and the TV refuse to get along, no picture. Is there either a way to get the VGA connection to work or a way to fix the overscan with Linux Mint Cinnamon 18.1 64-bit?

I downloaded ARandR, but I don't know how to use it.

xrandr --query
Screen 0: minimum 8 x 8, current 1280 x 720, maximum 32767 x 32767
DP1 connected primary 1280x720+0+0 (normal left inverted right x axis y axis) 1102mm x 620mm
1280x720 60.00*+ 59.94
1920x1080i 60.00 59.94
720x480 60.00 59.94
640x480 60.00 59.94
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Last edited by piso mojado on Fri May 26, 2017 2:37 pm, edited 2 times in total.
Mint 18.2 Cinnamon 64 bit, kernel 4.10.0-30 on an Intel NUC6CAYH connected to a Samsung SP-R4232 via hdmi

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Fri May 19, 2017 9:38 am

Try testing if one of these commands eliminates the overscan:

Code: Select all

xrandr --output DP1 --panning 1280x720 --transform 1.04,0,-35,0,1.07,-35,0,0,1

xrandr --output DP1 --panning 1280x720 --transform 1.05,0,-55,0,1.07,-35,0,0,1
To reverse the effect:

Code: Select all

xrandr --output DP1 --panning 1280x720 --transform 1,0,0,0,1,0,0,0,1

piso mojado
Level 1
Level 1
Posts: 43
Joined: Wed May 17, 2017 6:35 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by piso mojado » Fri May 19, 2017 1:21 pm

Thanks, that's great, it works! This setting works for me:

Code: Select all

xrandr --output DP1 --panning 1280x720 --transform 1.04,0,-35,0,1.07,-25,0,0,1
I figured out that the first negative number affected left and right and the second negative number affected up and down.

How do I make this change permanent?
Mint 18.2 Cinnamon 64 bit, kernel 4.10.0-30 on an Intel NUC6CAYH connected to a Samsung SP-R4232 via hdmi

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Fri May 19, 2017 2:37 pm

Add the xrandr command to the /etc/mdm/Init/Default file, so it will be executed automatically. Open the file with this command:

Code: Select all

gksudo xed /etc/mdm/Init/Default
Add the command at the end, just above the last line that says exit 0 and then reboot.

piso mojado
Level 1
Level 1
Posts: 43
Joined: Wed May 17, 2017 6:35 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics [SOLVED]

Post by piso mojado » Fri May 19, 2017 3:20 pm

It worked like a charm! You are a wonderful human being!
Mint 18.2 Cinnamon 64 bit, kernel 4.10.0-30 on an Intel NUC6CAYH connected to a Samsung SP-R4232 via hdmi

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Fri May 19, 2017 6:38 pm

That xrandr command may not remove the overscan completely but it can be fine tuned some more, if needed. Check my fourth post in this topic for more info:
viewtopic.php?f=59&t=224997

piso mojado
Level 1
Level 1
Posts: 43
Joined: Wed May 17, 2017 6:35 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by piso mojado » Sat Aug 04, 2018 1:54 pm

While updating to 18.3, I moved from mdm to lightdm.(for some reason that seemed to fix my audio problems) How can I make xandr changes to overscan permanent without mdm?
Mint 18.2 Cinnamon 64 bit, kernel 4.10.0-30 on an Intel NUC6CAYH connected to a Samsung SP-R4232 via hdmi

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by roblm » Sat Aug 04, 2018 3:09 pm

Add the xrandr command to Startup Applications. Click the Add button and select Custom Command.

piso mojado
Level 1
Level 1
Posts: 43
Joined: Wed May 17, 2017 6:35 pm

Re: Cannot get TV overscan compensation on a NUC PC with Intel Graphics

Post by piso mojado » Sat Aug 04, 2018 3:48 pm

roblm wrote:
Sat Aug 04, 2018 3:09 pm
Add the xrandr command to Startup Applications. Click the Add button and select Custom Command.
Brilliant! Works beautifully! Thanks!
Mint 18.2 Cinnamon 64 bit, kernel 4.10.0-30 on an Intel NUC6CAYH connected to a Samsung SP-R4232 via hdmi

Post Reply

Return to “Graphics Cards & Monitors”