[SOLVED]System sees card but won't use

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
User avatar
RamBurner
Level 3
Level 3
Posts: 107
Joined: Wed Nov 23, 2011 7:31 pm

[SOLVED]System sees card but won't use

Postby RamBurner » Mon Jun 19, 2017 5:09 pm

Qualcomm Atheros AR922x is the PCI card, which can be seen with lspci and other commands but it won't show in the network manager to use. I'm using a USB wireless to post this. I do see that it says
*-network UNCLAIMED

System:
Dell XPS-410
64bit 18.1 Cinnamon
Wireless adapter D-Link DWA-542 pci card


Code: Select all

 lshw -c net; iwconfig
WARNING: you should run this program as super-user.
  *-network               
       description: Ethernet interface
       product: 82566DC Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 02
       serial: 00:19:d1:87:46:93
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=1.1-0 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:dffe0000-dfffffff memory:dffdb000-dffdbfff ioport:ecc0(size=32)
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR922x Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 3
       bus info: pci@0000:04:03.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master cap_list
       configuration: latency=64
       resources: memory:dcef0000-dcefffff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@2:6.4
       logical name: wlx08863b664a86
       serial: 08:86:3b:66:4a:86
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8712u ip=192.168.0.104 multicast=yes wireless=IEEE 802.11bgn
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
tun0      no wireless extensions.

lo        no wireless extensions.

enp0s25   no wireless extensions.

wlx08863b664a86  IEEE 802.11bgn  ESSID:"Microdata"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:24:01:D0:91:18   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=96/100  Signal level=90/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

User avatar
RamBurner
Level 3
Level 3
Posts: 107
Joined: Wed Nov 23, 2011 7:31 pm

Re: [SOLVED]System sees card but won't use

Postby RamBurner » Mon Jun 19, 2017 9:49 pm

Turns out I had a PCI slot that was not working properly, changed to a different PCI slot and it works fine now.


Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 0 guests