LM18 doesn't recognize external hard drive :(

Forum rules
Before you post please read this
Post Reply
MintDude2013
Level 1
Level 1
Posts: 26
Joined: Fri Feb 15, 2013 4:19 pm

LM18 doesn't recognize external hard drive :(

Post by MintDude2013 » Mon Aug 14, 2017 2:07 pm

Hi Forum:

I use LM18 with 3 external hard drives (in addition to 2 internal ones), two of which always get recognized/mounted when I start Linux. The third one, however, doesn't (although Win7 always recognizes it).

Googling for a solution didn't really find anything helpful. Except to open the Terminal and run 'sudo blkid', which showed all hard drives, internal and external, partitions, etc. just not the elusive 3rd external HDD :cry:.

Many thanks.

MintDude2013 aka John

User avatar
catweazel
Level 17
Level 17
Posts: 7117
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: LM18 doesn't recognize external hard drive :(

Post by catweazel » Mon Aug 14, 2017 6:38 pm

Actually, that command has revealed the problem. The drive is not recognised.

First, if you haven't already done so, unplug all the other external drives and move the cable for the errant drive into a socket that was occupied by one of the two known working drives. Post back with the results.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

MintDude2013
Level 1
Level 1
Posts: 26
Joined: Fri Feb 15, 2013 4:19 pm

LM18 doesn't recognize external hard drive :(

Post by MintDude2013 » Wed Aug 16, 2017 9:29 am

Hi Catweazel:

Thanks for your feedback!

Well, I did exactly what you suggested. The 2 external HDDs, that Linux always recognizes, of course showed up in the "Explorer". The third one, though, once again did not :shock:.

What next?

Many thanks again.

MintDude2013 aka John

User avatar
MintBean
Level 9
Level 9
Posts: 2955
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: LM18 doesn't recognize external hard drive :(

Post by MintBean » Wed Aug 16, 2017 9:38 am

Unplug all other external drives and try again.

MintDude2013
Level 1
Level 1
Posts: 26
Joined: Fri Feb 15, 2013 4:19 pm

LM18 doesn't recognize external hard drive :(

Post by MintDude2013 » Wed Aug 16, 2017 9:49 am

Hi MintBean:

Thanks for your reply.

Well, that's exactly what I did. Before restarting LM18 I unplugged the 2 'working' drives, i.e. only plugged in the one that doesn't and in one of the USB ports where one of the working external HDDs had been plugged in.

Still, the same result: Linux doesn't recognize the 'darn' thing :shock:.

MintDude13/John

Post Reply

Return to “Mounting Partitions”