Very annoying bug in Mint 18 preventing me from adding PPAs

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
blackoutworm
Level 2
Level 2
Posts: 80
Joined: Sun Jun 05, 2011 2:20 pm

Very annoying bug in Mint 18 preventing me from adding PPAs

Post by blackoutworm »

Hi there.
I just upgraded from Mint 17.3 and for some reason, the settings haven't really been changed from trusty to xenial.
When I am trying to add a PPA, it tells me that the PPA is not supported on Trusty.
So how do I fix this? Where is this distro name info stored so I can fix it?

blackoutworm
Level 2
Level 2
Posts: 80
Joined: Sun Jun 05, 2011 2:20 pm

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Post by blackoutworm »

Nevermind.
I figured it out.
For those who wonder, edit the /etc/lsb-release file.
I hope the LinuxMint team fixes this problem.

User avatar
catweazel
Level 19
Level 19
Posts: 9895
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Post by catweazel »

This isn't caused by the Mint team. You caused it. Upgrades from different major version numbers are not recommended.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

User avatar
phd21
Level 19
Level 19
Posts: 9550
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Post by phd21 »

Hi "blackoutworm",

I have both Linux Mint version 17.3 and 18.1 installed, and you can easily add PPA's to either one.

CAUTION: there are PPA's that do not have software that has been updated for Linux Mint 18.x based on Ubuntu 16.04 Xenial.

If there is some software application that you are trying to get into your newly installed Linux Mint 18.x system that used a PPA for Linux Mint 17.x based on "Ubuntu 14.04 Trusty" that now does not work in LM 18.x, then tell us what it is, or search for other options to install that software. Do not try editing system files and such...

Hope this helps ...
Last edited by phd21 on Sat Aug 19, 2017 2:15 pm, edited 1 time in total.
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
jimallyn
Level 18
Level 18
Posts: 8951
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Post by jimallyn »

catweazel wrote:This isn't caused by the Mint team. You caused it. Upgrades from different major version numbers are not recommended.
Actually, the Mint devs did post a procedure for upgrading from 17 to 18. But enough people had problems with it that I'm going to do a clean install when I upgrade.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

Post Reply

Return to “Software & Applications”