Calculator showing comma instead of period decimal separator

Questions about applications and software
Forum rules
Before you post please read how to get help
Locked
tsger
Level 1
Level 1
Posts: 2
Joined: Sat Dec 03, 2011 10:52 am

Calculator showing comma instead of period decimal separator

Post by tsger »

How do I change the decimal separator in calculator from a comma to a decimal? I think because my location is in tEurope, it is using commas instead of decimals.
User avatar
Pierre
Level 21
Level 21
Posts: 12562
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Calculator showing comma instead of period decimal separ

Post by Pierre »

what is your keyboard language / layout set to?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
User avatar
tenry
Level 1
Level 1
Posts: 29
Joined: Sat Aug 30, 2014 5:14 pm
Location: Germany
Contact:

Re: Calculator showing comma instead of period decimal separ

Post by tenry »

It's the same for me (US-international keyboard, US-english language, but I am located in Germany where the comma is used as the decimal point). I don't see any settings, not even in the gsettings of the calculator.

Maybe the calculator knows that I am in Germany (although I didn't tell my system anywhere).

The calculator that is shipped with Mint Cinnamon is "gnome-calculator", maybe you can find something on the web about that issue. Although, check if there is somewhere a system settings, where you can set the number format.
It is just a matter of definition.
ulrich
Level 1
Level 1
Posts: 1
Joined: Fri Sep 15, 2017 6:22 am

Re: Calculator showing comma instead of period decimal separator

Post by ulrich »

The way I fixed it for ubuntu mate (Mint should be similar) was as follows:

in Desktop/gnome-calculator.desktop I changed the line
Exec=gnome-calculator
to
Exec=<pathname>/us_calculator

where us_calculator is a script:

:
LC_NUMERIC=en_US.UTF-8 gnome-calculator

Good luck,

ulrich
User avatar
tachikata
Level 1
Level 1
Posts: 2
Joined: Mon Mar 11, 2019 4:28 am
Location: Various

Re: Calculator showing comma instead of period decimal separator

Post by tachikata »

Depending on what region you are in the world, the decimal point will be represented by either a comma "," or a dot "."
This can be a pain to some formatting and programs, so I would suggest the following for correction to your preferences.

Preferences > Languages > Regions
-Change it to one of the relevant countries below relevant to you.
-Click on APPLY SYSTEM WIDE button.
-Reopen calculator and it should have the dot instead of comma, or comma instead of dot depending on your country preference

---------------------------------------------------------------------
Countries where a dot "." is used as decimal mark include
Australia
Bangladesh
Botswana
British West Indies
Brunei
Cambodia
Canada (when using English)
China, People's Republic of Hong Kong
Macau (in Chinese and English text)
Dominican Republic
Egypt
El Salvador
Ghana
Guatemala
Honduras
India
Ireland
Israel
Japan
Jordan
Kenya
Korea, North
Korea, South
Lebanon
Luxembourg (uses both marks officially)
Malaysia
Malta
Mexico
Myanmar
Nepal
New Zealand
Nicaragua
Nigeria
Pakistan
Palestine
Panama
Philippines
Puerto Rico
Singapore
Sri Lanka
Switzerland (for Swiss currency)
Taiwan
Tanzania
Thailand
Uganda
United Kingdom
United States (including insular areas)
Zimbabwe

Countries where a comma "," is used as decimal mark include
Albania
Algeria
Andorra
Angola
Argentina
Armenia
Austria
Azerbaijan
Belarus
Belgium
Bolivia
Bosnia and Herzegovina
Brazil
Bulgaria
Cameroon
Canada (when using French)
Chile
Colombia
Costa Rica
Croatia (comma used officially, but both forms are in use)[citation needed]
Cuba
Cyprus
Czech Republic
Denmark
East Timor
Ecuador
Estonia
Faroes
Finland
France
Germany
Georgia
Greece
Greenland
Hungary
Iceland
Indonesia
Italy
Kazakhstan
Kosovo
Kyrgyzstan
Latvia
Lebanon
Lithuania
Luxembourg (uses both marks officially)
Macau (in Portuguese text)
Macedonia
Moldova
Mongolia
Morocco
Mozambique
Namibia
The Netherlands
Norway
Paraguay
Peru
Poland
Portugal
Romania
Russia
Serbia
Slovakia
Slovenia
South Africa
Spain
Switzerland (other than Swiss currency)
Sweden
Tunisia
Turkey
Ukraine
Uruguay
Uzbekistan
Venezuela
Vietnam
User avatar
Pierre
Level 21
Level 21
Posts: 12562
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Calculator showing comma instead of period decimal separator

Post by Pierre »

Hi tachikata ,
it does pay to Not re-activate an older post, as those people have now moved on,
from their issue & thus your reply may no longer be relevant, anymore.

NB: if you, or any one else, has an ongoing issue - then it does actually pay to Start a New Post
- about Your New Issues.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
Locked

Return to “Software & Applications”