Synaptics Touchpad stopped working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 66
Joined: Fri Mar 24, 2017 1:29 pm
Location: Florida

Synaptics Touchpad stopped working

Post by wedjlok » Mon Sep 18, 2017 1:06 pm

The Synaptics touchpad on my Toshiba Satellite C855-S5194 just recently stopped working, and I cannot find a solution. I have looked over past posts and also tried to blacklist as others have suggested on other forums and it is still not working. I'm pretty sure it simply happened after some update, but just not sure which/what update did it. I do use a mouse most times, but it would be nice to know why the touchpad stopped working, and how to fix it.

The device shows up when I run cat/proc/bus/input/devices:

Code: Select all

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse1 event7 
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003
and also appears on any mouse/touchpad device list setting, but is simply not responding.

Here's also my inxi -Fxzd output:

Code: Select all

System:    Host: andromeda Kernel: 4.12.10-041210-generic x86_64 (64 bit gcc: 7.1.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya
Machine:   System: TOSHIBA (portable) product: Satellite C855 v: PSCBLU-066003
           Mobo: TOSHIBA model: Portable PC v: MP Bios: Insyde v: 6.70 date: 04/15/2013
CPU:       Dual core Intel Core i3-3120M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977
           clock speeds: max: 2500 MHz 1: 1199 MHz 2: 1199 MHz 3: 1199 MHz 4: 1199 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.02hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.12.10-041210-generic
Network:   Card-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx port: 3000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce port: 2000 bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 640.1GB (34.6% used) ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 640.1GB
           ID-2: /dev/mmcblk0 model: N/A size: 128.6GB
           Optical: /dev/sr0 model: TSST CDDVDW SN-208AB rev: TO04 dev-links: cdrom,cdrw,dvd,dvdrw
           Features: speed: 24x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 142G used: 91G (68%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 440G used: 111G (27%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 6.32GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 67.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 231 Uptime: 2:30 Memory: 1319.4/5851.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

User avatar
Level 5
Level 5
Posts: 635
Joined: Thu Jun 08, 2017 2:31 pm
Location: Top of Georgia

Re: Synaptics Touchpad stopped working

Post by wallyUSA » Mon Sep 18, 2017 1:15 pm

In Cinnamon, we have an applet for Mouse & TouchPad settings. Don't know if you have that in Xfce? Might help to check it out.
Tina 19.2 Cinnamon 4.2.4 Kernel 4.15.0-64 (64 bit). {Dell XPS 13}
Please, if your query has been resolved, edit your first post and add [SOLVED] to the beginning of the subject line. This may help others find solutions.

Level 2
Level 2
Posts: 66
Joined: Fri Mar 24, 2017 1:29 pm
Location: Florida

Re: Synaptics Touchpad stopped working

Post by wedjlok » Mon Sep 18, 2017 1:22 pm

Yes, it's there, and shows the touchpad. Even when I enable it, though, it doesn't work. Same goes for in LXDE.

Post Reply

Return to “Newbie Questions”