[SOLVED] Now I'm pissed off with the sound

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

[SOLVED] Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 2:54 pm

I had Creative SoundBlaster Zx which is reported that does not work with Linux Mint 18.2. I removed the card but the internal sound card also does not work - it is with ALC892 and after searching I found out that it also has problem with linux. And finally I tried to get sound with the HDMI from my video card which is Radeon RX460 and there was no sound as well. Looking for the problem in the forum showed that the sound from this card does not work with Ubuntu and Mint. Is there ANYTHING which can get ANY sound with linux???
Last edited by silfox2000 on Sun Dec 17, 2017 2:37 am, edited 2 times in total.

User avatar
Moem
Level 16
Level 16
Posts: 6803
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Now I'm pissed off with the sound

Post by Moem » Sat Oct 21, 2017 3:02 pm

silfox2000 wrote:Is there ANYTHING which can get ANY sound with linux???
No. You've discovered the horrible truth: none of us have any sound on our computers, at all. :roll:
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 3:13 pm

Off course you have but what is this luck from 3 sound devices none of them to work as it is.

User avatar
Pjotr
Level 20
Level 20
Posts: 10904
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Now I'm pissed off with the sound

Post by Pjotr » Sat Oct 21, 2017 3:14 pm

@Moem: :lol:

@silfox2000: Please generate an overview of your system like this:

- Launch a terminal window (this is how to launch a terminal window);

- make the terminal window full screen, to avoid chopped lines;

- copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

- Press Enter.

- Copy/paste the output in your next message.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 3:27 pm

System: Host: HomePC Kernel: 4.13.0-041300-generic x86_64 (64 bit gcc: 7.2.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya

Graphics: Card: Advanced Micro Devices [AMD/ATI] Device 67ef bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
Resolution: 3840x2160@60.00hz
GLX Renderer: Gallium 0.4 on AMD POLARIS11 (DRM 3.18.0 / 4.13.0-041300-generic, LLVM 4.0.0)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Advanced Micro Devices [AMD/ATI] Device aae0 driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.13.0-041300-generic

Some of the outputs in alsamixer have been muted but I unmuted them. I also tried several recommendations found in the net - installing Realtek drivers, adding lines in alsa-base.conf file, updated the kernel to 4.13... still no sound.

User avatar
Pjotr
Level 20
Level 20
Posts: 10904
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Now I'm pissed off with the sound

Post by Pjotr » Sat Oct 21, 2017 3:40 pm

The full inxi -Fxz output please.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 3:45 pm

Sorry. I though this is the essential information. I wanted to keep it short.

System: Host: HomePC Kernel: 4.13.0-041300-generic x86_64 (64 bit gcc: 7.2.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya
Machine: Mobo: ASUSTeK model: P8Z77-V PRO v: Rev 1.xx Bios: American Megatrends v: 2104 date: 08/13/2013
CPU: Quad core Intel Core i5-2500K (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26476
clock speeds: max: 3700 MHz 1: 3309 MHz 2: 3309 MHz 3: 3309 MHz 4: 3309 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Device 67ef bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
Resolution: 3840x2160@60.00hz
GLX Renderer: Gallium 0.4 on AMD POLARIS11 (DRM 3.18.0 / 4.13.0-041300-generic, LLVM 4.0.0)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Advanced Micro Devices [AMD/ATI] Device aae0 driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.13.0-041300-generic
Network: Card-1: Intel 82579V Gigabit Network Connection driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Card-2: Qualcomm Atheros AR5416 Wireless Network Adapter [AR5008 802.11(a)bgn]
driver: ath9k bus-ID: 06:01.0
IF: wlp6s1 state: down mac: <filter>
Drives: HDD Total Size: 5121.0GB (1.6% used) ID-1: /dev/sda model: WDC_WD1002FBYS size: 1000.2GB
ID-2: /dev/sdb model: KINGSTON_SH103S3 size: 120.0GB
ID-3: /dev/sdc model: WDC_WD1002FBYS size: 1000.2GB
ID-4: /dev/sdd model: ST3000DM001 size: 3000.6GB
Partition: ID-1: / size: 20G used: 6.9G (38%) fs: ext4 dev: /dev/sdb1
ID-2: /home size: 64G used: 44G (72%) fs: ext4 dev: /dev/sdb5
ID-3: swap-1 size: 28.76GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 35.0
Fan Speeds (in rpm): cpu: 0
Info: Processes: 238 Uptime: 10:53 Memory: 3709.2/15987.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

User avatar
Pjotr
Level 20
Level 20
Posts: 10904
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Now I'm pissed off with the sound

Post by Pjotr » Sat Oct 21, 2017 3:46 pm

Did you, by any chance, perhaps install sandbox Firejail?
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 3:55 pm

No, I'm not.

dark
Level 3
Level 3
Posts: 114
Joined: Wed Feb 22, 2017 3:02 pm

Re: Now I'm pissed off with the sound

Post by dark » Sat Oct 21, 2017 4:01 pm

Does the sound work if you boot into Mint live from USB?

User avatar
Pjotr
Level 20
Level 20
Posts: 10904
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Now I'm pissed off with the sound

Post by Pjotr » Sat Oct 21, 2017 4:09 pm

Try pavucontrol:

Code: Select all

sudo apt-get install pavucontrol
Then:

Code: Select all

pavucontrol
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 4:21 pm

dark wrote:Does the sound work if you boot into Mint live from USB?
Nope. Just tried.
Pjotr wrote:Try pavucontrol:

Code: Select all

sudo apt-get install pavucontrol
Then:

Code: Select all

pavucontrol
pavucontrol is the default audio control in xfce and it is installed by default. It says that everything should work just fine but there is no sound at all.

User avatar
JerryF
Level 10
Level 10
Posts: 3072
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Now I'm pissed off with the sound

Post by JerryF » Sat Oct 21, 2017 4:35 pm

External speakers? Check the volume, power.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Sat Oct 21, 2017 5:20 pm

Under Windows everything works fine. Even the monitor, which has speakers, play sound through the display port.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: Now I'm pissed off with the sound

Post by silfox2000 » Mon Nov 20, 2017 11:50 am

Just bought USB sound card Behringer UCA222 and I finally got sound.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: [SOLVED] Now I'm pissed off with the sound

Post by silfox2000 » Sun Dec 10, 2017 9:53 am

I've read that kernel 4.15 is a huge improvement for the AMD graphics cards. So I installed 4.15 RC2 kernel and once again tried to get sound from the graphic card - no luck. It seems that I have to wait for future improvements. I've thought to replace the video card with Nvidia one, but so far I sold my Sound Blaster Zx and bought the Behringer sound card loosing some money and sound quality. If I do the same with the video card, the price to have Linux will become no so cheap. The workaround I figured out was to buy an optical sound cable and to connect the sound bar of the TV with the Behringer sound card. It is not the best solution but much more cheaper than replacing the video card. Hopefully there will be better support for AMD graphics in the future kernels.

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: [SOLVED] Now I'm pissed off with the sound

Post by silfox2000 » Sun Dec 10, 2017 4:03 pm

A little bit like a monologue but after searching a while I found this source: https://github.com/M-Bab/linux-kernel-amdgpu-binaries in which are provided kernels with the most recent amdgpu developments. Now I have sound on the TV through the HDMI and on the monitor through the display port... and I have one extra optical sound cable :mrgreen:

User avatar
silfox2000
Level 2
Level 2
Posts: 93
Joined: Fri Sep 08, 2017 8:13 am

Re: [SOLVED] Now I'm pissed off with the sound

Post by silfox2000 » Wed Dec 13, 2017 4:35 pm

One last update: Since I have installed the 4.14.1 with the latest AMD patches I noted that the system become more stable regarding the hibernating. Before that it often could not resume from hibernating and/or sleeping. So far with the new kernel I hadn't faced that. And something that I've read from the news: With the final release of the 4.15 kernel there will no be need of such modifications because it will contain all this patches.

Post Reply

Return to “Hardware Support”