Issue with dependancy libfontconfig [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Issue with dependancy libfontconfig [SOLVED]

Post by darkkhaine » Sun Dec 10, 2017 6:49 am

I'm trying to install Airwave Vst bridge on a linux mint 18.3 64bits, but the installation stops when trying to install the libfoncconfig dependancy. This is the error i get in the installation process :
/var/cache/apt/archives/libfontconfig1_2.11.94-0ubuntu1.1_i386.deb
After this, synaptic tells me i have a broken package: libgd3:i386

Any idea how to solve this ?
Last edited by darkkhaine on Tue Dec 12, 2017 1:47 pm, edited 1 time in total.
Linux Mint 18.3 Cinnamon 64 bits

User avatar
WharfRat
Level 20
Level 20
Posts: 11549
Joined: Thu Apr 07, 2011 8:15 pm

Re: Issue with dependancy libfontconfig

Post by WharfRat » Sun Dec 10, 2017 11:21 am

It would be better if you try to install that package in the terminal using apt or apt-get and paste the results back here.

The error or whatever it is you're showing is not any help at all :?
ImageImage

darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Re: Issue with dependancy libfontconfig

Post by darkkhaine » Sun Dec 10, 2017 3:05 pm

I tried to install the program with this file (i donwloaded the airwave_1.3.3-1_amd64.deb file and double click on it to install):
https://github.com/phantom-code/airwave/releases

When trying to install, it asks to install several items like libfontconfig1, libgd3 and wine.

How should I proceed from the terminal ?
Linux Mint 18.3 Cinnamon 64 bits

User avatar
WharfRat
Level 20
Level 20
Posts: 11549
Joined: Thu Apr 07, 2011 8:15 pm

Re: Issue with dependancy libfontconfig

Post by WharfRat » Sun Dec 10, 2017 4:39 pm

Change to the folder containing that package file and sudo dpkg -i airwave_1.3.3-1_amd64.deb
ImageImage

darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Re: Issue with dependancy libfontconfig

Post by darkkhaine » Sun Dec 10, 2017 5:46 pm

Thanks for the quick answer. This is what i get:

Code: Select all

sudo dpkg -i airwave_1.3.3-1_amd64.deb
[sudo] password for gregoire: 
(Reading database ... 342445 files and directories currently installed.)
Preparing to unpack airwave_1.3.3-1_amd64.deb ...
Unpacking airwave (1.2.1-2) over (1.2.1-2) ...
dpkg: dependency problems prevent configuration of airwave:
 airwave depends on wine; however:
  Package wine is not installed.
  Package wine1.6 which provides wine is not installed.
  Package wine-rt which provides wine is not installed.

dpkg: error processing package airwave (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 airwave
Linux Mint 18.3 Cinnamon 64 bits

User avatar
WharfRat
Level 20
Level 20
Posts: 11549
Joined: Thu Apr 07, 2011 8:15 pm

Re: Issue with dependancy libfontconfig

Post by WharfRat » Sun Dec 10, 2017 8:04 pm

Well there ya go:

airwave depends on wine; however:
Package wine is not installed.

You would have to first install wine I guess :?
ImageImage

darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Re: Issue with dependancy libfontconfig

Post by darkkhaine » Mon Dec 11, 2017 5:07 pm

I tried that already, but it gives more or less the same issue :?

Code: Select all

sudo apt-get install wine
[sudo] password for gregoire: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libglib2.0-0:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  liborc-0.4-0:i386 lmms-vst-full:i386
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libfontconfig1:i386 libgd3:i386 libgphoto2-6:i386 wine1.6 wine1.6-amd64
  wine1.6-i386:i386
Suggested packages:
  libgd-tools:i386 gphoto2:i386 dosbox:any winbind
Recommended packages:
  gnome-exe-thumbnailer | kde-runtime fonts-droid ttf-mscorefonts-installer
  fonts-horai-umefont fonts-unfonts-core winetricks libcapi20-3 libosmesa6
  unixodbc wine-gecko2.21 wine-mono0.0.8 libcapi20-3:i386 libcups2:i386
  libgif7:i386 libosmesa6:i386 libp11-kit-gnome-keyring:i386 libsane:i386
  libv4l-0:i386 libxcomposite1:i386 libxcursor1:i386 libxi6:i386
  libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386
  p11-kit-modules:i386 unixodbc:i386 wine-gecko2.21:i386 wine-mono0.0.8:i386
The following NEW packages will be installed:
  libfontconfig1:i386 libgd3:i386 libgphoto2-6:i386 wine wine1.6 wine1.6-amd64
  wine1.6-i386:i386
0 upgraded, 7 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/34,0 MB of archives.
After this operation, 250 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package wine1.6-amd64.
(Reading database ... 342437 files and directories currently installed.)
Preparing to unpack .../wine1.6-amd64_1%3a1.6.2-0ubuntu14.2_amd64.deb ...
Unpacking wine1.6-amd64 (1:1.6.2-0ubuntu14.2) ...
Preparing to unpack .../libfontconfig1_2.11.94-0ubuntu1.1_i386.deb ...
Unpacking libfontconfig1:i386 (2.11.94-0ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/libfontconfig1_2.11.94-0ubuntu1.1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libfontconfig1/changelog.Debian.gz', which is different from other instances of package libfontconfig1:i386
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package libgd3:i386.
Preparing to unpack .../libgd3_2.1.1-4ubuntu0.16.04.8_i386.deb ...
Unpacking libgd3:i386 (2.1.1-4ubuntu0.16.04.8) ...
Selecting previously unselected package libgphoto2-6:i386.
Preparing to unpack .../libgphoto2-6_2.5.9-3_i386.deb ...
Unpacking libgphoto2-6:i386 (2.5.9-3) ...
Selecting previously unselected package wine1.6-i386:i386.
Preparing to unpack .../wine1.6-i386_1%3a1.6.2-0ubuntu14.2_i386.deb ...
Unpacking wine1.6-i386:i386 (1:1.6.2-0ubuntu14.2) ...
Selecting previously unselected package wine1.6.
Preparing to unpack .../wine1.6_1%3a1.6.2-0ubuntu14.2_amd64.deb ...
Unpacking wine1.6 (1:1.6.2-0ubuntu14.2) ...
Selecting previously unselected package wine.
Preparing to unpack .../wine_1%3a1.6.2-0ubuntu14.2_amd64.deb ...
Unpacking wine (1:1.6.2-0ubuntu14.2) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for udev (229-4ubuntu21) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libfontconfig1_2.11.94-0ubuntu1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Linux Mint 18.3 Cinnamon 64 bits

User avatar
WharfRat
Level 20
Level 20
Posts: 11549
Joined: Thu Apr 07, 2011 8:15 pm

Re: Issue with dependancy libfontconfig

Post by WharfRat » Mon Dec 11, 2017 6:22 pm

There seems to be some sort of conflict with the libfontconfig1 package

What's returned with dpkg -l libfontconfig1*
ImageImage

darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Re: Issue with dependancy libfontconfig

Post by darkkhaine » Mon Dec 11, 2017 6:54 pm

here's what i get, i didn't remove the broken package yet (don't know if that affects the results or not)

Code: Select all

dpkg -l libfontconfig1*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libfontconfig1 2.11.94-0ubu amd64        generic font configuration librar
in  libfontconfig1 <none>       i386         (no description available)
Linux Mint 18.3 Cinnamon 64 bits

User avatar
WharfRat
Level 20
Level 20
Posts: 11549
Joined: Thu Apr 07, 2011 8:15 pm

Re: Issue with dependancy libfontconfig

Post by WharfRat » Mon Dec 11, 2017 7:34 pm

Try moving that file to your home, it's just a compressed text file of changes - I don't know why it's croaking on it :?

sudo mv -v /usr/share/doc/libfontconfig1/changelog.Debian.gz ~ then run apt-get install --fix-broken
ImageImage

darkkhaine
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 4:16 am

Re: Issue with dependancy libfontconfig [SOLVED]

Post by darkkhaine » Tue Dec 12, 2017 1:43 pm

That solved my problem, many thanks for your help ! :mrgreen:
Linux Mint 18.3 Cinnamon 64 bits

Post Reply

Return to “Software & Applications”