xfce4-panel freeze

Forum rules
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 193
Joined: Fri May 30, 2014 6:44 pm

xfce4-panel freeze

Post by bjmh46 » Tue Dec 12, 2017 7:44 am

Greetings fellow Mint xfce users!
I've been using Mint xfce since Mint 13. Current primary os is Mint 17 64bit xfce which has run flawlessly since ~July 2014. So flawlessly in fact, that I never saw the need to update to any of the 17 point releases. I do have an external hdd with 18.2 fully configured and updated for the inevitable eos of 17.
All that said, my install (on 3 different laptops), has developed the occasional annoyance of having the xfce4 panel "freeze up". Super key will still launch the whisker menu, but nothing else on the panel responds to mouse or touchpad input. Happens often enough that I mapped a keyboard shortcut to restart the panel--which solves the problem. At first I thought it was a hardware problem, but now I've experienced the same thing on multiple laptops. All thinkpads--2 sl510's and my t520 which is my everyday user. A web search seems to indicate that this problem has been around for a while, and may be related to fullscreen mode (which I use a lot in Firefox). I never had the problem before Firefox 57, which may or may not be relevant, but it does occur after watching videos fullscreen in Firefox, although it's not repeatable.
Anyone else experienced this? Obligatory inxi :

Code: Select all

bob@bob-T520 ~ $ inxi -Fxz
System:    Host: bob-T520 Kernel: 3.13.0-135-generic x86_64 (64 bit, gcc: 4.8.4) 
           Desktop: Xfce 4.11.8 (Gtk 2.24.23) Distro: Linux Mint 17 Qiana
Machine:   System: LENOVO (portable) product: 4242W29 version: ThinkPad T520
           Mobo: LENOVO model: 4242W29 Bios: LENOVO version: 8AET66WW (1.46 ) date: 09/20/2016
CPU:       Dual core Intel Core i5-2540M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10365.9 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz 
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.1.0 Direct Rendering: Yes
Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-135-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e ver: 2.3.2-k port: 5080 bus-ID: 00:19.0
           IF: eth5 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi ver: in-tree: bus-ID: 03:00.0
           IF: wlan3 state: up mac: <filter>
Drives:    HDD Total Size: 339.1GB (13.8% used) 1: id: /dev/sda model: Crucial_CT275MX3 size: 275.1GB 
           2: id: /dev/sdb model: Micron_M550_MTFD size: 64.0GB 
Partition: ID: / size: 96G used: 7.9G (9%) fs: ext4 ID: swap-1 size: 8.35GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: 0 
Info:      Processes: 198 Uptime: 3 days Memory: 1088.6/7761.8MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4 
bob@bob-T520 ~ $ 

User avatar
Level 17
Level 17
Posts: 7086
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: xfce4-panel freeze

Post by Flemur » Tue Dec 12, 2017 12:32 pm

bjmh46 wrote:I mapped a keyboard shortcut to restart the panel--which solves the problem
Have you tried running the panel from a terminal in order to see possible error messages?

Code: Select all


Code: Select all

xfce4-panel --disable-wm-check
I run the 2nd one to use the panel (mainly the menu) while running fluxbox.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

Post Reply

Return to “Xfce”