Solved. Meltdown an Spectre kernel upgrade problems

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Thu Jan 18, 2018 4:23 am

Solved. Meltdown an Spectre kernel upgrade problems

Post by Alastairo » Thu Jan 18, 2018 6:03 am

I am using cinnamon and after the kernel upgrade virtualbox and connection to the server gave problems. I don't believe in going backwards, and so decided to fix things instead. I managed to fix virtualbox by upgrading to the latest version from oracle.
The connection to the server is the issue that I now face. Previously I had a link from the desktop to /mnt/server/ and the /etc/fstab was: // /mnt/server cifs username=xxxx,password=xxxxxxxx,_netdev,uid=alastairo,gid=users,auto 0 0 . This had worked perfectly previously, but now doesn't see the files. I can access the server via nemo using smb:// , but this only opens files as read only and it seems that the whole contents of server get uploaded to a temp folder, which takes a long time.
I am not sure where the problem lies - could it be samba or is it something else?. All software is up to date. Any pointers would be appreciated.
Last edited by Alastairo on Fri Jan 19, 2018 2:20 am, edited 1 time in total.

Hoser Rob
Level 15
Level 15
Posts: 5505
Joined: Sat Dec 15, 2012 8:57 am

Re: Meltdown an Spectre kernel upgrade problems

Post by Hoser Rob » Thu Jan 18, 2018 9:21 am

There's almost no useful info there at all. Copy/paste this to the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz

Level 1
Level 1
Posts: 2
Joined: Thu Jan 18, 2018 4:23 am

Re: Meltdown an Spectre kernel upgrade problems

Post by Alastairo » Thu Jan 18, 2018 10:16 am

Code: Select all

alastairo@alastairo-MS-7846 ~ $ inxi -Fxz
System:    Host: alastairo-MS-7846 Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: MSI product: MS-7846 v: 0A
           Mobo: MSI model: H81M-P32L (MS-7846) v: 1.0
           Bios: American Megatrends v: V1.9 date: 03/31/2015
CPU:       Dual core Intel Pentium G3250 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12801
           clock speeds: max: 3200 MHz 1: 3200 MHz 2: 3200 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Atmel AVR ISP mkII usb-ID: 003-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (18.7% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
Partition: ID-1: / size: 910G used: 167G (20%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 191 Uptime: 6:09 Memory: 1327.1/7856.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Meltdown an Spectre kernel upgrade problems

Post by rene » Thu Jan 18, 2018 11:11 am

Recent kernels changed the default SMB protocol version to 3.0; it used to be 1.0. The issue likely is that your server does not speak 3.0. You can specify the version to mount with by adding e.g. "vers=1.0", "vers=2.0" or "vers=2.1" to you fstab line. That is, make it be

Code: Select all

// /mnt/server cifs username=xxxx,password=xxxxxxxx,uid=alastairo,gid=users,vers=2.1,auto 0 0
I'd try 2.1, 2.0 and 1.0 in that order. The above also takes out "_netdev"; it's implied for CIFS when using systemd with no need to be explicit.

Note that the reason the default changed kernel-side is that versions of SMB before 3.0 are insecure and have been recently compromised. No cause for alarm on a private LAN but if non-private you should be aware of this.

Level 1
Level 1
Posts: 12
Joined: Thu Jan 18, 2018 4:08 pm

Re: Meltdown an Spectre kernel upgrade problems

Post by DD4711 » Thu Jan 18, 2018 4:25 pm


I have the same problem. After the update my network shares do not mount.

On my Synology NAS I noticed that there's a setting for SMB version. It was set to "max v 2". I set it to "max v 3" and the shares mount again. BUT after that I have only read access. Other than that mentioned linux update do not exist.

This is my fstab row:

Code: Select all

//NAS.local/sharename /home/user/sharename cifs credentials=/home/.credNAS 0 0
In .credNAS the account details for user on NAS are saved.

Does anyone know where the problem could be?

Post Reply

Return to “Software & Applications”