Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
thx-1138
Level 6
Level 6
Posts: 1273
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by thx-1138 » Sat Jan 06, 2018 10:12 am

Also, if the problem was caused by my connection or router, I would expect the video to stop to buffer, but it doesn't do that; it just skips for about half a second, then goes back to normal.
somelurker, if that happens under Firefox, you might also want to play around with layers.acceleration.force-enabled in about:config: sometimes when it's enabled, it returns problems when rendering video (and not only).

Still, the underlying graphics' stack should be updated & the drivers configured properly, if nothing else, just for being on the safe side & the sake of good practice...if such is the case, open Update Manager, and set your policy to show everything for the time being. Refresh...and if you see anything related to Mesa and Pulseaudio, select it & update it. A reboot afterwards wouldn't hurt...
I don't have an NVidia card myself, so i can't really recommend anything specific in regards to the drivers available for such & how to further configure them...try the above first, and we'll see afterwards...

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Mon Jan 08, 2018 9:15 am

Ok, so I updated my BIOS, but the stuttering actually got worse with the latest version of 4.4.

Then, I upgraded to the latest version of 4.13 using only the official Update Manager. Now I could be wrong because the problem is intermittent, but based on listening for roughly 30 minutes (which would be a record if the stuttering was still there), I think my sound is finally normal.

What a nightmare it was for me to have to go through all this. If I'm right that the stuttering is gone, it took a BIOS flash (I had to do this from Windows by the way) and a kernel update to the latest officially supported version to fix the problem! If you don't mind me asking, Pjotr and thx-1138, how did you two gain the experience you have now? I've done quite a bit of poking around since switching to Linux, and I'm mostly comfortable with the terminal but whenever I have a problem that seems so simple like stuttering sound, I feel so lost.

I don't mind if your answer is that you had to read multiple books or get a degree in IT or computer science. I just want to know what it would take to really get comfortable with Linux. How did the kernel and BIOS even occur to you two as possible problems? I was trying to fix the problem with potential solutions that were completely wrong, such as installing experimental versions of the Alsa driver and disabling dynamic CPU frequency scaling. Nothing I tried worked. Until now.

I would like to add, by the way, that the support in this community is amazing. It might help explain why Mint is #1: https://distrowatch.com/

Edit: I'm at 40 minutes. Still no sign of stuttering. I think it's gone for good this time.

User avatar
Pjotr
Level 20
Level 20
Posts: 11059
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by Pjotr » Mon Jan 08, 2018 10:18 am

somelurker wrote:If you don't mind me asking, Pjotr and thx-1138, how did you two gain the experience you have now? I've done quite a bit of poking around since switching to Linux, and I'm mostly comfortable with the terminal but whenever I have a problem that seems so simple like stuttering sound, I feel so lost.

I don't mind if your answer is that you had to read multiple books or get a degree in IT or computer science. I just want to know what it would take to really get comfortable with Linux.
Well, I'm strictly an amateur, without any professional or educational qualifications in computing.... I do have almost twelve years of hands-on experience with desktop Linux (mainly the *buntu's and their derivatives). Since the summer of 2006, I've only used Windows for updating my navigation device. :)

So no worries: all it takes is some experience. Or access to people who have that experience. Note that really tough problems like yours, are rare nowadays, thankfully.

This forum may be full of problems, but you rarely hear the people who have no problems at all with Linux Mint. I suspect that's the majority.
Edit: I'm at 40 minutes. Still no sign of stuttering. I think it's gone for good this time.
Good to hear! :)
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Wed Jan 10, 2018 1:00 am

Well, unfortunately, it looks like I spoke too soon again. After a reboot, I noticed stuttering happening again. But at least some progress has been made. Why don't we start fresh? Let me show the new output of inxi -Fxz now with the BIOS update and new kernel version reflected. Again, everything down to audio has been included:

Code: Select all

System:    Host: 123PC Kernel: 4.13.0-21-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18 Sarah
Machine:   Mobo: HP model: 2B4B v: 1.04 Bios: AMI v: A0.57 date: 08/09/2017
CPU:       Quad core Intel Core i7-6700 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27264
           clock speeds: max: 4000 MHz 1: 3400 MHz 2: 3400 MHz 3: 3400 MHz
           4: 3400 MHz 5: 3400 MHz 6: 3400 MHz 7: 3400 MHz 8: 3400 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on NV124
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GM204 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-21-generic
I did further testing to rule out network issues. I played an audio file stored locally, and the stuttering was still there. This rules out the possibility of a network problem (e.g. router or connection) and Firefox being the cause.

Based on thx-1138's suggestions, I updated everything possible in Update Manager, including levels 4 and 5. There was a bunch of mesa stuff, but nothing involving pulseaudio. I still updated everything just in case something was relevant though.

Despite all this, the stuttering is still there. What other factors could be causing this? I've already risked having to reinstall my entire operating system by installing a kernel not officially supported by Mint (though I later removed it when it didn't fix the problem), so I do want this fixed pretty badly.

This time, I'm going to test for many hours and across reboots before I say this is solved.

Edit: I have a new theory. I don't think I was imagining things when I ran the 40-minute test. I don't think there were any problems with my sound during that test. However, I do system updates on a regular basis, and I can't rule out that I updated something between the stutter-free test and the time the stuttering returned.

My theory is that updates may be causing sound to break; that some kernel versions work and others don't. Assuming updates cause the problem to come back, what kinds of updates might be the culprit? If I find that a kernel update is the problem, should I just stick to a working kernel version rather than always chasing the latest supported official kernel, or could newer non-kernel software eventually cause the same problem due to incompatibility with an older kernel? I guess I'm trying to figure out if the kernel alone could be the problem, or whether other a combination of other software and the kernel may be to blame.

User avatar
phd21
Level 17
Level 17
Posts: 7486
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by phd21 » Thu Jan 18, 2018 12:51 pm

Hi "somelurker",

I just replied to your other post on this, please read it and respond.

It is really easy to test if a Linux Kernel is a problem, just reboot, and select another Kernel and see if the issues exist in that Kernel.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

phelest
Level 1
Level 1
Posts: 17
Joined: Sun Jul 22, 2012 7:44 pm
Location: Nuremberg / Germany

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by phelest » Fri Jan 19, 2018 9:05 pm

Is there a difference when disabling WLAN and using LAN ?
LinuxMint 18 definitely has a quite unfriendly problem with video streaming when using dedicated WLAN-HW - which LinuxMint 17 does not have at all!
This can be stated at least when older WLAN-HW is used, i.e. Lenovo Thinkpad T60 (Mate 32-bit) or P5W DH Deluxe of ASUS Digital Home Series (Mate 64-bit), while there is absolutely no problem when using LAN! ==> Activate the Netspeed Applet in the Panel and watch the Device Details to check when using WLAN!
Last edited by phelest on Sat Jan 20, 2018 8:08 am, edited 1 time in total.

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Fri Jan 19, 2018 9:50 pm

go to .config/pulse/ and delete everything except presets folder if you have one and reboot
if still the same try to mute the microphone

sometimes when sound goes bad all you need to do is LOG OFF/ON
Image

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 12:41 am

phelest wrote:Is there a difference when disabling WLAN and using LAN ?
LinuxMint 18 definitely has a quite unfriendly problem with video streaming when using dedicated WLAN-HW - which LinuxMint 17 does not have at all!
This can be stated at least when older WLAN-HW is used, i.e. Lenovo Thinkpad T60 (Mate 32-bit) or P5W DH Deluxe of ASUS Digital Home Series (Mate 64-bit),
while there is absolutely no problem when using LAN! ==> Activate the Netspeed Applet in the Panel and watch the Device Details to check when using WLAN!
I am not using wireless LAN, though it is enabled. I set Wi-Fi to not automatically connect to my router, so only manual connections are possible. This computer uses LAN all the time, except for testing purposes. In any case, I used a media player to play a locally stored sound file and had the same stuttering problem, so unless the mere existence of Wi-Fi is interfering with the sound, including for sound that doesn't require any network access to play, it's unlikely to be the cause.
trytip wrote:go to .config/pulse/ and delete everything except presets folder if you have one and reboot
if still the same try to mute the microphone

sometimes when sound goes bad all you need to do is LOG OFF/ON
I've rebooted many times. The problem never goes away. I also muted the microphone just now to test, and the problem is still there. There is no presets folder, but what are those files I would be deleting? Are they important?

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sat Jan 20, 2018 12:57 am

the files in .config/pulse/ are temporary sound memory and will come back after reboot. have you installed the nvidia graphics drivers?
Image

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 1:02 am

I have not. Do I need them if I'm not using HDMI as my sound output? I'm just using the motherboard's stereo jack. Under sound preferences, the device I have picked for sound output is the "built-in audio analog stereo" instead of HDMI, so I didn't think the Nvidia driver mattered.

By the way, I renamed the .config/pulse folder (probably the same as deleting it). I'm testing now, but with an intermittent problem like this it will be a while before I can report results. The only way to have fast results is if it's bad news; i.e. the stuttering happens right away, but it hasn't yet, so I have to keep testing.

By the way, I just wanted to say I really appreciate all the input everyone is giving me, regardless of whether it's working or not. Even a suggestion that didn't work or was ruled out helps me learn more about this problem. So thanks, and please keep the comments coming! I read everything carefully.

Edit: I just finished testing with the newly regenrated .config/pulse folder. I muted the microphone before rebooting, and it is still muted, but the stuttering is still there.

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sat Jan 20, 2018 3:17 am

go to Driver manager and install the intel microcode and nvidia graphics recommended

this may not be a linux issue but hardware interference. look in .xsession-errors there may be info about pulse or audio. search the text for that
Image

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 3:34 am

I just looked in the file, but because it's about 1000 lines, I just did a search for "audio" and "pulse", but neither of the words were found.

I'm installing the recommended drivers for Nvidia and the Intel microcode you suggested now. I'll report back as soon as I have results. By the way, if something drastic happens, is there any way I can recover the system without having to wipe the hard drive and reinstall everything? Presumably I can just hold shift, enter some kind of recovery mode, and uninstall the packages right?

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sat Jan 20, 2018 3:43 am

before making changes open Timeshift and create snapshot then you can restore
Image

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 3:50 am

Well, I installed both recommended drivers, but I don't think they like my system. After rebooting, I got a whole bunch of ACPI errors. I am lucky to be back in my system. I still need to test the sound.

Edit: The stuttering is still here. I guess I will uninstall both those drivers now because they aren't playing nice with my system. It was worth a try though! I do have data backed up, so I was willing to try a potentially fatal fix, but I still don't want to have to go through the trouble of reinstalling all my apps.

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sat Jan 20, 2018 12:59 pm

you need the microcode for the meltdown and spectre bug but the nvidia drivers are optional although recommended. you can also delete .xsession-errors it will populate again on next reboot and sounds like you need to look into it and see if anything pops out
Image

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 407
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by Joe2Shoe » Sat Jan 20, 2018 8:33 pm

Had this same audio "stuttering" issue while watching YouTube videos on a client's laptop with Windoze 10. I found that the Broadcom WiFi card was shot, so I installed a new identical one which works a wee-bit better, but still "stuttering". So I installed a USB WiFi adapter and the "stuttering" quit. Worthless Broadcom adapters and/or a bad mobo.
Also installed LM18.3 Cinnamon 64-bit dual-boot. Broadcom WiFi was pulling 3-30% connection with downloads of 1.5MBs in Windoze & LM, if it worked at all. USB WiFi adapter was pulling 73% connection with downloads of 17.5MBs in Windoze & LM.
Go figure. Cheap Toshiba Satellite "economy" laptop, super flimsy. The DVDRW drive did not work in either Windoze or LM and the "red" WiFi indicator light never turned "green".
Most times the online videos "stuttering" issue is caused by slow WiFi intenet connection, but not always.
Hope this helps.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 8:53 pm

Joe2Shoe wrote:Had this same audio "stuttering" issue while watching YouTube videos on a client's laptop with Windoze 10. I found that the Broadcom WiFi card was shot, so I installed a new identical one which works a wee-bit better, but still "stuttering". So I installed a USB WiFi adapter and the "stuttering" quit. Worthless Broadcom adapters and/or a bad mobo.
Also installed LM18.3 Cinnamon 64-bit dual-boot. Broadcom WiFi was pulling 3-30% connection with downloads of 1.5MBs in Windoze & LM, if it worked at all. USB WiFi adapter was pulling 73% connection with downloads of 17.5MBs in Windoze & LM.
Go figure. Cheap Toshiba Satellite "economy" laptop, super flimsy. The DVDRW drive did not work in either Windoze or LM and the "red" WiFi indicator light never turned "green".
Most times the online videos "stuttering" issue is caused by slow WiFi intenet connection, but not always.
Hope this helps.
But the Wi-Fi adapter in question was being used to stream a video right? I use a LAN connection more than 99% of the time, so the only way Wi-Fi could be the problem is if its mere existence on the system (e.g. drivers) was causing audio to stutter. Also, I found that the problem happened even when I was using an offline media player to play a locally stored file.
trytip wrote:you need the microcode for the meltdown and spectre bug but the nvidia drivers are optional although recommended. you can also delete .xsession-errors it will populate again on next reboot and sounds like you need to look into it and see if anything pops out
This sounds like a fairly crucial security problem. I'll see if the errors come back without the nvidia driver. By the way, why isn't a critical security update like this in update manager? Am I affected by meltdown/spectre if I choose "do not use this device" instead of intel-microcode?

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 407
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by Joe2Shoe » Sat Jan 20, 2018 9:08 pm

Yes, they are using WiFi only. Watching offline (downloaded) videos tells me it's a video card or driver issue or maybe the video is corrupt (that happens sometimes when I watch a downloaded video later on, so I have to download it again) or something is hogging your resources.
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

somelurker
Level 2
Level 2
Posts: 99
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 20, 2018 9:26 pm

Well, I reinstalled intel-microcode without any kind of problem. The cause of all those errors must have been the recommended Nvidia driver. Unless not having the Nvidia driver is causing sound issues even when my speakers are connected only to a stereo audio output on the motherboard (not the Nvidia card), I would rather not use the driver. I still did have the driver installed just to test, and found that the recommended Nvidia driver did not prevent stuttering.

Aside from "audio" and "pulse", should I be looking for anything else in .xsession-errors?

User avatar
trytip
Level 8
Level 8
Posts: 2484
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sun Jan 21, 2018 12:02 am

it's hard to know what exactly this shuttering would sound like on my end and how to troubleshoot it. it may be some bad connection or a bad config file.
let's try a weird test to install a sound compressor it will not break your system and can be deleted with no issues.
first lemme know the output of this info command in terminal

pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2
(i usually delete .xsession-errors and reboot wait till everything starts and not open anything but .xsession-errors sometimes there is useful info sometimes it's just techno-garble what's your say on fresh session after deleting and rebooting?
Image

Post Reply

Return to “Sound, Multimedia, & Codecs”