Radeon R7 M265 in Mint 18.3

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Wed Jan 31, 2018 11:25 am

Radeon R7 M265 in Mint 18.3

Post by maladict » Wed Jan 31, 2018 12:13 pm

Hi everyone. This topic has been discussed before and I usually solve this kind of problems looking for the answers on the Internet, but this time I really need some help.

I can't install the graphic driver for my laptop. It is a Dell Inspiron from 2015. My GPU is an AMD Radeon R7 M265.

Code: Select all

 # sudo lspci -v
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
	Subsystem: Dell Broadwell-U Host Bridge -OPI
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information: Len=0c <?>
	Kernel driver in use: bdw_uncore

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Dell Broadwell-U Integrated Graphics
	Flags: bus master, fast devsel, latency 0, IRQ 49
	Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 5000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915
	Kernel modules: i915


04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] (rev ff) (prog-if ff)
	!!! Unknown header type 7f
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu
Some relevant information: I have been using Debian Stretch up to this week. It looks like the AMDGPU driver was included in the package linux-firmware for Debian Stretch, and it worked out of the box: install that package and that's it. I could even play some games from steam demanding a decent GPU performance. Last week I had this weird problem: whenever I open a plain text editor (kile or gedit, for instance) I get screen glitch and tearing. The same would eventually happen after some minutes using my laptop so it is probably not related to these editors. I tried reinstalling Debian Stretch and got the same problem BEFORE installing the linux-firmware package.

My next step was trying linuxmint 18.3. After installing linux-firmware I found that the AMDGPU driver is not included (this is a well-known problem that I was unaware of).

Code: Select all

 # sudo lshw -c video

       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:d0000000-d0ffffff memory:c0000000-cfffffff ioport:5000(size=64) memory:c0000-dffff

Code: Select all

 # lspci -nnk | grep -i vga -A3 | grep 'in use'
	Kernel driver in use: i915
After looking for some answer on the Internet, I learned that AMD had released the AMDGPU-PRO driver. I downloaded it and followed the instructions from viewtopic.php?t=248059 and viewtopic.php?f=59&t=242474, that is: edit the file amdgpu-pro-install and replace 'ubuntu' instances with 'linuxmint'. The driver installs without any error. After rebooting, I get the message cinnamon just crashed you are currently running in Fallback Mode. It asks me to restart cinnamon and it will not work no matter if I choose 'yes' or 'not'. So I am stuck at this point.

Thanks for reading. I would appreciate any help!

Level 14
Level 14
Posts: 5496
Joined: Sun Aug 09, 2015 10:00 am

Re: Radeon R7 M265 in Mint 18.3

Post by deepakdeshp » Wed Jan 31, 2018 1:38 pm

AMD supports the listed processors on Linux. Please check for yours.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Level 1
Level 1
Posts: 3
Joined: Wed Jan 31, 2018 11:25 am

Re: Radeon R7 M265 in Mint 18.3

Post by maladict » Wed Jan 31, 2018 2:17 pm

These are the supported processors for the R7 M265:

CentOS (​64-bit)
​RHEL ​​(32-bit | ​64-bit)
SLED/SLES 12 SP2 (​64-bit)
Ubuntu ​16.04 ​​(​64-bit)
Ubuntu ​15.04 ​​(32-bit | ​64-bit)​
​Ubuntu 14.04.2​​​ ​​(32-bit | ​64-bit)
​Ubuntu 12.04.4 LTS​​ ​​(32-bit | ​64-bit)
​​Linux​ ​​(32-bit | ​64-bit)

I have already tried Ubuntu ​16.04 ​​(​64-bit) (I had to edit a file in order to start the installation). After installing that one, cinnamon crashes and goes into fallback mode, and asks me to restart. If I click yes it refreshes the same message, if I click no the message leaves and nothing happens.

I am not sure whether ​​Linux​​ 64-bit would be more suitable for me, or whether I should try Ubuntu ​16.04 ​​(​64-bit) again.

Level 1
Level 1
Posts: 3
Joined: Wed Jan 31, 2018 11:25 am

Re: Radeon R7 M265 in Mint 18.3

Post by maladict » Mon Feb 05, 2018 10:50 am

I've that my problem is due to the kernel linux-image-4.9.0-4-amd64. Just in case someone looks for this problem and finds this post: the topic has been discussed in the following link https://bugs.debian.org/cgi-bin/bugrepo ... bug=878221.

The workaround is downgrading the kernel and booting linux-image-4.9.0-3-amd64. I hope this is fixed in the next versions of the kernel.

I have tried installing the ubuntu drivers for my GPU from the AMD site in mint 18.3. Cinnamon keeps crashing at startup. I don't know whether this is a common problem, and cannot find a solution in this forums. I will definitely have to move back to debian.

Post Reply

Return to “Hardware Support”