[SOLVED] Mint doesn't boot on Lenovo Yoga 300

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
MrPantera
Level 1
Level 1
Posts: 22
Joined: Wed Jan 31, 2018 5:08 pm

[SOLVED] Mint doesn't boot on Lenovo Yoga 300

Post by MrPantera » Wed Jan 31, 2018 7:29 pm

Hi all,

I installed from a USB bootable device Linux Mint 64 bit on a laptop Lenovo Yoga 300. The installation seems all right, but I cannot boot from hard disk now. I have found this:

viewtopic.php?f=46&t=255722&p=1378623&h ... 0#p1378623

so I partitioned the HDD in that way, then I tryed to use Boot Repair, but this did'n fix the problem. Apparently there is a problem in the HDD of the laptop: it is 'mmcblk0', somenthing like a SD card and this is a problem for GRUB. Before that, I had already tried to use Boot Repair but I couldn't fix the problem.

Does anybody know how to make it work?

THanks
Last edited by MrPantera on Mon Feb 05, 2018 3:11 am, edited 1 time in total.

deepakdeshp
Level 16
Level 16
Posts: 6053
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint doesn't boot on Lenovo Yoga 300

Post by deepakdeshp » Thu Feb 01, 2018 12:52 am

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
michael louwe
Level 10
Level 10
Posts: 3300
Joined: Sun Sep 11, 2016 11:18 pm

Re: Mint doesn't boot on Lenovo Yoga 300

Post by michael louwe » Thu Feb 01, 2018 4:50 am

@ MrPantera, .......
MrPantera wrote:...
.
Try the fix at this link ... viewtopic.php?f=46&t=256446

or install in Legacy BIOS mode ... viewtopic.php?f=46&t=258959

MrPantera
Level 1
Level 1
Posts: 22
Joined: Wed Jan 31, 2018 5:08 pm

Re: Mint doesn't boot on Lenovo Yoga 300

Post by MrPantera » Thu Feb 01, 2018 8:54 am

Thank you for your anwers! I will soon try them and post a feedback.

MrPantera
Level 1
Level 1
Posts: 22
Joined: Wed Jan 31, 2018 5:08 pm

Re: Mint doesn't boot on Lenovo Yoga 300

Post by MrPantera » Thu Feb 01, 2018 5:51 pm

Hi all,

Thanx everybody for your support. I managed to fix the problem by looking at your links.

Following I repeat what I have done (maybe I am not very accurate in writing it but I hope it will be clear enough):

1) I set the Bios on UEFI and booted from USB key Mint 18.3 64 bit

2) During Mint install setup, I made a 512Mb partition EFI , a larger partition partition for the OS and a 4Gb partition for the swap area.

3) When the installation was completed, I installed Grub on the EFI partition. I used Boot-Repair. I installed a UEFI grub on the EFI partition, then I clicked on OK and I followed ALL the steps I was given by Boot Repair.

4) I restarted the laptop (the Bios was still in UEFI mode) and Linux Mint booted.... but....

But I could'nt log in with my user name!!! Why??? I repeated this steps twice (I was afraid I didn't write the right password). But nothing.

So in the end I installed Ubuntu 16.04 64 bit and now it's all righ.

So strange. I can consider this topic closed, but the problem of the login at the end was so disappointing.... :-(

Post Reply

Return to “Installation & Boot”