[Solved]Intermittent DNS problem causing broken internet.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

[Solved]Intermittent DNS problem causing broken internet.

Post by Charlie » Sat Feb 03, 2018 12:40 pm

I think my internet is being broken by the fact the DNS servers that I added via "Network Settings" in the start menu is losing those values. I use 8.8.8.8 and 8.8.4.4. Intermittently those values vanish and I revert to something like 127.0.1.1 which then leads to my internet becoming unavailable.

After I enter the DNS servers manually and lock them using that facility in Network Settings.

I have also added them in "Edit Connections" via the icon in my taskbar. Those remain unaffected but do not seem to be influential. As soon as I go into "Network Settings" and place the DNS servers in the functionality is restored.

I am using a fresh install.

Code: Select all

 charlie@charlie-ThinkPad-X61 ~ $ inxi -Fxz
System:    Host: charlie-ThinkPad-X61 Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO (portable) product: 76757KU v: ThinkPad X61
           Mobo: LENOVO model: 76757KU
           Bios: LENOVO v: 7NETC1WW (2.21 ) date: 10/09/2009
CPU:       Dual core Intel Core2 Duo T7300 (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 7979
           clock speeds: max: 2001 MHz 1: 1200 MHz 2: 1200 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x768@60.00hz
           GLX Renderer: Mesa DRI Intel 965GM
           GLX Version: 2.1 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel 82566MM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 1840 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           driver: iwl4965 v: in-tree: bus-ID: 03:00.0
           IF: wls3 state: up mac: <filter>
Drives:    HDD Total Size: 324.1GB (2.9% used)
           ID-1: /dev/sda model: Hitachi_HTS54501 size: 160.0GB
           ID-2: /dev/sdb model: WDC_WD1600BEVS size: 160.0GB
           ID-3: USB /dev/sdc model: USB_Flash_Disk size: 4.0GB
Partition: ID-1: / size: 144G used: 5.7G (5%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 472M used: 129M (29%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 3.19GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: 38.0C
           Fan Speeds (in rpm): cpu: 3415 fan-2: 4947
Info:      Processes: 185 Uptime: 1:21 Memory: 871.6/2976.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
charlie@charlie-ThinkPad-X61 ~ $ 
 
Last edited by Charlie on Tue Feb 06, 2018 4:51 pm, edited 1 time in total.

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Intermittent DNS problem causing broken internet.

Post by minitux » Sat Feb 03, 2018 12:47 pm

Code: Select all

sudo nano /etc/resolvconf/resolv.conf.d/head
add to file those lines

Code: Select all

nameserver 8.8.8.8
nameserver 8.8.4.4
save with Ctrl+o+enter and close with Ctrl+x and in the end

Code: Select all

sudo resolvconf -u
and reboot

in the first command you can sobstitute nano with your text editor.

User avatar
trytip
Level 11
Level 11
Posts: 3566
Joined: Tue Jul 05, 2016 1:20 pm

Re: Intermittent DNS problem causing broken internet.

Post by trytip » Sat Feb 03, 2018 12:56 pm

sudo nano /etc/NetworkManager/NetworkManager.conf

comment out dns like this and reboot
[main]
plugins=ifupdown,keyfile,ofono
#dns=dnsmasq
Image

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sat Feb 03, 2018 1:30 pm

Thanks very much I will try each of those suggestions.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sat Feb 03, 2018 5:03 pm

I have implemented both of those suggestions but I don't think the problem is entirely 100% fixed. So I cannot say "solved" just yet.

The vanishing DNS servers has been solved.

I was wondering if my router set-up may be contributing to this broken internet problem. I have two routers linked together via an Ethernet cable, only one has DHCP enabled, the modem router supplied by my ISP, the other has a static IP.

On the second router I have DD-WRT installed and DNSmasq etc was enabled, I have now tried disabling the three settings that were of relevance.

There has been no problem so far, so, so far so good.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sun Feb 04, 2018 7:42 am

It seems to be forgetting my WiFi password now. I have enabled WDS/Connection Watchdog on my router which attempts to keep alive the connection, I think it pings the IP address which I have entered, if no reply, it reboots the router.

No idea why the password would be vanishing.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sun Feb 04, 2018 8:05 am

Screenshot at 2018-02-04 11-55-43.png
It's adding multiple copies of my WiFi connection all by itself.
Screenshot at 2018-02-04 11-55-43.png (23.6 KiB) Viewed 332 times

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sun Feb 04, 2018 2:53 pm

Seems to be working perfectly, but I can't decide what I did that solved it. I deleted all but one instance of WiFi connection as detailed in graphic above, then I altered the name of the remaining instance to "dd-wrt", I lost the "1".

Either that did it OR the "keep alive" tweak on my router did. But, for now, it is looking like solved. Will update when definite and close thread.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Sun Feb 04, 2018 3:05 pm

Screenshot at 2018-02-04 19-02-59.png
Two WiFi devices listed now, I was using the later but now the first.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Mon Feb 05, 2018 8:44 am

It seems like upgrading to "Sylvia" has solved this issue. Perhaps "Sonya" doesn't play well with the latest Kernel.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Tue Feb 06, 2018 9:50 am

Just did a factory reset of router and a 30-30-30 hoping that will aid connectivity. So far so good.

dwburt
Level 1
Level 1
Posts: 11
Joined: Sat Oct 14, 2017 5:27 pm

Re: Intermittent DNS problem causing broken internet.

Post by dwburt » Tue Feb 06, 2018 11:45 am

What's 30-30-30?

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Tue Feb 06, 2018 11:49 am

dwburt wrote:What's 30-30-30?
You reset the router by holding a pin or something into the relevant hole. The unit resets to default but you keep holding the pin in position until a count of 30, then unplug the router from the power source and carry on holding for another count of 30, then plug in and carry on holding for another count of 30.

Apparently this clears up any junk retained during a firmware upgrade. Which are frequent in DD-WRT.

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Tue Feb 06, 2018 11:59 am

Charlie wrote:
dwburt wrote:What's 30-30-30?
You reset the router by holding a pin or something into the relevant hole. The unit resets to default but you keep holding the pin in position until a count of 30, then unplug the router from the power source and carry on holding for another count of 30, then plug in and carry on holding for another count of 30.

Apparently this clears up any junk retained during a firmware upgrade. Which are frequent in DD-WRT.
https://www.dd-wrt.com/wiki/index.php/H ... r_30/30/30

Charlie
Level 4
Level 4
Posts: 321
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: Intermittent DNS problem causing broken internet.

Post by Charlie » Tue Feb 06, 2018 4:50 pm

Happily I am now calling this solved. The 30-30-30 looks to have completed my fix. Apparently the same thing can be achieved via Telnet and the Terimal, just log into the router and type the commands "erase nvram" then "reboot".

Post Reply

Return to “Newbie Questions”