Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 2:44 am

Hello,

I just transitioned from Windows 10 to Linux so please bear with me if the questions sound stupid or if I ask for simpler or easier instructions.

My Windows 10 laptop was rendered unusable even before I could equip myself with beginner's knowledge required for Linux mint like playing around with linux in VM's. Nevertheless, I purchased a new laptop - Dell i3-6th Gen, 4Gb RAM, 1TB HDD and not so sure about the graphics card. This one came pre installed with Ubuntu latest LTS. On using it I found it a bit difficult for some one like me who has never used linux before. Hence, I created a LIve USB while still using Ubuntu and used LM 18.3

After all the trouble with the installation and no bootable devices due to UEFI and Legacy fiasco, I was able to start the system properly and it booted from the HDD. I updated the system using Update manager. Now, when I clicked Driver Manager, it prompted the screen for Intel Micro code or Do not use it. I selected Intel MIcro code and restarted the system. Since then, the system boots, I can hear the start up sound, Caps Lock key and Mouse LED light switches on but there is no Display and only a Black Screen. I tried rebooting multiple times thinking it might be a boot issue but it didnt help.

I started the Live USB and the system worked fine. I tried searching on LM forums and other links on google but could not find helpful instructions or maybe I used wrong search terms, not sure.

Please advise on how to fix this issue. Also, as I just moved to LM, I am still learning the beginner's guide, trying to familiarize myself with bootloader,grub and other aspects. So please be considerate while helping. Thanks.

User avatar
slipstick
Level 5
Level 5
Posts: 569
Joined: Sun Oct 21, 2012 9:56 pm
Location: Somewhere on the /LL0 scale

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by slipstick » Tue Feb 20, 2018 4:48 am

Maybe some help here:
viewtopic.php?f=49&t=261748

and the link referenced in the second post in that thread (a grub parameter is all that will be needed):
https://wiki.debian.org/Microcode#Worki ... de_updates

Recovery procedure here:
http://metadata.ftp-master.debian.org/c ... DME.Debian
In theory, theory and practice are the same. In practice, they ain't.

User avatar
michael louwe
Level 8
Level 8
Posts: 2020
Joined: Sun Sep 11, 2016 11:18 pm

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by michael louwe » Tue Feb 20, 2018 5:05 am

@ Mike619, .......
Mike619 wrote:...
.
Likely, your computer was affected by this issue ... http://www.zdnet.com/article/intel-stop ... er-notice/ (23 Jan 2018 - intel-stop-firmware-patching-until-further-notice/).

Looks like, you need to reinstall LM = boot the Live LM USB/DVD,... use the manual "Something else" install option, delete all the LM partitions on the 1TB internal hard-drive and repartition the newly created free space accordingly, eg 50GB for / or Root, 200GB for Home and 6GB for Swap.
....... Ensure that the "Device for boot loader installation" is the EFI Boot Partition(= fat32/about 200MB in size/flagged as boot/efi or boot, esp) which is usually at dev/sda1.

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 9:14 am

@slipstick - I tried the instructions but the system boots to LM and there is no other screen showing up as indicated in the link. I cannot access the grub as instructed.

Please advise..
slipstick wrote:
Tue Feb 20, 2018 4:48 am
Maybe some help here:
viewtopic.php?f=49&t=261748

and the link referenced in the second post in that thread (a grub parameter is all that will be needed):
https://wiki.debian.org/Microcode#Worki ... de_updates

Recovery procedure here:
http://metadata.ftp-master.debian.org/c ... DME.Debian

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 9:15 am

@michael louwe - I thank you for your instructions and thought of reinstalling as a last resort.
michael louwe wrote:
Tue Feb 20, 2018 5:05 am
@ Mike619, .......
Mike619 wrote:...
.
Likely, your computer was affected by this issue ... http://www.zdnet.com/article/intel-stop ... er-notice/ (23 Jan 2018 - intel-stop-firmware-patching-until-further-notice/).

Looks like, you need to reinstall LM = boot the Live LM USB/DVD,... use the manual "Something else" install option, delete all the LM partitions on the 1TB internal hard-drive and repartition the newly created free space accordingly, eg 50GB for / or Root, 200GB for Home and 6GB for Swap.
....... Ensure that the "Device for boot loader installation" is the EFI Boot Partition(= fat32/about 200MB in size/flagged as boot/efi or boot, esp) which is usually at dev/sda1.

User avatar
Pjotr
Level 20
Level 20
Posts: 10060
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Pjotr » Tue Feb 20, 2018 9:38 am

Before re-installing, you might try removing microcode files manually, from within a live session of the Mint DVD. It's what I would try myself. Note: this hack is untested by me, risky and experimental. So proceed at your own risk!

Boot from the Mint DVD and mount your root partition. For example, if your root partition is on sda5:

Code: Select all

sudo mount /dev/sda5 /mnt
Then remove everything in this folder in the root partition on the hard disk:
/lib/firmware/intel-ucode

Reboot and try to boot from the hard disk again.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 9:51 am

@Pjotr - what kind of risks are we talking that might come up ?
Pjotr wrote:
Tue Feb 20, 2018 9:38 am
Before re-installing, you might try removing microcode files manually, from within a live session of the Mint DVD. It's what I would try myself. Note: this hack is untested by me, risky and experimental. So proceed at your own risk!

Boot from the Mint DVD and mount your root partition. For example, if your root partition is on sda5:

Code: Select all

sudo mount /dev/sda5 /mnt
Then remove everything in this folder in the root partition on the hard disk:
/lib/firmware/intel-ucode

Reboot and try to boot from the hard disk again.

User avatar
thx-1138
Level 5
Level 5
Posts: 616
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by thx-1138 » Tue Feb 20, 2018 10:14 am

...Pjotr is correct, this will remove the microcode files in question. The risk is that there might be hooks to them to the kernel, and maybe it doesn't load afterwards. But since it already doesn't do so correctly...

Did you tried editing the grub parameter as instructed in the Debian's site?
Press Shift repeatedly after powering up, it should land you in Grub's menu (the bootloader). If shift doesn't do the trick, try ESC.
Use 'e' to edit, change "quiet splash" to "dis_ucode_ldr", you're set.

Alternative method: get into Recovery Mode, again by either Shift and/or ESC after powering up.
Execute mount -o remount,rw /, then sudo apt-get purge intel-microcode. That's all.

Of course you can choose the nuclear option and reinstall completely as well...

Cosmo.
Level 23
Level 23
Posts: 17632
Joined: Sat Dec 06, 2014 7:34 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Cosmo. » Tue Feb 20, 2018 10:20 am

I suggest, instead of removing the content of the folder intel-ucode, to rename this folder to intel-ucode.bck. This leaves the possibility to revert the step.

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 12:01 pm

Finally was able to get the Grub option, although its very tricky and does not always allow to Edit the grub and goes straight to boot OS.

tried editing the file as per steps on Debian Wiki - added the command at the end of the line for example: <existing code><space><dis_ucode_ldr> , F10 - Still same. Infact, when I re-entered Grub, the added code disappeared.
Changed "quiet splash" to "dis_ucode_ldr, F10, again same issue and code disappeared in grub. Tried using CtrlX but it just adds either lower x or Capital X so no other way but to use F10.

Alternately, tried entering Recovery mode but I am surprised to see 2 LM with different Linux versions. One is Linux 4.13.0-32 recovery mode and other is Linux 4.10.0-38

So not sure which one to enter. Please guide..

User avatar
thx-1138
Level 5
Level 5
Posts: 616
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by thx-1138 » Tue Feb 20, 2018 12:13 pm

By default, Linux always boots with the most recent kernel, hence 4.13.0-32 must have been the one which you were using, and the one you should enter.

Just in case, after sudo mount -o remount,rw / & sudo apt-get purge intel-microcode, also try running sudo update-initramfs -uk all.

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 1:31 pm

thx-1138 wrote:
Tue Feb 20, 2018 12:13 pm
By default, Linux always boots with the most recent kernel, hence 4.13.0-32 must have been the one which you were using, and the one you should enter.

Just in case, after sudo mount -o remount,rw / & sudo apt-get purge intel-microcode, also try running sudo update-initramfs -uk all.
just tried this now. Was able to reach the recovery mode and just when I typed the command mount -o the system kinda crashed and the screen prompted again to the menu with a number of options where I again selected Drop to root shell prompt but could not, its like freezing or behaving cranky not allowing to select any thing.

Should I start with Live USB > mount the root partition and INSTEAD of deleting the contents of /lib/firmware/intel-ucode as instructed by @Pjotr as it does sound risky, just follow the command > sudo apt-get purge intel-microcode, also try running sudo update-initramfs -uk all

Will it work. Please suggest.

User avatar
thx-1138
Level 5
Level 5
Posts: 616
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by thx-1138 » Tue Feb 20, 2018 2:01 pm

Should I start with Live USB > mount the root partition and INSTEAD of deleting the contents of /lib/firmware/intel-ucode as instructed by @Pjotr as it does sound risky, just follow the command > sudo apt-get purge intel-microcode, also try running sudo update-initramfs -uk all
...you would probably need to chroot first in order to uninstall it, no idea myself if this would work.
I'd personally either try again editing / passing the required parameter to Grub, or the recovery mode. Or also rename / remove the intel-ucode folder via the LiveCD as suggested above...

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Tue Feb 20, 2018 2:22 pm

I tried this right now but there is no intel-ucode folder in /lib/firmware. There is only one folder which is intel and no intel-ucode

User avatar
slipstick
Level 5
Level 5
Posts: 569
Joined: Sun Oct 21, 2012 9:56 pm
Location: Somewhere on the /LL0 scale

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by slipstick » Tue Feb 20, 2018 3:35 pm

Mike619 wrote:
Tue Feb 20, 2018 2:22 pm
I tried this right now but there is no intel-ucode folder in /lib/firmware. There is only one folder which is intel and no intel-ucode
After doing the mount command from the live Mint DVD as above, do you find /mnt/lib/firmware/intel-ucode ?
In theory, theory and practice are the same. In practice, they ain't.

User avatar
thx-1138
Level 5
Level 5
Posts: 616
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by thx-1138 » Tue Feb 20, 2018 5:18 pm

...btw, the faulty intel-microcode package was replaced / removed 1 month ago, 22 January, and the OP installed it just now, so there's also a chance it might be a totally different issue altogether we're dealing with here for the machine to not be able to boot...

Was it only the microcode that you updated? Nothing marked Level 4 from the update manager or a graphics driver etc?

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Wed Feb 21, 2018 3:08 am

my bad, I did find the intel-ucode in the /mnt/lib folder.. earlier i was checking maybe in the wrong place so could not find it.
I renamed the folder to .bck and rebooted but still on booting, the blank/black screen showed up with no change.

When doing Software UPdate, I selected or rather chose to go for all available updates, dont remember which one, thinking it would be best to keep the system updated.

And selected the intel - micro code option and rebooted the system which is when the problem.

So, should I select specific updates in future or is their only certain level that needs to be updated, asking for future reference.

also, why is it that even after editing the grub like updating the disc_unicode at the end of the line or just replacing quiet splash with disc_unicode not getting saved and working ? does it mean I wont be able to edit grub file at all ? As Ctrlx or CtrlX was just adding x or X instead of saving or doing anything else, I used F10 which rebooted the system but still issue persisted and to my horror all the changes I made were rolled back. what could be the cause?

why is the recovery mode not working as its supposed to ? I follwed the steps to the T, but as soon as I type "mount -o" it just goes back to options menu where I need to select Drop to root shell

Just asking these questions for future reference..

User avatar
thx-1138
Level 5
Level 5
Posts: 616
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by thx-1138 » Wed Feb 21, 2018 11:36 am

Mike619, i'm afraid i don't have an 100% exact answer, maybe i can help you in somewhat narrowing it down & also in preventing it from happening again in the future.
Nevertheless, I purchased a new laptop - Dell i3-6th Gen, 4Gb RAM, 1TB HDD and not so sure about the graphics card.
When doing Software UPdate, I selected or rather chose to go for all available updates, dont remember which one, thinking it would be best to keep the system updated. And selected the intel - micro code option and rebooted the system which is when the problem.
That's why we can't be certain 100% on what went wrong there. The problematic microcodes were already removed back in January, replaced with ones from July. Since you're running a newer laptop, chances are those ones wouldn't even get loaded in the first place, even if you installed them. Then again, there's also no absolute guarantee that trying to install older microcode wouldn't cause some kind of conflict: just because they aren't proved by Intel to be problematic & withdrawn, it doesn't mean they will always play nicely on every system - it's rare, but it happens...

Getting into Grub & then editing the parameters probably needs some exercise...

I have no idea why the recovery mode crashed when mounting /. It's certainly not a good sign though...as this is the standard method for resolving such kind of problems, eg. repairing Xorg, removing crappy graphic drivers etc...Maybe someone can fill the gap here & provide few ideas as to why such happened.

"dis_ucode_ldr": in case the microcode was the problem, this is the official workaround straight from Debian's developers. If after doing successfully such, it still don't load properly...then either microcode wasn't the problem, or you somehow managed to stumble upon a new previously unknown bug that even them wouldn't know about it.

The very first thing i'd suggest would be to learn to use TimeShift. This will save you from lots of future headaches - something goes wrong, back & running few minutes afterwards...
Newer users generally speaking should stay with up to Level 3 updates, until they become more familiar with the whereabouts of their system. Actually, experienced users as well are also cautious with Level 4 updates: updates to the graphics' stack, updates to systemd (the init system), and the kernel, all of them might render the system unbootable one way or another. And if applying them in batch mode, then things become even harder, as someone can't easily track down what went wrong and with which package(s)...

Mike619
Level 1
Level 1
Posts: 9
Joined: Tue Feb 20, 2018 2:25 am

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Mike619 » Wed Feb 21, 2018 12:40 pm

@thx-1138 Thanks for the detailed explanation. I think reinstalling LM is the only way forward now.
I will learn Timeshift as per your advise and hopefully avoid any unforeseen issues. btw any easy to understand and helpful link for Timeshift apart from the one you mentioned, is TS like a System Restore points used in Windows wherein I can restore to the last successful boot without loosing any user added/downloaded files?

my main concern is and i am not sure if i am able to convey this properly or not, is that in future a need arises to edit the grub and then going by my current experience, it would not help me. in my case, even after making the edits; be it at the end of the line with a space at the beginning and removing quiet splash and adding new ucode, these changes were not saved. thats what is bothering. even if the micro code was not the problem, then atleast when re-entering grub, I should ideally see the code that i have added but instead it just goes back to default. i am pretty sure that i saved it properly using F10 because Ctrlx(lower case) or CtrlX(upper case) were just adding x or X. or if there is any other way to save the contents of grub which i might not know.

also, any guide/links that you or any other guys recommend that i should follow to get myself known with LM once I reinstall it. i will follow the documentation and start up guides that i may find on forums and LM site but asking if there is any thing else. i came across @Pjotr's following links when i was searching for microcode issue on google. should i start with them. i dont mean to offend his inputs but just asking as a safety precaution especially after i came across this microcode/ UPdate fiasco and then grub issue and then recovery mode issue. its like all the unique things are happening with me and that too one after the other. which makes me believe anything can happen anytime to anybody :shock:

i just want my system to stay Updated with latest updates as well as running. i hope i am able to explain it properly and once again apologise to @Pjotr or anybody who may be offended/disrespected.

https://sites.google.com/site/easylinux ... /firstmint
https://sites.google.com/site/easylinux ... almistakes

and lastly sorry for the long read..
any comments,advise,criticism will be appreciated.


thx-1138 wrote:
Wed Feb 21, 2018 11:36 am
Mike619, i'm afraid i don't have an 100% exact answer, maybe i can help you in somewhat narrowing it down & also in preventing it from happening again in the future.
Nevertheless, I purchased a new laptop - Dell i3-6th Gen, 4Gb RAM, 1TB HDD and not so sure about the graphics card.
When doing Software UPdate, I selected or rather chose to go for all available updates, dont remember which one, thinking it would be best to keep the system updated. And selected the intel - micro code option and rebooted the system which is when the problem.
That's why we can't be certain 100% on what went wrong there. The problematic microcodes were already removed back in January, replaced with ones from July. Since you're running a newer laptop, chances are those ones wouldn't even get loaded in the first place, even if you installed them. Then again, there's also no absolute guarantee that trying to install older microcode wouldn't cause some kind of conflict: just because they aren't proved by Intel to be problematic & withdrawn, it doesn't mean they will always play nicely on every system - it's rare, but it happens...

Getting into Grub & then editing the parameters probably needs some exercise...

I have no idea why the recovery mode crashed when mounting /. It's certainly not a good sign though...as this is the standard method for resolving such kind of problems, eg. repairing Xorg, removing crappy graphic drivers etc...Maybe someone can fill the gap here & provide few ideas as to why such happened.

"dis_ucode_ldr": in case the microcode was the problem, this is the official workaround straight from Debian's developers. If after doing successfully such, it still don't load properly...then either microcode wasn't the problem, or you somehow managed to stumble upon a new previously unknown bug that even them wouldn't know about it.

The very first thing i'd suggest would be to learn to use TimeShift. This will save you from lots of future headaches - something goes wrong, back & running few minutes afterwards...
Newer users generally speaking should stay with up to Level 3 updates, until they become more familiar with the whereabouts of their system. Actually, experienced users as well are also cautious with Level 4 updates: updates to the graphics' stack, updates to systemd (the init system), and the kernel, all of them might render the system unbootable one way or another. And if applying them in batch mode, then things become even harder, as someone can't easily track down what went wrong and with package(s)...

User avatar
Pjotr
Level 20
Level 20
Posts: 10060
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Black Screen after enabling Intel Microcode(open source) on Linux Mint 18.3

Post by Pjotr » Wed Feb 21, 2018 1:00 pm

Mike619 wrote:
Wed Feb 21, 2018 12:40 pm
i came across @Pjotr's following links when i was searching for microcode issue on google. should i start with them. i dont mean to offend his inputs but just asking as a safety precaution especially after i came across this microcode/ UPdate fiasco and then grub issue and then recovery mode issue. its like all the unique things are happening with me and that too one after the other. which makes me believe anything can happen anytime to anybody :shock:

i just want my system to stay Updated with latest updates as well as running. i hope i am able to explain it properly and once again apologise to @Pjotr or anybody who may be offended/disrespected.

https://sites.google.com/site/easylinux ... /firstmint
https://sites.google.com/site/easylinux ... almistakes

and lastly sorry for the long read..
any comments,advise,criticism will be appreciated.
First of all: I'm not in the least offended. And there's nothing wrong with examining my tips critically. :)

About microcode: I used to advise against installing it, unless specific problems might be solved by installing new microcode. Precisely because of mishaps like yours. About a year ago I myself experienced boot failure on one of my machines after installing microcode.

But the current Meltdown/Spectre misery ("thanks" to the irresponsible behaviour of Intel and AMD) has changed the landscape.... New microcode might mitigate these huge gaping security holes.

In your case you should of course avoid installing new microcode: better a less secure computer than a computer that doesn't boot anymore.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Newbie Questions”