So I broke my kernel

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
trevdev
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 11:08 pm

So I broke my kernel

Post by trevdev » Wed Mar 07, 2018 11:25 pm

Long story short, I ran virtualbox and it completely froze/crashed my entire system. I had to reboot. There were ACPI errors thrown and I got thrown into emergency mode. The errors seemed too low-level for me to comprehend.

I was able to load an older kernel, reinstall the current kernal, reboot and get back in dandy. I noticed my nvidia drivers weren't working anymore. Apparently nvidia-settings couldn't find dbus even though it was there. Reinstalled my nvidia drivers + software software. Fixed.

I was wondering if there was a way for me to check and see if anything else is broken. Everything seems fine, but I just want to be sure. Also, if anyone has had this happen, I'd love to know if you figured out why. Virtualbox has never compromised my kernel before. I think it's fair to say it was some kind of video hardware conflict. I had virtualbox working on this machine with a previous version of mint, FYI.

User avatar
catweazel
Level 17
Level 17
Posts: 7534
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: So I broke my kernel

Post by catweazel » Thu Mar 08, 2018 2:08 am

trevdev wrote:
Wed Mar 07, 2018 11:25 pm
I ran virtualbox and it completely froze/crashed my entire system.
What version of VBox, and where did it come from?
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: So I broke my kernel

Post by Cosmo. » Thu Mar 08, 2018 6:04 am

Also:
What is your version of Mint and what is the desktop environment? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.

You need to give this information for every help request in every thread.
Do not forget this in the future.

Mute Ant
Level 13
Level 13
Posts: 4926
Joined: Tue Sep 03, 2013 7:45 pm

Re: So I broke my kernel

Post by Mute Ant » Thu Mar 08, 2018 6:16 am

"I was wondering if there was a way for me to check and see if anything else is broken?" Yes, assuming it wasn't malicious damage that added unwanted files to the OS.

Investigate
You can install the debsums command and test that each installed package fragment matches the version from the repository... is it there... is it intact? The results need a little interpretation because some package scripts get modified after installation...
sudo debsums firefox ### Check the installed version of Firefox.
sudo debsums | grep -v OK ### Check the whole OS and report not-OK results.

Repair
You can do a blind re-install of every package in the system, whether it needs it or not. This will do an Update Everything, temporarily ignoring your Update Manager preferences. The first run is relatively slow as it has to download every package that was used to make your Mint.
sudo apt-get install --reinstall $(apt-mark showmanual) $(apt-mark showauto)

Example
I am test-driving devuan-ascii-beta right now. I get 1 file missing and 4 files that don't match...
devuan@devuan:~$ sudo debsums | grep -v OK
debsums: missing file /data/etc/apt/apt.conf.d/05disable-suggests (from devuan-baseconf package)
/lib/udev/rules.d/75-persistent-net-generator.rules FAILED
/usr/lib/refractainstaller/pre-install/loc-timezn.sh FAILED
/usr/share/applications/refractainstaller.desktop FAILED
/usr/lib/refractasnapshot/iso/isolinux/splash.png FAILED
2018-10-13 Google designs 3-phase feed-forward to improve 2-phased governors with no sense of direction.

trevdev
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 11:08 pm

Re: So I broke my kernel

Post by trevdev » Thu Mar 08, 2018 4:34 pm

catweazel wrote:
Thu Mar 08, 2018 2:08 am
trevdev wrote:
Wed Mar 07, 2018 11:25 pm
I ran virtualbox and it completely froze/crashed my entire system.
What version of VBox, and where did it come from?
5.0.18 (x86) version from the mint software manager.
Cosmo. wrote:
Thu Mar 08, 2018 6:04 am
Also:
What is your version of Mint and what is the desktop environment? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.

You need to give this information for every help request in every thread.
Do not forget this in the future.
Mint 18.3 Cinnimon. I apologize for the lack of information.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: So I broke my kernel

Post by Cosmo. » Thu Mar 08, 2018 6:15 pm

VB 5.0.18 is older than old. If you should use kernel 4.13.x a freeze by using VB is to expected.

Remove the old VB version and reboot. Download either the latest version of VB 5.1 (preferred for stability) or 5.2 and install it. You need the version for Ubuntu 16.04 with the architecture (32 - 64 bit) which matches with your system.
Last edited by Cosmo. on Thu Mar 08, 2018 6:23 pm, edited 1 time in total.

trevdev
Level 1
Level 1
Posts: 3
Joined: Wed Mar 07, 2018 11:08 pm

Re: So I broke my kernel

Post by trevdev » Thu Mar 08, 2018 6:17 pm

Thanks Cosmo. All is working as of last night with 5.2 VB. I really do appreciate everyone who stepped up here. So far as I can tell, I'm safe, but I'll be very wary of dated software.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: So I broke my kernel

Post by Cosmo. » Thu Mar 08, 2018 6:24 pm

Although you found the download page for VB yourself (very good), I have edited my last post and added the forgotten link for other readers.

User avatar
catweazel
Level 17
Level 17
Posts: 7534
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: So I broke my kernel

Post by catweazel » Fri Mar 09, 2018 1:32 am

trevdev wrote:
Thu Mar 08, 2018 6:17 pm
Thanks Cosmo. All is working as of last night with 5.2 VB. I really do appreciate everyone who stepped up here. So far as I can tell, I'm safe, but I'll be very wary of dated software.
I'm glad you got it sorted.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Post Reply

Return to “Newbie Questions”