(solved) Trouble with university wifi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

(solved) Trouble with university wifi

Post by sleepyski » Mon Mar 19, 2018 1:29 am

Hello, I recently put mint on my laptop over spring break and everything was working fine, but now that I am back in my dorm I am connected to the wifi but after maybe five minutes of a usable connection I get "DNS_PROBE_FINISHED_NO_INTERNET" even though I am connected on other devices running different operating systems and they work just fine.
Last edited by sleepyski on Wed Mar 21, 2018 2:12 am, edited 1 time in total.
Sorry, sounds like a hardware problem.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6743
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Trouble with university wifi

Post by Spearmint2 » Mon Mar 19, 2018 3:15 am

Check your DNS server settings. You may be required to use a particular one at a university. Or, they may just block certain DNS servers. If all else fails, the DNS google supplies is 8.8.8.8 and 8.8.4.4
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Mon Mar 19, 2018 3:59 pm

Spearmint2 wrote:
Mon Mar 19, 2018 3:15 am
Check your DNS server settings. You may be required to use a particular one at a university. Or, they may just block certain DNS servers. If all else fails, the DNS google supplies is 8.8.8.8 and 8.8.4.4
I'm not very knowledgeable on this but I attempted to add the DNS servers that my macbook says I am using on this network and the google ones and I am still getting the error.
Sorry, sounds like a hardware problem.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6743
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Trouble with university wifi

Post by Spearmint2 » Mon Mar 19, 2018 4:35 pm

Then you need to look at the setup, the encryption used, the SSID used, the password needed.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
phd21
Level 19
Level 19
Posts: 9296
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trouble with university wifi

Post by phd21 » Mon Mar 19, 2018 6:01 pm

Hi sleepyski,

Welcome to the wonderful world of Linux Mint and its excellent forum!

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Depending upon your WiFi adapter, it may be going into power saving mode, which you can turn off (disable).

If you are able to connect for 5 minutes or any amount of time, then it is probably not the DNS servers. But I highly recommend that everyone change their local ISP connection's (Your University in this case) to secure and anonymous ones from a DNS provider like "dns.watch", "opennic", "OpenDNS", etc...

Always restart or at least logout and log back in after changing networking stuff...

How to change DNS servers - Linux Mint/Cinnamon – OpenDNS
- Very good instructions and you can use any DNS server IP addresses.
https://support.opendns.com/hc/en-us/ar ... t-Cinnamon

Also, a lot of people get better performance when using IPv4 versus IPv6.
Disable IPv6 if its not supported
See #2 & #3 to set priority to "IPv4" (I use #2 & #3)
http://www.blackmoreops.com/2015/08/04/ ... -in-linux/


Hope this helps ...
Network Manager - Edit Connection IPv4
Network Manager - Edit Connection IPv4
Network Manager - Edit Connection IPv6
Network Manager - Edit Connection IPv6
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Tue Mar 20, 2018 4:27 pm

phd21 wrote:
Mon Mar 19, 2018 6:01 pm

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.
So this is what I get when I run the command

Code: Select all

System: Host: sleebs Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard product: HP Pavilion 11 x360 PC v: 0975100002405F00010420180
           Mobo: Hewlett-Packard model: 2209 v: 57.19
           Bios: Insyde v: F.04 date: 02/15/2014
CPU:       Quad core Intel Pentium N3520 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17326
           clock speeds: max: 2415 MHz 1: 499 MHz 2: 578 MHz 3: 963 MHz
           4: 608 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.07hz
           GLX Renderer: Mesa DRI Intel Bay Trail
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
           driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
           IF: wlp2s0f0 state: down mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
           Card-3: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
           driver: rtl8192cu usb-ID: 001-004
           IF: wlx74da388b073e state: N/A mac: N/A
Drives:    HDD Total Size: 120.0GB (9.1% used)
           ID-1: /dev/sda model: KingDian_S280 size: 120.0GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 106G used: 6.5G (7%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.18GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 33.0C mobo: 33.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 194 Uptime: 16 min Memory: 577.5/3841.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
As an added note I have been messing with this today and I connected to the connection then pinged 8.8.8.8 and while the command was running I could use the internet. After testing the connection for 20 minutes or so I stopped the command and the second it stopped pinging google I got a "dns_probe_finished_no_internet ". Why would my connection work only when it is in constant use?
Last edited by Moem on Wed Mar 21, 2018 3:07 am, edited 1 time in total.
Reason: Adding code tags [</>]. They retain some formatting that makes your output easier to read.
Sorry, sounds like a hardware problem.

User avatar
phd21
Level 19
Level 19
Posts: 9296
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trouble with university wifi

Post by phd21 » Tue Mar 20, 2018 4:48 pm

Hi sleepyski,

phd21 wrote:Depending on your WiFi adapter, it may be going into power saving mode, which you can turn off (disable).
It looks like you have 2 Wifi adapters? Please post the results of the "lsusb" and "iwconfig" console terminal commands.
sleepyski wrote: Network: Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
IF: wlp2s0f0 state: down mac: <filter>

Card-3: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
driver: rtl8192cu usb-ID: 001-004
IF: wlx74da388b073e state: N/A mac: N/A
Speed up your Mint! - Easy Linux tips project (Great Linux website)
https://sites.google.com/site/easylinuxtipsproject/3
Speed up your Mint! - Easy Linux tips project wrote:Speed up your wireless internet
11. For some wireless chipsets, a simple tweak is sufficient for increasing the speed and the connection quality of your wireless internet. Namely disabling the power management for the wireless chipset. The price you pay is obviously an increase in power consumption, although this increase isn't big.

You can do that as follows:

a. First find out if Ubuntu or Mint applies power management to your wireless chipset:

Launch a terminal window.
(You can launch a terminal window like this: *Click*)

Type in the terminal:

Code: Select all

iwconfig
Press Enter.

... Read the rest from the link ...

I personally would not use the Google Public DNS servers (8.8.8.8 ) because of there willingness to snoop on our activities. I would recommend using one of the other DNS provider's DNS server IP addresses.
OpenNIC Project
https://www.opennic.org/


You may also want to read the link below.
If your system automatically recognizes your WiFi adapters, then you do not need to install any new drivers.

Realtek wireless chipset: install the right driver - Easy Linux tips project
https://sites.google.com/site/easylinux ... /reserve-7

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Tue Mar 20, 2018 5:42 pm

phd21 wrote:
Tue Mar 20, 2018 4:48 pm
Hi sleepyski,

phd21 wrote:Depending on your WiFi adapter, it may be going into power saving mode, which you can turn off (disable).
It looks like you have 2 Wifi adapters? Please post the results of the "lsusb" and "iwconfig" console terminal commands.
sleepyski wrote: Network: Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
IF: wlp2s0f0 state: down mac: <filter>

Card-3: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
driver: rtl8192cu usb-ID: 001-004
IF: wlx74da388b073e state: N/A mac: N/A
Speed up your Mint! - Easy Linux tips project (Great Linux website)
https://sites.google.com/site/easylinuxtipsproject/3
Speed up your Mint! - Easy Linux tips project wrote:Speed up your wireless internet
11. For some wireless chipsets, a simple tweak is sufficient for increasing the speed and the connection quality of your wireless internet. Namely disabling the power management for the wireless chipset. The price you pay is obviously an increase in power consumption, although this increase isn't big.

You can do that as follows:

a. First find out if Ubuntu or Mint applies power management to your wireless chipset:

Launch a terminal window.
(You can launch a terminal window like this: *Click*)

Type in the terminal:

Code: Select all

iwconfig
Press Enter.

... Read the rest from the link ...

I personally would not use the Google Public DNS servers (8.8.8.8 ) because of there willingness to snoop on our activities. I would recommend using one of the other DNS provider's DNS server IP addresses.
OpenNIC Project
https://www.opennic.org/


You may also want to read the link below.
If your system automatically recognizes your WiFi adapters, then you do not need to install any new drivers.

Realtek wireless chipset: install the right driver - Easy Linux tips project
https://sites.google.com/site/easylinux ... /reserve-7

Hope this helps ...
Oh gosh I forgot to post what I got for "lsusb"
This is it for lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 0781:5598 SanDisk Corp.
Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 002: ID 04f2:b40e Chicony Electronics Co., Ltd HP Truevision HD camera
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and iwconfig gives me

enp4s0 no wireless extensions.

wlx74da388b073e IEEE 802.11 ESSID:"SFA-WIRELESS"
Mode:Managed Frequency:2.412 GHz Access Point: A0:E0:AF:1D:33:50
Bit Rate=72.2 Mb/s Tx-Power=16 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off
Link Quality=57/70 Signal level=-53 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:343 Missed beacon:0

wlp2s0f0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off

lo no wireless extensions.

I have two wifi adapters because the onboard one is really weak and slow (its an older laptop) so I am using a usb adapter. I really appreciate your help this far, thank you!
Sorry, sounds like a hardware problem.

User avatar
phd21
Level 19
Level 19
Posts: 9296
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trouble with university wifi

Post by phd21 » Tue Mar 20, 2018 5:54 pm

Hi sleepyski,

You are welcome...

So, is your WiFI connection stable now or more stable?

Were the power management settings "off" already, or did you change that before posting your reply.

I read somewhere that there is a trick or tweak to get the internal WiFi to work better. But there is nothing wrong with using a USB WiFi adapter.

It might help to disable the onboard wifi adapter through the Bios if there is a setting for that, or to remove the internal Wifi card. You can also try using another USB port for the USB WiFi adapter. FYI: Do not use USB hubs that do not have their own power supply.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Tue Mar 20, 2018 6:00 pm

phd21,

It is only stable if I am constantly pinging a dns server. And I did not touch the power management setting so it was already enabled. I disabled the internal wifi card through the console with "lspci" then added that to "sudo nano /etc/modprobe.d/blacklist".
Sorry, sounds like a hardware problem.

User avatar
phd21
Level 19
Level 19
Posts: 9296
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trouble with university wifi

Post by phd21 » Tue Mar 20, 2018 7:22 pm

Hi sleepyski,

That is weird.

Have you checked the system power settings, screensaver settings, etc...?

I rarely get disconnected from the Internet, even if I do not access it for hours (unless someone else here is messing with the router :x ).

You might be able to simply add a network monitor speed applet, desklet, widget, etc... and adjust how often it updates itself which might work. I always have a network monitor running (desklet widget) and they usually update every second, and is usually user configurable. You can install "linssid", "wavemon" (runs from console terminal), or "wireshark", and have it update every so often (default), or see links below to create a "stay awake" script or cron job.

It could be that your University ISP has some activity monitor that disconnects after so many minutes, that would be a pain. Are others having the same issues?

Did you manually install any network wifi driver?

How to solve internet connection problems - Easy Linux tips project
https://sites.google.com/site/easylinux ... t/internet

networking - How to keep alive a wifi connection on a laptop - Ask Ubuntu
https://askubuntu.com/questions/653096/ ... n-a-laptop

WiFi drops, cron and nmcli heartbeat script - Unix & Linux Stack Exchange
https://unix.stackexchange.com/question ... eat-script


Hope this helps ...
NetSpeed Widget (desklet)
NetSpeed Widget (desklet)
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Wed Mar 21, 2018 12:36 am

I scripted a "network pacemaker" cron job, for lack of better words. I went to the IT services department at my university to see if they could help me and I was essentially told that I should just switch to windows because linux machines have problems on their network (WOW!). But with this cron job I have a reliable connection and had a lot of fun figuring this out! Thank you so much for your help. :D
Sorry, sounds like a hardware problem.

User avatar
phd21
Level 19
Level 19
Posts: 9296
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trouble with university wifi

Post by phd21 » Wed Mar 21, 2018 1:15 am

Hi sleepyski,.

You are welcome...

I am glad you figured it out. Still surprised that you would have to ping their network for it to stay active.

Does not sound like their IT services dept is well rounded. There is no reason Linux Machines should have a problem on any ISP or WiFi network. Their comments make me think the problem is on their end. Did they offer any real explanations? Linux is the 3 & 4th most used operating systems in the world. And the number one choice for most large servers.

How about sharing your script file with us, and exactly how you implemented it, so that others may benefit. And, you can tell others at your University using Linux how to resolve their similar connection issues.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
sleepyski
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 1:20 am
Location: Texas

Re: Trouble with university wifi

Post by sleepyski » Wed Mar 21, 2018 1:34 am

I got no real explanation! It was kind of sad. And for my script I simply opened the terminal and typed "sudo crontab -e" hit enter then "@reboot ping 208.67.220.220". Again I really appreciate your time. 8)
Sorry, sounds like a hardware problem.

Post Reply

Return to “Wireless”