Wrong GB count in the system

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 6
Joined: Thu May 24, 2018 1:30 pm

Wrong GB count in the system

Post by Jarekk » Sat May 26, 2018 2:03 pm


I upgraded my 250 GB SSD to a 500 GB SSD as I needed more space. I used Clonezilla to clone the small disc to the large one. My system is fully encrypted with I made sure to select "k1" and "r" options to automatically enlarge the partition into the size of the bigger drive. Everything went fine and I was able to use the "new" system right after I changed the discs.

My problem is that although Gparted shows that the partition was properly resized to the maximum size, the system can see only 238 GB.
I checked it and the system does not allow to copy any file that exceeds the 238GB size.

Is there any way to tell the system the real size of the partition?


Level 13
Level 13
Posts: 4597
Joined: Sun Aug 09, 2015 10:00 am

Re: Wrong GB count in the system

Post by deepakdeshp » Sat May 26, 2018 2:10 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Mute Ant
Level 14
Level 14
Posts: 5122
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Wrong GB count in the system

Post by Mute Ant » Sun May 27, 2018 7:27 pm

Clonezilla has done what it can. It knows about partitions and the data inside partitions, but it can't re-work that data to adjust the size of the logical volume /dev/mapper/mint--vg-root or the size of the ext4 file-system in that volume. So your problem is just normal for a cloned encrypted Mint. Next step is like this...
https://www.rootusers.com/lvm-resize-ho ... partition/
...to make the Logical Volume bigger, then make the EXT4 inside that volume bigger, too. Both operations can be performed while the OS is running (it says here) but I have never tried it.
Gandalf says: 'All we have to decide is what to do in the time that is given to us.'

Post Reply

Return to “Hardware Support”