[Solved] Calendar app shows UTC?

Please post suggestions for improvement of Cinnamon here
Post Reply
Level 1
Level 1
Posts: 13
Joined: Thu Dec 24, 2009 10:35 am

[Solved] Calendar app shows UTC?

Post by jrw32982 » Sun Jun 17, 2018 4:55 pm

This bizarre situation was being caused by a Linux Mint 17 / Linux Mint 18 dual boot configuration. When I boot from the hard disk where 18 is installed, everything works as expected. However, when booting from the disk where 17 is installed (and choosing 18 from the GRUB menu), somehow UTC was being used by the system. I don't understand the exact mechanism, but I'm satisfied with the fix!

Original question:
Using Cinnamon 18.3. The Calendar app and the login screen both show UTC, but the system timezone is EDT. (My Mate 17.2 system has no problems.) How can I fix this?

Code: Select all

$ timedatectl
      Local time: Sun 2018-06-17 16:46:53 EDT
  Universal time: Sun 2018-06-17 20:46:53 UTC
        RTC time: Sun 2018-06-17 20:46:53
       Time zone: America/Detroit (EDT, -0400)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

$  ( unset TZ && date )
Sun Jun 17 16:53:42 EDT 2018

$ inxi -Fxz
System:    Host: anjali Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard product: p6612p
           Mobo: FOXCONN model: 2AB1 v: 1.00
           Bios: American Megatrends v: 6.02 date: 07/21/2010
CPU:       Quad core AMD Athlon II X4 635 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 23141
           clock speeds: max: 2900 MHz 1: 1700 MHz 2: 1700 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4200]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: AMD RS880 (DRM 2.50.0 / 4.13.0-37-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series]
           driver: snd_hda_intel bus-ID: 01:05.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-3 Logitech Webcam C270 driver: USB Audio usb-ID: 001-006
           Sound: Advanced Linux Sound Architecture v: k4.13.0-37-generic
Network:   Card: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2766.1GB (23.6% used)
           ID-1: /dev/sda model: ST3750528AS size: 750.2GB temp: 32C
           ID-2: /dev/sdb model: ST2000DX002 size: 2000.4GB temp: 34C
           ID-3: USB /dev/sdc model: Cruzer size: 15.5GB temp: 0C
Partition: ID-1: / size: 20G used: 9.4G (51%) fs: ext4 dev: /dev/dm-2
           ID-2: /boot size: 976M used: 326M (34%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 6.44GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 33.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 213 Uptime: 6:58 Memory: 1528.0/5709.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Post Reply

Return to “Cinnamon”