Very High CPU Usage

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 13
Joined: Tue Mar 13, 2018 10:46 pm

Very High CPU Usage

Post by logx7 » Tue Jun 19, 2018 5:41 pm

my installation is very very slow

here's a screenshot with some info

and here's the output of sudo inxi -GSCMm -t c -P -x

Code: Select all

System:    Host: hammi-MS-7793 Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: FM2-A85XA-G65 (MS-7793) v: 1.0
           Bios: American Megatrends v: V1.1 date: 10/09/2012
CPU:       Quad core AMD A8-5600K APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28739
           clock speeds: max: 3600 MHz 1: 3600 MHz 2: 3600 MHz 3: 3600 MHz
           4: 3200 MHz
Memory:    Array-1 capacity: 8 GB devices: 4 EC: None
           Device-1: A1_DIMM0 size: No Module Installed type: N/A
           Device-2: A1_DIMM1 size: No Module Installed type: N/A
           Device-3: A1_DIMM2 size: No Module Installed type: N/A
           Device-4: A1_DIMM3 size: 8 GB speed: 6 MHz type: DDR3
           part: DDR3 1600G 2OZ
Graphics:  Card: NVIDIA GK107 [GeForce GT 740] bus-ID: 01:00.0
           Display Server: 1.18.4 driver: nvidia
           tty size: 80x24 Advanced Data: N/A for root
Partition: ID-1: / size: 140G used: 104G (79%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb1
Processes: CPU: % used - Memory: MB / % used - Used/Total: 2250.2/8007.1MB - top 5 active
           1: cpu: 21.3% command: xdg-mime (started by: sh) pid: 8178 mem: 8.24MB (0.1%)
           2: cpu: 21.2% command: xdg-mime (started by: sh) pid: 8237 mem: 8.20MB (0.1%)
           3: cpu: 21.2% command: xdg-mime (started by: sh) pid: 8189 mem: 8.23MB (0.1%)
           4: cpu: 21.0% command: xdg-mime (started by: sh) pid: 8093 mem: 8.18MB (0.1%)
           5: cpu: 13.7% command: cinnamon pid: 20265 mem: 258.79MB (3.2%)
as you can see xdg-mime is the culprit .. i don't even know what it does -_-

Thank You XD

User avatar
Sir Charles
Level 7
Level 7
Posts: 1835
Joined: Thu Jan 04, 2018 1:00 pm

Re: Very High CPU Usage

Post by Sir Charles » Tue Jun 19, 2018 6:10 pm

Hi logx7,

I don't have any solution to offer :( but If I remember correctly, Discord can cause this kind of high CPU usage. Try turning it off to verify. And if this is the case at least now you know what to look for.

Good luck!

I remembered where I had seen something similar: Discord start xdg-mime and use all cpu
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
Level 11
Level 11
Posts: 3535
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Very High CPU Usage

Post by JerryF » Tue Jun 19, 2018 7:06 pm

Did this happen from the beginning when you first installed Mint?

Maybe a place to start would be your Startup Applications.

Can you post a screenshot of Startup Applications? A great program to do that is Shutter, which can be found in Software Manager.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
Level 16
Level 16
Posts: 6482
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Very High CPU Usage

Post by Flemur » Tue Jun 19, 2018 7:12 pm

logx7 wrote:
Tue Jun 19, 2018 5:41 pm
as you can see xdg-mime is the culprit .. i don't even know what it does -_-
It's pretty complicated. I typed

Code: Select all

into a search engine, and it told me that it's another fine product of
xdg-mime — command line tool for querying information about file type handling and adding descriptions for new file types

Try this in a terminal:

Code: Select all

killall xdg-mime
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Manjaro openbox/fluxbox/pulse-less
Lubuntu LXDE/fluxbox/pulse-less

Post Reply

Return to “Newbie Questions”