LM 18.3 KDE - menus not appearing in several applications

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
kentchristopher
Level 1
Level 1
Posts: 19
Joined: Thu Aug 16, 2012 3:44 pm

LM 18.3 KDE - menus not appearing in several applications

Post by kentchristopher » Wed Jul 11, 2018 9:49 am

In certain applications (Firefox, Opera, Linphone, Deadbeef (music player), FileZilla, Audacity...) when I try to click the menu (e.g. File, Edit, View, or the 3-line menu button in Firefox), no menu appears. However, I notice that the cursor changes color, as if the menu has opened, and if I click randomly in the area where the menu should be, I get an appropriate response, e.g. if I click Help and then a few space down, I might get the "About" window of that application. So the menu is there, but not showing up.

I first noticed this problem in Firefox and posted about it here. It has received no replies after 2 days, and I've discovered the problem goes well beyond Firefox.

I'm unable to see anything if I open Driver Manager, although it too seems it might be there but just invisible, as nothing else responds until I hit ESC.

I've tried rebooting into previous kernels. Current: 4.15.0-24, previous 4.13.0-45 and -43.

If this is the wrong place to post this, please let me know where it should be posted. I have 3 posts in a row now on these forums that have gone unanswered in the past few weeks (and yes, I only posted after considerable searching for the answers on my own).

Edit with new info: I'm also unable to see a right-click menu from Linphone when it's minimized to the notification bar (next to the clock).

User avatar
phd21
Level 19
Level 19
Posts: 9319
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: LM 18.3 KDE - menus not appearing in several applications

Post by phd21 » Wed Jul 11, 2018 10:49 am

HI "kentchristopher",

See this recent post - Can't click menu items in several programs - KDE 18.3 - Linux Mint Forums
viewtopic.php?f=47&t=272789

Using the QtCurve Window Decoration will resolve this for most applications, supposedly, but it did not with Firefox for me. You may need to restart after this, or at least logout and log back in.

I tried changing Linux Kernels as well and that did not make a difference with this.

Whatever it is that caused this, I hope they fix it soon because this is something new.

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

kentchristopher
Level 1
Level 1
Posts: 19
Joined: Thu Aug 16, 2012 3:44 pm

Re: LM 18.3 KDE - menus not appearing in several applications

Post by kentchristopher » Wed Jul 11, 2018 1:37 pm

phd21 wrote:
Wed Jul 11, 2018 10:49 am
HI "kentchristopher",

See this recent post - Can't click menu items in several programs - KDE 18.3 - Linux Mint Forums
viewtopic.php?f=47&t=272789

Using the QtCurve Window Decoration will resolve this for most applications, supposedly, but it did not with Firefox for me. You may need to restart after this, or at least logout and log back in.

I tried changing Linux Kernels as well and that did not make a difference with this.

Whatever it is that caused this, I hope they fix it soon because this is something new.

Hope this helps ...
Thank you, I'll jump in on the thread you linked as it definitely seems to be the same problem.

User avatar
phd21
Level 19
Level 19
Posts: 9319
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: LM 18.3 KDE - menus not appearing in several applications

Post by phd21 » Wed Jul 11, 2018 1:41 pm

Hi entchristopher,

You are welcome...

FYI: I tried the "Audacity" audio editor and the "DeadBeef' music apps and they are working for me using the 'QtCurve"...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Newbie Questions”