[Solved] CUPS Configuration / What is my Printer URI

Forum rules
Before you post please read this
Post Reply
MCDELTAT
Level 1
Level 1
Posts: 26
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

[Solved] CUPS Configuration / What is my Printer URI

Post by MCDELTAT » Mon Sep 24, 2018 3:55 pm

Today I went through the process of installing a CUPS server on a remote machine based on CentOS 7. I can access the web configuration, I was able to add the Canon D530/560 over USB from the Web Admin Page, but then all the tutorials/documentation stop short. The button "Share printers connected to this system" is checked and the server was restarted after that option was chosen.

How do I find the URI that I need to point other remote machines to that printer? In the CUPS Web Admin Page it simply says the URI is usb://Canon/D530/D560?serial=1137H3600986&interface=1

In the Linux Mint menu I tried URIs like ipp://<cups-server-ip> and ipp://<cups-server-ip>/printers/ etc. No dice. lpstat -d reveals that is the default printer. -p and -v also show it.

EDIT: I believe I solved part of it, but now I have another issue to deal with. I noticed one tutorial that said I might need to add that Printer to a Class, so I did that. While doing do it presented with the route ipp://<cups-server-ip>/printers/Canon_D530_D560 so I used that to add it to my Remote Linux Mint machine. It's talking to the server because I can see both jobs get put in the queue, but then nothing happens. What should I do to troubleshoot that final step. The CUPS Web Admin menu states "completed at Mon 24 Sep 2018 01:39:02 PM PDT"

EDIT2: I decided to also see if I had just assigned the incorrect PPD to the device, so I went ahead and ran the install script on the server that was found on Canon's Official Website (https://www.usa.canon.com/internet/port ... _downloads) This introduced a seconder printer listing in the CUPS Web Page, with the URI cnusb:/dev/usb/lp0

I deleted the previous printer and class, then added this new device labelled as "Canon D530/D560 UFRII LT" and tried to print a test page directly from the CUPS menu. This also said it rendered and completed, but nothing came out.

So what's my next step?
Last edited by MCDELTAT on Mon Sep 24, 2018 7:45 pm, edited 2 times in total.

pdc_2
Level 8
Level 8
Posts: 2418
Joined: Mon May 11, 2009 1:21 am

Canon D530

Post by pdc_2 » Mon Sep 24, 2018 5:16 pm

Is there anything of assistance in this Ubuntu wiki?

https://help.ubuntu.com/community/Netwo ... WithUbuntu

what does

Code: Select all

lpinfo -v
give please?

So you have a Mint machine? which version ........ the driver for the D530 is the UFR driver? version 3.6? (released Aug 2018?)

MCDELTAT
Level 1
Level 1
Posts: 26
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: CUPS Configuration / What is my Printer URI

Post by MCDELTAT » Mon Sep 24, 2018 6:23 pm

Code: Select all

lpinfo -v
On my server returns

Code: Select all

network ipps
network beh
network https
direct cnusb:/dev/usb/lp0
network http
network lpd
network socket
network ipp
direct usb://Canon/D530/D560?serial=1137H3600986&interface=1
network smb
On my remote Mint Machine it returns:

Code: Select all

network ipps
network https
network beh
file cups-brf:/
network socket
direct hp
network lpd
network http
network ipp
direct hpfax

pdc_2
Level 8
Level 8
Posts: 2418
Joined: Mon May 11, 2009 1:21 am

Re: CUPS Configuration / What is my Printer URI

Post by pdc_2 » Mon Sep 24, 2018 7:21 pm

sometimes I really need to spell stuff out; so it is clear if I am understanding things correctly;

so my assumption is the Canon in connected to a CentOS computer; as it sees the Canon as
direct cnusb:/dev/usb/lp0
and it also reports it as
direct usb://Canon/D530/D560?serial=1137H3600986&interface=1
on the remote Mint machine, it cannot reach across to see these things; is the issue not that there need to be settings changed on the CentOS so it allows Mint to recognise the Canon? (I apologise if I have got completely the wrong end of the stick ..... as some would say ..)

has this got something to do with it? https://techpoli.info/2016/03/14/config ... on-centos/

MCDELTAT
Level 1
Level 1
Posts: 26
Joined: Thu May 26, 2016 11:54 pm
Location: California, US

Re: CUPS Configuration / What is my Printer URI

Post by MCDELTAT » Mon Sep 24, 2018 7:45 pm

Yes you're assumptions were correct.

This got resolved however in mysterious ways. I went to try another solution that required unplugging the USB cable from my CentOS 7, but it didn't work either. When I plugged the printer back into my CentOS CUPS Server, it suddenly started working on all my devices. So on linux I'm using the URL ipp://<server-ip>/printers/Canon_D530_D560

This also is working on all our Mac computers, except that discovery isn't working, so you have to manually type in that URL, but meh. Good enough.

Will have to test on our lonely Windows machine at work later.

pdc_2
Level 8
Level 8
Posts: 2418
Joined: Mon May 11, 2009 1:21 am

Re: [Solved] CUPS Configuration / What is my Printer URI

Post by pdc_2 » Mon Sep 24, 2018 9:20 pm

well done; we all learn from folks like you who have all the hardware; and can tell us what happens; enjoy

Post Reply

Return to “Printers & Scanners”