cinnamon eating cpu

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Vitali
Level 1
Level 1
Posts: 3
Joined: Wed Oct 03, 2018 2:21 pm

cinnamon eating cpu

Post by Vitali » Wed Oct 03, 2018 2:44 pm

Hi, community.

Here is output of top:

Code: Select all

 5031 vitali    20   0 4532556 346264  86184 S 216.6  2.8 116:12.96 cinnamon                                                                                             
 2031 root      20   0 1100732 116128  76796 S   9.3  1.0   5:37.44 Xorg                                                                                                 
16321 vitali    20   0  792828 108064  75628 S   7.3  0.9   0:01.16 chrome                                                                                               
 7544 vitali    20   0 1628044 344116 174204 S   3.3  2.8   6:45.87 chrome   
I guess that the reason of this is videosystem or rather the problem with the drivers, so here part of my laptop`s configuration (HP - 14-cf0005la):

Code: Select all

System:    Host: workhorse Kernel: 4.18.11-041811-generic x86_64 bits: 64 gcc: 8.2.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) dm: lightdm Distro: Linux Mint 19 Tara
CPU:       Quad core Intel Core i5-8250U (-MT-MCP-)
Graphics:  Card-1: Intel UHD Graphics 620 bus-ID: 00:02.0 chip-ID: 8086:5917
           Card-2: Advanced Micro Devices [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]
           bus-ID: 01:00.0 chip-ID: 1002:6900
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,ati,amdgpu (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           OpenGL: renderer: llvmpipe (LLVM 6.0, 256 bits)
           version: 3.3 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes 
Can u help me, pls.

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: cinnamon eating cpu

Post by roblm » Thu Oct 04, 2018 9:39 am

The inxi output shows there is no 3D hardware acceleration of the graphics from the graphics processor, so software rendering of the graphics is done by the CPU, which uses a lot of processing power.

You’re using an unsupported mainline kernel, I presume because you’re trying to correct some other major problem? Try using a newer kernel through the Update Manager > View > Linux kernels, or install Mint Xfce or MATE, which don’t need 3D hardware acceleration to display the desktop.

User avatar
trytip
Level 8
Level 8
Posts: 2489
Joined: Tue Jul 05, 2016 1:20 pm

Re: cinnamon eating cpu

Post by trytip » Thu Oct 04, 2018 10:19 am

i use the unsupported kernel OP is using with no issues, and i have good working nvidia drivers.
@Vitali open Driver Manager and install the graphics from there. i have no experience with [AMD/ATI] drivers but i believe your focus should be on installing the video graphics for your card.
Image

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: cinnamon eating cpu

Post by roblm » Thu Oct 04, 2018 12:07 pm

trytip wrote:@Vitali open Driver Manager and install the graphics from there.
Driver Manager will be empty for systems with AMD graphics, unless you go back to Mint 17, which had the proprietary fglrx driver available as an option.

User avatar
trytip
Level 8
Level 8
Posts: 2489
Joined: Tue Jul 05, 2016 1:20 pm

Re: cinnamon eating cpu

Post by trytip » Thu Oct 04, 2018 6:42 pm

@ roblm
are you saying there are no drivers offered for amd/ati graphics in mint 19? :(
Image

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: cinnamon eating cpu

Post by roblm » Thu Oct 04, 2018 7:25 pm

trytip wrote:@ roblm
are you saying there are no drivers offered for amd/ati graphics in mint 19?
That’s correct. Older AMD cards will use the radeon driver and newer ones the amdgpu driver, both open source.

There is an exception for cards in the chip series Southern Islands and Sea Islands, which usually use the radeon driver. They can also use the amdgpu driver if the instructions in this guide are used, under the section Enable Southern Islands (SI) and Sea Islands (CIK) support, but I don’t think there is a significant difference in overall performance between the two:
https://wiki.archlinux.org/index.php/AM ... parameters


The only other alternative is to download and manually install the AMDGPU-Pro Driver from AMD’s website for those newer cards that are supported by it, which are listed on this web page:
https://www.amd.com/en/support/kb/relea ... -lin-18-30

Vitali
Level 1
Level 1
Posts: 3
Joined: Wed Oct 03, 2018 2:21 pm

Re: cinnamon eating cpu

Post by Vitali » Fri Oct 05, 2018 9:55 am

roblm wrote:
Thu Oct 04, 2018 9:39 am
install Mint Xfce or MATE, which don’t need 3D hardware acceleration to display the desktop.
I thought about it, but the reinstallation will take time, which is a pity.
roblm wrote:
Thu Oct 04, 2018 12:07 pm
trytip wrote:@Vitali open Driver Manager and install the graphics from there.
Driver Manager will be empty for systems with AMD graphics, unless you go back to Mint 17, which had the proprietary fglrx driver available as an option.
Yep, Driver Manager is empty.
roblm wrote:
Thu Oct 04, 2018 7:25 pm
The only other alternative is to download and manually install the AMDGPU-Pro Driver from AMD’s website for those newer cards that are supported by it, which are listed on this web page:
https://www.amd.com/en/support/kb/relea ... -lin-18-30
I installed drivers following this link. Being that I have linux mint 19, I gave to the installer /etc/os-release from ubuntu 18.04
But my video still is not working.
dmesg | grep VGA

Code: Select all

[    0.285177] pci 0000:00:02.0: vgaarb: setting as boot VGA device
[    0.285177] pci 0000:00:02.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    1.770020] fb0: EFI VGA frame buffer device
[    2.401468] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   88.962201] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   89.051604] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   91.571824] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
lspci -v

Code: Select all

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company UHD Graphics 620
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at b1000000 (64-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 6000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [40] Vendor Specific Information: Len=0c <?>
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [100] Process Address Space ID (PASID)
	Capabilities: [200] Address Translation Service (ATS)
	Capabilities: [300] Page Request Interface (PRI)
	Kernel modules: i915

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] (rev c3)
	Subsystem: Hewlett-Packard Company Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]
	Flags: fast devsel, IRQ 255
	Memory at a0000000 (64-bit, prefetchable) [disabled] [size=256M]
	Memory at b0000000 (64-bit, prefetchable) [disabled] [size=2M]
	I/O ports at 5000 [disabled] [size=256]
	Memory at b2200000 (32-bit, non-prefetchable) [disabled] [size=256K]
	Expansion ROM at b2240000 [disabled] [size=128K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Capabilities: [270] #19
	Capabilities: [2b0] Address Translation Service (ATS)
	Capabilities: [2c0] Page Request Interface (PRI)
	Capabilities: [2d0] Process Address Space ID (PASID)
	Kernel modules: amdgpu

User avatar
roblm
Level 9
Level 9
Posts: 2795
Joined: Sun Feb 24, 2013 2:41 pm

Re: cinnamon eating cpu

Post by roblm » Fri Oct 05, 2018 11:14 am

I don’t think your Radeon R7 GPU for mobile devices is supported by the AMDGPU-Pro driver. Your inxi output lists these GPUs: [Radeon R7 M260/M265 / M340/M360 / M440/M445]

AMD lists these supported GPUs for the R7 series on their website: R7 240/250/250X/260/260X/350

The only one that was questionable was the M260, so I used this AMD support page to find if any package with the AMDGPU-Pro driver came up in the result and there was none:

https://www.amd.com/en/support


amd support.png

User avatar
thx-1138
Level 6
Level 6
Posts: 1275
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: cinnamon eating cpu

Post by thx-1138 » Fri Oct 05, 2018 11:38 am


User avatar
smurphos
Level 8
Level 8
Posts: 2238
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: cinnamon eating cpu

Post by smurphos » Fri Oct 05, 2018 2:43 pm

Just a quick check before heading down the rabbit warren of AMD graphics support.

Log off and on the login screen click on the little Cinnamon icon next to your user name and double check you are not logging into the Cinnamon Software Rendering session.

Vitali
Level 1
Level 1
Posts: 3
Joined: Wed Oct 03, 2018 2:21 pm

Re: cinnamon eating cpu

Post by Vitali » Fri Oct 05, 2018 3:55 pm

smurphos wrote:
Fri Oct 05, 2018 2:43 pm
Just a quick check before heading down the rabbit warren of AMD graphics support.

Log off and on the login screen click on the little Cinnamon icon next to your user name and double check you are not logging into the Cinnamon Software Rendering session.
If I check "Cinnamon default session", then after login I receive message in right corner that "Running in software rendering mode".

User avatar
smurphos
Level 8
Level 8
Posts: 2238
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: cinnamon eating cpu

Post by smurphos » Sat Oct 06, 2018 12:49 am

Vitali wrote:
Fri Oct 05, 2018 3:55 pm
If I check "Cinnamon default session", then after login I receive message in right corner that "Running in software rendering mode".
Ok - worth a try I guess.

Post Reply

Return to “Graphics Cards & Monitors”