Making Linux mint 19 see Windows SMB shares

Write tutorials here
There are more tutorials here
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Tue Oct 16, 2018 12:04 am

Making Linux mint 19 see Windows SMB shares

Post by daveschrom »

I seem to struggle with Linux MINT with Windows Networking in almost every new installation. I even created a file folder with copies of other blog suggestions, fixes, etc. in order to edit the dreaded SMB.CONF file. But after installing the latest MINT 19 TARA release, I was baffled as to why Networking refused to see my Windows Shares.

So........... Here is my two cents in what seems to have worked for me.

1st - Here is the pertinent section of my SMB.CONF file that I have edited, which seems to work:

Code: Select all


## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP
   name resolve order = bcast host lmhosts wins
   client max protocol = NT1
   netbios name = DELL-Latitude
# server string is the equivalent of the NT Description field
	server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = yes
2nd - Here are two Commands that you will need to run in Terminal which seems to be the key to making MINT see Windows Shares. This is what I've used in Linux MINT 19 Tara, but may work in version 18 as well:

Type these commands in the terminal:

Code: Select all

sudo iptables -t raw -A OUTPUT -p udp -m udp --dport 137 -j CT --helper netbios-ns
Since any change to iptables is lost on reboot without a configuration file I installed the iptables-persistent package, this way the 'fix' will not be gone after a system restart. To install type this in the terminal, and save the current rules.

Code: Select all

sudo apt install iptables-persistent
Anyway, this is what worked for me.. Good luck........
Post Reply

Return to “Tutorials”