Firefox themes don't work despite being same version as W10?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
photonfanatic
Level 1
Level 1
Posts: 20
Joined: Sat Oct 13, 2018 8:48 pm

Firefox themes don't work despite being same version as W10?

Post by photonfanatic » Thu Oct 18, 2018 4:28 am

This one seems a bit odd to me. So I have Firefox on Windows 10, and on Linux Mint. And its the same version. Both Quantum, both version 63.0.3

But if I'm using Windows, I can install black themes such as Deep Dark, or Nasa Night launch. I love these themes, they make firefox so much more enjoyable for me. Can't use it when I load up Mint 19 cinnamon. All the themes on firefox's site say "Not compatible with your version of Firefox". How can that be, if they're the same version? Isn't firefox platform independent? Meaning its the same program on mac, windows, or linux?

User avatar
Moem
Level 17
Level 17
Posts: 7205
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Firefox themes don't work despite being same version as W10?

Post by Moem » Thu Oct 18, 2018 4:36 am

This is a bit of a guess, but 'platform independent' usually means that you can install the program on different platforms because it has versions for those platforms. You can't download Firefox-for-Windows on Linux and expect it to install, right?

I'm not sure whether that's the reason why you can't use all the same themes. But it might be.

Or the themes are using something from the Windows interface which is not present or works differently in Linux.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

gm10
Level 13
Level 13
Posts: 4599
Joined: Thu Jun 21, 2018 5:11 pm

Re: Firefox themes don't work despite being same version as W10?

Post by gm10 » Thu Oct 18, 2018 5:00 am

photonfanatic wrote:
Thu Oct 18, 2018 4:28 am
This one seems a bit odd to me. So I have Firefox on Windows 10, and on Linux Mint. And its the same version. Both Quantum, both version 63.0.3

But if I'm using Windows, I can install black themes such as Deep Dark, or Nasa Night launch. I love these themes, they make firefox so much more enjoyable for me. Can't use it when I load up Mint 19 cinnamon. All the themes on firefox's site say "Not compatible with your version of Firefox". How can that be, if they're the same version? Isn't firefox platform independent? Meaning its the same program on mac, windows, or linux?
1. My FF 63.0 has no problem installing the addons you mentioned:
ffnnl.png
2. You are not running FF 63.0.3. That version doesn't exist. I would assume you are running the pre-installed Mint version of Firefox 62.0.3. It's a modified Firefox which breaks/blocks some things. We've had a few threads about it removing google from the search providers and resetting settings on upgrades. It's possible it also breaks addons, although I hadn't seen that complaint yet and I haven't tried. Nevertheless, it's always preferable to use the non-Mint version instead:

Code: Select all

apt install firefox/bionic-updates
or https://www.mozilla.org/en-US/firefox/

Let us know if that fixes it.

Post Reply

Return to “Newbie Questions”