Welcome screen, in Encrypted LM-19, won't accept password

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Keni-Marie
Level 1
Level 1
Posts: 5
Joined: Sat Jun 03, 2017 2:06 pm
Location: Montana

Welcome screen, in Encrypted LM-19, won't accept password

Post by Keni-Marie »

I have been running Linux Mint 19 Tara on my Toshiba Satellite laptop since it's release and all previous versions of LM dating back to LM 17.3. However, this morning the logon screen won't accept my password. It just loops back to the logon screen.

1. The HD is encrypted. The password to logon to the encrypted disk works fine and machine moves on to the user logon screen.
2. If I modify the password, or use another one, I get the "Incorrect" password error message.
3. Cap locks is off.
4. If I use CTL-ALT-F4 I move to the TTY logon screen. When I enter my user name and password, the machine logs on to my user account properly. Telling me the password is valid.

Since the posts in this thread deal with unencrypted disks, and mentions not to use those methods on an encrypted machine, and since they are dealing with earlier versions of LM, I thought it might be nice if someone knows how to fix this looping logon screen on a LM 19, encrypted machine.

Reinstalling LM 19 is an option. I can do a fresh install in a couple of hours, But, I'd rather see if there's a way to get the machine to logon properly to my user account without a reinstall. ;)
User avatar
Moem
Level 20
Level 20
Posts: 12329
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Welcome screen, in Encrypted LM-19, won't accept password

Post by Moem »

Mod note:
I've split your post off into a new thread, the original thread is years old, please do not revive old topics as per the forum guidelines. Thanks!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Welcome screen, in Encrypted LM-19, won't accept password

Post by gm10 »

The typical reasons for a login loop have nothing to do with encryption:

1. Full / root or /home partition, check Use% columns in the output of this command df / /home
2. Messed up permissions, run sudo chown -Rc $USER:$USER $HOME
3. Corrupt authentication caches, run rm ~/.Xauthority ~/.ICEauthority
4. If none of that helps, run startx and check the error message(s)

All commands to be run in a virtual console, Ctrl+Alt+F1 to get there, Alt+F7 to get back to the login screen.
Post Reply

Return to “Newbie Questions”