Thunar can not browse Windows network

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 46
Joined: Fri Sep 08, 2017 10:44 pm

Thunar can not browse Windows network

Post by brvcf »

I have a mix of Windows, Mint 18.3 XFCE and Mint 19 XFCE computers on my network.

If I click on Browse Network in Thunar on any Mint 18.3 PC Thunar will list all the Windoze machines regardless of version (XP ...10), but none show up on any Mint 19 PC.

This seems like a loss of functionality from 18.3 to 19, not an improvement. The average non-technical user choosing Mint because the GUI is 'Windows-like' would expect the file manger to work to show network shares. I can get around it by smb://computername, but it is a pita.

What changed? What do I have to install or configure to get it to work?
Level 3
Level 3
Posts: 196
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Thunar can not browse Windows network

Post by donalduck »

I had the same issue on ubuntu 18.* xfce, found out it was the because of firewall settings (blocked connections).
Level 20
Level 20
Posts: 10327
Joined: Tue Feb 03, 2009 10:27 am

Re: Thunar can not browse Windows network

Post by altair4 »

Ubuntu 18.04 and the version of Samba that comes with it made many changes. Please see this: Mint 19 and Samba File Sharing Changes

In short:

** Discovery ( browsing ) of netbios hosts does not work for the more recent versions - at least not through the file managers - in Linux .
** Netbios' replacement in Windows ( WSD ) has no counterpart in Linux.
** You can still connect to the Windows machine but it must be done explicitly by name as you already found out - you know you can bookmark them.
** You can "fix" the discovery issue ( client max protocol = NT1 ) which is where Ubuntu 16.04 was but it comes at a price.
** None of this affects how Linux or macOS machines find each other since they don't have to use netbios although you may need to add a file to older Mint versions.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
Post Reply

Return to “Xfce”