problems with updater mannager

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

problems with updater mannager

Post by pcfan5 »

Hello, I wasn't able to install the updates neither to get to the "software origins" option in the updater... it didn't work . So I uninistall "sudo apt remove...." and "sudo apt purge..." , but when trying to install again "sudo apt install...." it says "this package isn't available" or "there is no candidate".
By doing "apt-get update" I get a problem here 0% [Conectando a muug.ca (2605:e200:3:4::244)] (conectando means "connecting"), nothing is dowload.

The software updater "mintupdate" isn't available neither in synaptic non in "software mannager" now...

I am under linux mint 18.3 xfce

sources.list in /etc/apt says this

Code: Select all

#deb cdrom:[Linux Mint 18.3 _Sylvia_ - Release amd64 20171213]/ xenial contrib main non-free
I was able to reinstall "mintupdate" from here https://www.ubuntuupdates.org/package/m ... mintupdate, but still cannot sellect the sofware origins... "the apt cache is dammaged"
User avatar
Moem
Level 20
Level 20
Posts: 11788
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: problems with updater mannager

Post by Moem »

pcfan5 wrote:
Thu Jan 10, 2019 12:24 pm
The software updater "mintupdate" isn't available neither in synaptic non in "software mannager" now...
I'm not surprised. Both of these are front ends for apt.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
philotux
Level 5
Level 5
Posts: 832
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: problems with updater mannager

Post by philotux »

See if you can run it from a terminal:

Code: Select all

pkexec mintsources
User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: problems with updater mannager

Post by pcfan5 »

philotux wrote:
Thu Jan 10, 2019 12:42 pm
See if you can run it from a terminal:

Code: Select all

pkexec mintsources

Code: Select all

sudo pkexec mintsources
[sudo] password for
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Failed to connect to Mir: Failed to connect to server socket: No existe el archivo o el directorio
Unable to init server: No se puede conectar: Connection refused

(mintSources.py:7890): Gtk-CRITICAL **: gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
/usr/lib/linuxmint/mintSources/mintSources.py:716: Warning: g_object_get_qdata: assertion 'G_IS_OBJECT (object)' failed
  self.builder.add_from_file(glade_file)

User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: problems with updater mannager

Post by pcfan5 »

I have updated the latests reply after running the command as "root"
Last edited by pcfan5 on Thu Jan 10, 2019 2:08 pm, edited 1 time in total.
User avatar
philotux
Level 5
Level 5
Posts: 832
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: problems with updater mannager

Post by philotux »

Sorry pcfan5, this seems to be above my pay grade. You would need assistance from more experienced forum members.

cheers,
philotux
User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: problems with updater mannager

Post by pcfan5 »

Ok, , no problem. thank you !
User avatar
greerd
Level 6
Level 6
Posts: 1056
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: problems with updater mannager

Post by greerd »

Can you post terminal output for both:

Code: Select all

apt update
and

Code: Select all

inxi -r
User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: problems with updater mannager

Post by pcfan5 »

greerd wrote:
Thu Jan 10, 2019 3:24 pm
Can you post terminal output for both:

Code: Select all

apt update
and

Code: Select all

inxi -r

Thanks for your reply here are the results (I have to translate them with google translator since my system language isn't in english and i don't remember the command to get it translated in console) *

Code: Select all

sudo apt-get update
[sudo] password for sil:
Obj: 1 https://repo.skype.com/deb stable InRelease
Obj: 2 http://linux.teamviewer.com/deb preview InRelease
Obj: 3 http://archive.canonical.com/ubuntu great InRelease
From: 4 http://security.ubuntu.com/ubuntu great-security InRelease [107 kB]
From: 5 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ InRelease [1,492 B]
Obj: 6 ftp://ftp.cs.mun.ca/pub/mirror/ubuntu great InRelease
Obj: 7 ftp://ftp.cs.mun.ca/pub/mirror/ubuntu genial-updates InRelease
Obj: 8 ftp://ftp.cs.mun.ca/pub/mirror/ubuntu great-backports InRelease
Err: 9 http://muug.ca/mirror/linuxmint/packages sylvia InRelease
  Could not connect to muug.ca:80 (208.81.1.244), the connection time has expired [IP: 208.81.1.244 80]
Downloaded 108 kB in 2min 4s (869 B / s)
Reading packet list ... Done
W: Failed to get http://muug.ca/mirror/linuxmint/packages/dists/sylvia/InRelease Could not connect to muug.ca:80 (208.81.1.244), expired for connection [IP: 208.81. 1,244 80]
W: Some index files could not be downloaded, omitted, or some old ones have been used instead.

this muug.ca/mirror is driving me crazzy , and I don't know how to change the mirrows from console. so I run "sudo software-source" and I am able to change mirrows now, from GUI , put them into defaults.

Code: Select all

inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/megasync.list
           deb https://mega.nz/linux/MEGAsync/xUbuntu_16.04/ ./
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://muug.ca/mirror/linuxmint/packages sylvia main upstream import backport
           deb ftp://ftp.cs.mun.ca/pub/mirror/ubuntu xenial main restricted universe multiverse
           deb ftp://ftp.cs.mun.ca/pub/mirror/ubuntu xenial-updates main restricted universe multiverse
           deb ftp://ftp.cs.mun.ca/pub/mirror/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/teamviewer.list
           deb http://linux.teamviewer.com/deb preview tv14

*UPDATE: here is what I was looking for

Code: Select all

 LC_ALL=C. That forces output to be English
User avatar
greerd
Level 6
Level 6
Posts: 1056
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: problems with updater mannager

Post by greerd »

Yes, I see there is no InRelease in http://muug.ca/mirror/linuxmint/packages/dists/sylvia/InRelease, only a Release. I think it should of used ubuntu for the distro instead of linuxmint.

So is it working now?

P.S. You could of tried editing /etc/apt/sources.list.d/official-package-repositories.list instead of reseting the repos but...
User avatar
pcfan5
Level 4
Level 4
Posts: 352
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: problems with updater mannager

Post by pcfan5 »

Hi thank you for your reply. I have read somewhere else that that file could be edited but I didn't have the courage...
Now the updater is working, since I got to change the mirrow by runing as root in console "software-sources", then uninstalled the updater also from console ("sudo apt uninstall mintupdater"; "sudo apt purge mintupdater" , and install it again from there .

In my last post I forgot to say that when I was experiencing the first problems I had changed the mirrow into canada... I never know if my local mirrow should be trusted.

Anyway after refreshing the cache list I got this message now :

Code: Select all

Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available, an older version of the failed index will be used. Otherwise, the repository will be ignored. Check your network connection and ensure the repository address is correct in 'Repositories' under 'Settings'.

The repository 'cdrom://Linux Mint 18.3 _Sylvia_ - Release amd64 20171213 xenial Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.Failed to fetch cdrom://Linux Mint 18.3 _Sylvia_ - Release amd64 20171213/dists/xenial/contrib/binary-amd64/Packages  Please use apt-cdrom to allow APT to recognise this CD-ROM. 'apt-get update' cannot be used to add new CD-ROMsSome index files failed to download. They have been ignored, or old ones used instead.

I will unchecked this package from the sofware - sources - aditional repositories..
Post Reply

Return to “Software & Applications”