opera does not play html5 video in lmde 3.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mbunal
Level 1
Level 1
Posts: 4
Joined: Fri Nov 16, 2018 5:56 am

opera does not play html5 video in lmde 3.

Post by mbunal » Fri Nov 16, 2018 6:03 am

hello all

i cant play some html5 video with opera in lmde3. i found something but never success, which is about putting libffmpeg.so in /usr/lib/x86linux/opera/lib_extra. i tried to change /usr/lib/x86linux/opera/libffmpeg.so but opera crashed.

i must use opera.

any body help me please.

User avatar
kc1di
Level 14
Level 14
Posts: 5409
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: opera does not play html5 video in lmde 3.

Post by kc1di » Fri Nov 16, 2018 6:40 am

which version of Opera are you using?
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

mbunal
Level 1
Level 1
Posts: 4
Joined: Fri Nov 16, 2018 5:56 am

Re: opera does not play html5 video in lmde 3.

Post by mbunal » Fri Nov 16, 2018 10:42 pm

kc1di wrote:
Fri Nov 16, 2018 6:40 am
which version of Opera are you using?
56.0.3051.104

mbunal
Level 1
Level 1
Posts: 4
Joined: Fri Nov 16, 2018 5:56 am

Re: opera does not play html5 video in lmde 3.

Post by mbunal » Fri Nov 16, 2018 10:48 pm

if you check this address, you can see what is the problem:

https://www.youtube.com/html5

my output attached.
Attachments
Ekran Resmi 2018-11-17 05.45.20.jpg

User avatar
administrollaattori
Level 15
Level 15
Posts: 5887
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: opera does not play html5 video in lmde 3.

Post by administrollaattori » Sat Nov 17, 2018 5:21 am

It is a libffmpeg.so problem. Download latest libffmpeg.so via latest-proprietary-media.sh script.

Code: Select all

wget https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
Run that script, and copy its libffmpeg.so as an administrator into /usr/lib/x86_64-linux-gnu/opera folder and re-start Opera.

mbunal
Level 1
Level 1
Posts: 4
Joined: Fri Nov 16, 2018 5:56 am

Re: opera does not play html5 video in lmde 3.

Post by mbunal » Sat Nov 17, 2018 5:06 pm

administrollaattori wrote:
Sat Nov 17, 2018 5:21 am
It is a libffmpeg.so problem. Download latest libffmpeg.so via latest-proprietary-media.sh script.

Code: Select all

wget https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
Run that script, and copy its libffmpeg.so as an administrator into /usr/lib/x86_64-linux-gnu/opera folder and re-start Opera.
thank you very much. it worked.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5887
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

[SOLVED] opera does not play html5 video in lmde 3.

Post by administrollaattori » Sun Nov 18, 2018 8:27 am

mbunal wrote:
Sat Nov 17, 2018 5:06 pm
thank you very much. it worked.
Please edit topic as SOLVED, so that someone else can find the solution. :wink:

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 6:50 pm

I am using Opera 57.0.3098.106 and have the same issue.
administrollaattori wrote:
Sat Nov 17, 2018 5:21 am
It is a libffmpeg.so problem. Download latest libffmpeg.so via latest-proprietary-media.sh script.

Code: Select all

wget https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
Run that script, and copy its libffmpeg.so as an administrator into /usr/lib/x86_64-linux-gnu/opera folder and re-start Opera.
I ran the script but evidently am not up to speed because I don't know where to find the libffmpeg.so file to copy it into the recommended folder. Any direction with this would be appreciated. Thanks.
Smile, it makes people wonder what you've been up to.

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 7:12 pm

rgand wrote:
Thu Jan 10, 2019 6:50 pm
I am using Opera 57.0.3098.106 and have the same issue.
administrollaattori wrote:
Sat Nov 17, 2018 5:21 am
It is a libffmpeg.so problem. Download latest libffmpeg.so via latest-proprietary-media.sh script.

Code: Select all

wget https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
Run that script, and copy its libffmpeg.so as an administrator into /usr/lib/x86_64-linux-gnu/opera folder and re-start Opera.
I ran the script but evidently am not up to speed because I don't know where to find the libffmpeg.so file to copy it into the recommended folder. Any direction with this would be appreciated. Thanks.
At the end of the script you have run, it says:
The following files were installed onto your system:

$HOME/.local/lib/vivaldi/libffmpeg.so
$HOME/.local/lib/vivaldi/chromium-codecs-ffmpeg-extra-version.txt
So I guess you should find libffmpeg.soin $HOME/.local/lib/vivaldi/libffmpeg.so. That is open the fie manager and go to home directory. Press Ctrl-h to make visible hidden files and folders and go to /.local/lib/vivaldi

Hope this helps!

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 8:32 pm

In $HOME/local, there is no .lib folder.

When I run the script I get this:

Code: Select all

rg@rg-G75VW ~ $ wget https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
--2019-01-10 15:45:37--  https://gist.githubusercontent.com/ruario/bec42d156d30affef655/raw/53bb6a1fd298d114355453f6f19ae188c22e2e9c/latest-proprietary-media.sh
Resolving gist.githubusercontent.com (gist.githubusercontent.com)... 151.101.196.133
Connecting to gist.githubusercontent.com (gist.githubusercontent.com)|151.101.196.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4489 (4.4K) [text/plain]
Saving to: ‘latest-proprietary-media.sh.1’

latest-proprietary- 100%[===================>]   4.38K  --.-KB/s    in 0.001s  

2019-01-10 15:45:37 (3.31 MB/s) - ‘latest-proprietary-media.sh.1’ saved [4489/4489]

rg@rg-G75VW ~ $ 
Smile, it makes people wonder what you've been up to.

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 8:37 pm

I guess you would need to run latest-proprietary-media.sh.1by:

Code: Select all

./latest-proprietary-media.sh.1

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 8:44 pm

Sorry forgot to add that you would need to make the script executable first. Right-click on the script you have downloaded (it should be in your home directory) and choose "properties". Under "Permissions" tab, check the box "Allow this file to run as a program". Now open a terminal and run the command from the previous post.
Screenshot_2019-01-11_01-48-52.png

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 9:50 pm

philotux wrote:
Thu Jan 10, 2019 8:44 pm
Sorry forgot to add that you would need to make the script executable first. Right-click on the script you have downloaded (it should be in your home directory) and choose "properties". Under "Permissions" tab, check the box "Allow this file to run as a program". Now open a terminal and run the command from the previous post.

Screenshot_2019-01-11_01-48-52.png
I made that file and the original one (latest-proprietary-media.sh) executable but just keep getting copies of the file when I run the script.
I now have:
latest-proprietary-media.sh
latest-proprietary-media.sh.1
latest-proprietary-media.sh.2
and latest-proprietary-media.sh.3.

Should I run the original copy of the file, which is now executable, by itself?
Smile, it makes people wonder what you've been up to.

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 9:53 pm

Just keep this one: latest-proprietary-media.sh. Delete the rest. Open a terminal copy, paste and run

Code: Select all

chmod +x latest-proprietary-media.sh
Now run:

Code: Select all

./latest-proprietary-media.sh

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 10:00 pm

Code: Select all

rg@rg-G75VW ~ $ chmod +x latest-proprietary-media.sh
rg@rg-G75VW ~ $ ./ latest-proprietary-media.sh
bash: ./: Is a directory
rg@rg-G75VW ~ $ 

There's still nothing new in the /.local folder
Attachments
Screenshot from 2019-01-10 17-53-53.png
Smile, it makes people wonder what you've been up to.

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 10:01 pm

I am sorry, I had put an space to much. Please copy, paste and run again:

Code: Select all

./latest-proprietary-media.sh

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 10:07 pm

That did the trick. I tried an HTML5 video and total success. Many, many thanks. Double thumbs-up, there.
Smile, it makes people wonder what you've been up to.

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: opera does not play html5 video in lmde 3.

Post by philotux » Thu Jan 10, 2019 10:08 pm

Wow, that's great! Glad that it worked out!
You are most welcome!

cheers,
philotux
:D

User avatar
rgand
Level 4
Level 4
Posts: 427
Joined: Fri Feb 05, 2016 12:44 am

Re: opera does not play html5 video in lmde 3.

Post by rgand » Thu Jan 10, 2019 10:10 pm

:D 8)
Smile, it makes people wonder what you've been up to.

Onabi
Level 1
Level 1
Posts: 2
Joined: Sat Mar 30, 2019 1:08 pm

Re: opera does not play html5 video in lmde 3.

Post by Onabi » Tue May 14, 2019 11:47 am

Thank you much for this solution, also works for me with Opera 60.0.3255.83_amd64.
I recently looked for an alternative to the best browser of our planet (Firefox), but HTML5 H264 Video was not working on any other browser.

As the script printed, H.264/MP4 should now also work on Vivaldi, but here it does not!? (Vivaldi 2.2.1388.37)

I am using linux regularly since 2014 and ffmpeg is one of the few things that are still making me mad from time to time. :-/

Post Reply

Return to “Software & Applications”