Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Yfrwlf
Level 3
Level 3
Posts: 135
Joined: Sat Jun 08, 2013 7:46 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by Yfrwlf »

jodel wrote:
Mon Oct 22, 2018 5:53 am
I am using the Nouveau Driver and have the exact same effect. Black Boxes randomly appearing on the second screen and being really annoying and flickering. GTK CSS fix applied but did not work.

As I use the Nouveau Driver and _not_ the NVIDIA driver, I daresay it's nothing to do with the NVIDIA driver but with a second monitor setup in Linux Mint 19.

This didn't happen to me in Linux Mint 18.
That would mean it's a Xorg or Muffin/Cinnamon issue I assume. I always install the proprietary driver since you can't do gaming without it.

recluce
Level 1
Level 1
Posts: 36
Joined: Sat Mar 13, 2010 9:57 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by recluce »

Interesting, I have the same issue with a dual and one triple screen setup, both using Nvidia cards and Nvidia drivers. Here is my system configuration:

Cinnamon: 4.0.0
Muffin: 4.0.0-1
xorg-server: 1.20.3-1
nvidia driver: 410.66-3
Linux Kernel: 4.18.16

GPU on System 1: Nvidia GTX 970 (Intel CPU without graphics)
GPU on System 2: Nvidia Quadro P4000 (Intel graphics disabled in BIOS)

Now comes a big difference in system configuration that does not seem to make a difference, I still get occasional random flicker on both machines, mostly of backgrounds: I am not running Cinnamon on Mint, but on Artix Rolling (Artix is an Arch Linux fork without systemd). So the issue seems to be very much OS independent and just connected "somehow" to the interaction between Cinnamon / xorg / Nvidia Card. Oddly, I did not have these problems on the same hardware with Mint 17 (and whatever the versions of the other software were back then).

benchrest
Level 3
Level 3
Posts: 100
Joined: Tue Jan 17, 2012 2:19 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by benchrest »

I had the problem of the background flickering once a week or so with 18 - 18.3 cinnamon with an GEFORCE EN210 older graphics. I upgraded to GEFORCE GTX 1050ti preparing for 19. After installing 19 and now 19.1 cinnamon I have only seen the background flicker maybe once in the last month. BUT on a daily basis I am seeing a similar problem with a window. If I open a window on the primary monitor and drag it to the secondary in will more than flicker but at a slower rate and stop after 4 or five slow flicker or it might just blank out completely. Then if I click somewhere on the secondary it reappears. Don't know if this is the same problem showing little different. I am at kernel 4.15.0-43 and nvidia driver 390.77 I drag windows back and forth quite a bit so happening twice a day is not to often.
Rich
LM Cinnamon 19, ASUS TUF B450M, Ryzen 5 2600x, 16gb memory, Samsung SSD 970 EVO-Plus, Samsung SSD 850 Pro 256gb, dual 27" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison.

VtPoet
Level 3
Level 3
Posts: 116
Joined: Tue Jan 19, 2010 8:28 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by VtPoet »

Just upgraded to Linux Mint 19.1 and am experiencing severe flickering and misplaced frames (window elements flickering back and forth between former and current states):

System: Host: vtpoet-Lenovo-Yoga-2-11 Kernel: 4.18.0-041800-generic x86_64 bits: 64 Desktop: Cinnamon 4.0.8
Distro: Linux Mint 19.1 Tessa
Machine: Type: Laptop System: LENOVO product: 20428 v: Lenovo Yoga 2 11 serial: <root required>
Mobo: LENOVO model: VIUU4 v: 31900058WIN serial: <root required> UEFI [Legacy]: LENOVO v: AACN21WW
date: 01/30/2015
Battery: ID-1: BAT0 charge: 27.2 Wh condition: 27.2/34.0 Wh (80%)
CPU: Topology: Dual Core model: Intel Core i3-4012Y bits: 64 type: MT MCP L2 cache: 3072 KiB
Speed: 627 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 859 2: 852 3: 817 4: 788
Graphics: Device-1: Intel driver: i915 v: kernel
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.0.5

It's so bad that I'm having a hard time typing this comment.I'll probably have to install a different DE if there isn't a quick solution to this?

Edit: Just restarted Cinnamon (Alt-F2 + r), as a hail Mary, and that seems to have solved the issue? (Until the next restart?) Stay tuned.

Yfrwlf
Level 3
Level 3
Posts: 135
Joined: Sat Jun 08, 2013 7:46 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by Yfrwlf »

VtPoet wrote:
Mon Dec 31, 2018 12:16 am
Just upgraded to Linux Mint 19.1 and am experiencing severe flickering and misplaced frames (window elements flickering back and forth between former and current states):

System: Host: vtpoet-Lenovo-Yoga-2-11 Kernel: 4.18.0-041800-generic x86_64 bits: 64 Desktop: Cinnamon 4.0.8
Distro: Linux Mint 19.1 Tessa
Machine: Type: Laptop System: LENOVO product: 20428 v: Lenovo Yoga 2 11 serial: <root required>
Mobo: LENOVO model: VIUU4 v: 31900058WIN serial: <root required> UEFI [Legacy]: LENOVO v: AACN21WW
date: 01/30/2015
Battery: ID-1: BAT0 charge: 27.2 Wh condition: 27.2/34.0 Wh (80%)
CPU: Topology: Dual Core model: Intel Core i3-4012Y bits: 64 type: MT MCP L2 cache: 3072 KiB
Speed: 627 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 859 2: 852 3: 817 4: 788
Graphics: Device-1: Intel driver: i915 v: kernel
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.0.5

It's so bad that I'm having a hard time typing this comment.I'll probably have to install a different DE if there isn't a quick solution to this?

Edit: Just restarted Cinnamon (Alt-F2 + r), as a hail Mary, and that seems to have solved the issue? (Until the next restart?) Stay tuned.
That's a different issue. The severe screen flickering after upgrading to Mint 19.1 from 19 has been reported in this thread: viewtopic.php?p=1571645#p1571645

See my post where I asked everyone to try this but didn't get a response:
Would someone please try opening mintwelcome or "Welcome Screen" as it's called in the menu, and go to "First Steps" and try selecting the "traditional" or "modern" desktop layouts and see if either of those fix the problem? Because I have a sneaky suspicion that will take care of it, that there is some weird configuration cruft being leftover after upgrades that isn't getting cleaned out for certain configurations that is causing this problem.
Try that. If that doesn't work and there are no other solutions, reinstalling 19.1 from the ISO definitely does fix it. Hopefully you won't have to go to that length to solve it, though.

The issue being reported in this thread is certain windows in Cinnamon periodically and rarely blinking black, not flickering constantly insanely like with the 19.1 upgrade issue. They might be related to the same bug, though, who knows.

User avatar
Kilz
Level 4
Level 4
Posts: 200
Joined: Mon Apr 04, 2011 8:00 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by Kilz »

I tend to get it whenever I install any nvidia driver other than 340. I do have an older card though, 560 ti.
I trust Microsoft about as far as I could comfortably spit a dead rat
Ubuntu is my past, it is no longer the place it once was, on its forums you are no longer free to voice your opinion.
64bit Linux Powered

User avatar
BaconPancakes
Level 1
Level 1
Posts: 3
Joined: Sat Jan 12, 2019 2:08 am

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by BaconPancakes »

Linux Mint 19.1 - Cinnamon
Kernels: 4.18.0-13, 4.15.0-43
Nvidia drivers: 415.25 & 396.54 (MSI 1080)

Three monitor set up. Middle is primary, no flickering or shenanigans there. It happens predominantly on the right-most monitor, rarely on the left. 3D applications (Wine->DXVK->World of Warcraft for example.) don't do it. I use Dolphin, and 9:10 if it flickers or something strange happens the custom-background css I used to change it's colours are no longer applied. I can trigger the flicker with it fairly reliably by starting a new window on main screen, moving it right and then clicking on middle screen without touching the window once drag 'n drop is ended. It's not personally an issue, and it's easy to stop it once it starts (just highlight/click/select the misbehaving one) but I thought I'd throw out what little information I had.

klutzierthanmost
Level 1
Level 1
Posts: 2
Joined: Sat Jun 06, 2009 12:51 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by klutzierthanmost »

I just recently installed LMDE 3. System: Host: dell Kernel: 4.9.0-9-amd64 x86_64 bits: 64 Desktop: Cinnamon 4.0.10.
Graphics:
Device-1: AMD RV370 [Radeon X300] driver: radeon v: kernel
Display: x11 server: X.Org 1.19.2 driver: ati,radeon
unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz
OpenGL: renderer: Gallium 0.4 on ATI RV370 v: 2.1 Mesa 13.0.6

As you can see I do not have an NVIDIA Graphix card. I am having the flickering problem.

benchrest
Level 3
Level 3
Posts: 100
Joined: Tue Jan 17, 2012 2:19 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by benchrest »

I last posted in January on this problem. Still occurring. Have two monitors and can happen on either. Mostly the edge of the background flickers and can be stopped by clicking on the background. The problem started when I was on 18.3 cinnamon and is occurring on 19. Originally with nvidia GEFORCE EN210. See my signature. I have a new built computer. It has the same MSI Geforce 1050ti but all else different. Still on 19 as 19.1 killed one of my apps. Searching through bugs can find little. Not sure how to report it as it fails so little and no documentation.
Rich
LM Cinnamon 19, ASUS TUF B450M, Ryzen 5 2600x, 16gb memory, Samsung SSD 970 EVO-Plus, Samsung SSD 850 Pro 256gb, dual 27" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6879
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by Spearmint2 »

maybe your resolution settings don't match the monitor's ratio, 16:9 or 16:10
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

benchrest
Level 3
Level 3
Posts: 100
Joined: Tue Jan 17, 2012 2:19 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by benchrest »

my monitors are set to 16:9 1920 x 1080 and refresh rate is set at 60hz as the monitor requires. But both these settings were auto. Also I might have had two 24 in monitors when this started, can't be sure. I believe the problem has occurred 1 time today on the right monitor. Yesterday a couple of times on both. I am using the 390.116 driver. Don't remember which driver I had on 18.3
Perhaps a newer driver, but that would require manual install and may bring more grief than the flickering.
Rich
LM Cinnamon 19, ASUS TUF B450M, Ryzen 5 2600x, 16gb memory, Samsung SSD 970 EVO-Plus, Samsung SSD 850 Pro 256gb, dual 27" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison.

dRaiser
Level 1
Level 1
Posts: 9
Joined: Wed Jan 02, 2013 3:13 pm
Location: Poland
Contact:

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by dRaiser »

Same here, sometimes 2D windows flicker with black background intensively, moving mouse on them fixes the issue. Not happening very often, around daily I'd say. Can't find what triggers it specifically. I've seen this issue for years now.

Three monitors, all 1920x1080. Nvidia GTX 660.

Arch Linux, Cinnamon, proprietary driver.

User avatar
lsemmens
Level 9
Level 9
Posts: 2979
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by lsemmens »

I can't remember the details of this entire thread, so, if this has been covered, my apologies. Does this problem occur only in Linux, i.e. also on live OS, or (spit) Windwoes? If that is so, then you are looking at driver issues. Otherwise it might be a dodgy cable, video card or monitor. You will get artifacts if the HDMI cable is too long without any amplification or the like.
Fully mint Household
Out of my mind - please leave a message

dRaiser
Level 1
Level 1
Posts: 9
Joined: Wed Jan 02, 2013 3:13 pm
Location: Poland
Contact:

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by dRaiser »

Only on Linux, only on Cinnamon, only with Nvidia.

shu
Level 1
Level 1
Posts: 3
Joined: Thu Nov 17, 2016 6:30 am

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by shu »

I also have this problem from time to time. Dual monitors (1920*1080 and 1650*1050), Nvidia GTX 960, nvidia-driver 440.44.

When it happens I usually notice that when Firefox is open the desktop and windows behind it start to flicker (the FF window itself is not affected). When I click on the desktop it stops and is ok again.
So, not really a problem, but a bug nevertheless.

I don't use Windows anymore, but I never had a similar problem when I did a few years ago, so I doubt that it's faulty hardware.

fabien85
Level 7
Level 7
Posts: 1641
Joined: Tue Mar 11, 2014 4:30 pm

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by fabien85 »

I am also affected since a long time. Happened on all the LM 18 series, and now on all the 19 series.
It happens only when there is a second monitor attached. At the moment I'm connecting via HDMI, but previously I was using USB-C via an adaptor to VGA.
For me it happens on the primary monitor, i.e. the laptop screen. It's not rare at all, it's enough to have 2+ windows not maximized, and either moving them or moving the mouse hovering above some of the window sections, particularly the upper border. Not 100% systematic, but close to it. Sometimes the whole desktop background becomes black, but that's rarer.
I am using prime-select in Intel mode (will update with Nvidia results)

Code: Select all

$ inxi -CGMS
System:    Host: fabien-UX310UQK Kernel: 4.15.0-72-generic x86_64 bits: 64 Desktop: Cinnamon 4.4.7 
           Distro: Linux Mint 19.3 Tricia 
Machine:   Type: Laptop System: ASUSTeK product: UX310UQK v: 1.0 serial: <root required> 
           Mobo: ASUSTeK model: UX310UQK v: 1.0 serial: <root required> UEFI: American Megatrends 
           v: UX310UQK.311 date: 04/18/2019 
CPU:       Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 554 MHz min/max: 400/2700 MHz Core speeds (MHz): 1: 560 2: 542 3: 689 4: 566 
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.0.8
Update: I also get the black flickering when using the Nvidia graphic card

Code: Select all

Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 390.116
It happens in the same conditions : when an external monitor is attached, and only happens on the primary monitor=laptop screen.
Additionally I made two observations :
- if I disconnect the 2nd monitor, I still get flickering on the laptop screen, until I launch Menu > Preferences > Display which redetects the screens, and then the flickering stops.
- it seems to happen only if I attach the 2nd monitor after having logged to cinnamon. If I shutdown, attach the screen and boot, then I do not seem to have the flickering.

TheJJJ
Level 1
Level 1
Posts: 1
Joined: Wed Jan 08, 2020 5:39 am

Re: Anyone else get flickering desktop backgrounds and windows periodically on NVIDIA cards in Cinnamon?

Post by TheJJJ »

Same issue here with different systems (notebooks).

1. Mint 19.2 on HP with AMD Ryzen gpu. Samsung 38 inch wide display on hdmi. Issue is not that bad. Open source driver.

2a. Mint 19.2 on Lenovo with intel gpu. Samsung 38 inch wide display on hdmi or usb-c. Issue very bad.
2b. Mint 19.3 on Lenovo - new install. Issue is still very bad.

3. Mint 19.2 on another Lenovo with intel and nvidia gpus. Samsung 38 inch. Issue is medium bad. (I don't know what driver is used.)

Found this 6 year old thread https://askubuntu.com/questions/263996/ ... cker-issue where it still is not fixed.

We will try to connect/start the screens before boot.
Cinnemon restard via STRG-ALT-ESC currently fixes it.

Will reply if we got news / experience with this workaround.

Post Reply

Return to “Cinnamon”