Lost Panel after update (SOLVED)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 12:08 am

bushyiii wrote:
Wed Feb 06, 2019 12:06 am
Received an error:
mint@mint:/mnt/guy$ sudo mv -v ..cache/ .cache/.bak
mv: cannot stat '..cache/': No such file or directory

Did not continue with the terminal commands since this error.
My fault - it's getting late here :oops:

Code: Select all

sudo mv -v .cache/  .cache.bak
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 12:20 am

Does this help?

Code: Select all

mint@mint:/mnt/guy$ sudo ls .cache
 akonadi_kalarm_resource_4
 boomaga.env
 calibre
 chromium
 cs_backgrounds
 dconf
 event-sound-cache.tdb.bbada5cfcc9a4a80ac8dc5ce6d9f53aa.x86_64-pc-linux-gnu
 flatpak
 fontconfig
 gegl-0.3
 geocode-glib
 gnome-calculator
 gnome-disks
 gnome-screenshot
 google-chrome
 gstreamer-1.0
 icon-cache.kcache
'ksycoca5_en_fjc+hb8W+0bOZLcQrkdiWKz1OXs='
'ksycoca5_en_uu9bJKPNb90xyFgL0Yb30KRzAJE='
 libgweather
 media-art
 mesa
 mesa_shader_cache
 midori
 mintinstall
 motd.legal-displayed
 mozilla
 obexd
 pip
 rhythmbox
 rygel
 shutter
 simple-scan
 thumbnails
 thunderbird
 tomboy
 transmission
 vlc
 wallpaper
 webkit
 webkitgtk
 wine
 winetricks
 xreader

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 12:24 am

move it - it will not hurt anything. It can always be moved back.

In any event how much worse can it get :?:
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 12:50 am

Well, there was a slight improvement but no panel. What I noticed was that the min, max, close icons are now correct. The cursor is an arrowhead when I move it across the open folder but turns into an X when I move it to a blank area of the desktop.

It's pretty late for me so I bid you good night and appreciate all your efforts.

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 12:59 am

bushyiii wrote:
Wed Feb 06, 2019 12:50 am
Well, there was a slight improvement but no panel. What I noticed was that the min, max, close icons are now correct. The cursor is an arrowhead when I move it across the open folder but turns into an X when I move it to a blank area of the desktop.

It's pretty late for me so I bid you good night and appreciate all your efforts.
Getting late here too.

A lot happens upgrading versions so it's difficult to pin-down what caused the problem.

You could try a chroot to reinstall the display manager.

My only other recommendation would be to do a fresh install of 19.1.
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 1:09 am

i don't know how to do this:"You could try a chroot to reinstall the display manager."

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 1:22 am

bushyiii wrote:
Wed Feb 06, 2019 1:09 am
i don't know how to do this:"You could try a chroot to reinstall the display manager."
I would have to walk you through that for sure, but not tonight.
ImageImage

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 7:23 am

bushyiii,

The last Hail Mary attempt to revive your system. It will reinstall the window manager and already installed cinnamon desktop packages.

Code: Select all

sudo -i
mount /dev/sdf2 /mnt 
mount /dev/sdb1 /mnt/home
mount -t proc none /mnt/proc
mount --rbind /sys /mnt/sys
mount --rbind /dev /mnt/dev
/usr/sbin/chroot /mnt /bin/bash
source /etc/profile
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
export PS1="\[\033[1;33m\]chroot to ->\[\033[1;31m\](system) #\[\e[0m\] "
apt get install --reinstall $(dpkg -S $(cat /etc/X11/default-display-manager)|awk '{print $1}'|tr -d :)
apt search cinnamon|grep ^i|awk '{print $2}'|xargs apt-get install --reinstall
reboot
Cross your fingers - it helps sometimes :wink:
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 8:54 am

I rebooted this morning and the drives are listed differently but I think I modified your commands correctly.
Home is on sda1 and the OS is on SDD2
All the commands were accepted without error until this one:
chroot to ->(system) # apt get install --reinstall $(dpkg -S $(cat /etc/X11/default-display-manager)|awk '{print $1}'|tr -d :)
apt
Usage: apt command [options]

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 9:02 am

What's in that file cat /etc/X11/default-display-manager :?:
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 9:08 am

chroot to ->(system) # cat /etc/X11/default-display-manager
/usr/sbin/lightdm

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 9:10 am

Strange that didn't work

Use apt get install --reinstall lightdm in place of that line
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 9:15 am

Doesn't like it either
apt get install --reinstall lightdm
apt
Usage: apt command [options]
apt help command [options]

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 9:23 am

Sorry again - it's apt-get install --reinstall lightdm
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 9:30 am

Got this last line:"E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)."

reading the output I saw this:"You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
A whole lot of items are then listed...
Should I do "apt-get -f install"
and then apt-get install --reinstall lightdm?

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 9:33 am

What I would do is just execute the apt-get -f install then reboot to see if that fixes it.
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 9:41 am

It completed, I tried reboot and got this response: "chroot to ->(system) # reboot
Running in chroot, ignoring request."

Do I have to hit the power button?

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 9:43 am

Enter exit before reboot or use the Mint Menu 'Quit/Restart'
ImageImage

bushyiii
Level 3
Level 3
Posts: 142
Joined: Thu Apr 07, 2016 12:42 am

Re: Lost Panel after update

Post by bushyiii » Wed Feb 06, 2019 10:27 am

You should change your screen name to Merlin.

Panel is back, things are almost perfect. Something is wrong with Networking. Wired connection isn't working, tried using USB WifI and its not working either.

Should I start another post in a different support area?

I sincerely appreciate all the time you invested in helping me for these two days. I online now from a different box.

User avatar
WharfRat
Level 21
Level 21
Posts: 13159
Joined: Thu Apr 07, 2011 8:15 pm

Re: Lost Panel after update

Post by WharfRat » Wed Feb 06, 2019 10:33 am

bushyiii wrote:
Wed Feb 06, 2019 10:27 am
You should change your screen name to Merlin.

Panel is back, things are almost perfect. Something is wrong with Networking. Wired connection isn't working, tried using USB WifI and its not working either.

Should I start another post in a different support area?

I sincerely appreciate all the time you invested in helping me for these two days. I online now from a different box.
Well that was easy wasn't it :D

You followed instructions perfectly :wink:

It would be best to close this and start a new topic in the networking forum since this thread is already pretty looooooong.

You can always include a link to this topic to show how this all came about.
ImageImage

Post Reply

Return to “Newbie Questions”