My PC become noticeably slow

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 54
Joined: Sun Aug 19, 2018 2:48 am

My PC become noticeably slow

Post by bradrar »

I tried doing the sudo apt autoremove and other stuffs using a quick search from google. but none of that is fixing my problem. My pc began to slow down after my last update.

Code: Select all

inxi -Fxz

Code: Select all

less /var/log/apt/history.log

Code: Select all

inxi -Fxz
System:    Host: bradrar-X455LAB Kernel: 4.15.0-45-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: X455LAB v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X455LAB v: 1.0 serial: N/A
           UEFI: American Megatrends v: X455LAB.210 date: 10/28/2015
Battery    BAT0: charge: 20.8 Wh 74.1% condition: 28.1/37.3 Wh (75%)
           model: ASUSTeK ASUS status: Discharging

CPU:       Dual core Intel Core i3-4005U (-MT-MCP-) 
           arch: Haswell rev.1 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6784
           clock speeds: max: 1600 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz
           4: 1596 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           OpenGL: renderer: llvmpipe (LLVM 7.0, 256 bits)
           version: 3.3 Mesa 18.2.2 Direct Render: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-45-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (10.8% used)
           ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 12G used: 11G (93%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 42G used: 37G (92%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 4.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 2800
Info:      Processes: 227 Uptime: 2 min Memory: 1180.7/3854.3MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Code: Select all

Start-Date: 2019-02-02  00:05:47
Commandline: apt-get install screenruler
Requested-By: bradrar (1000)
Install: ruby-text:amd64 (1.3.0-1, automatic), ruby-gtk2:amd64 (3.2.4-1, automatic), ruby-cairo:amd64 (1.15.12-1, automatic), ruby-gettext:amd64 (3.2.9-1, automatic), ru
by-atk:amd64 (3.2.4-1, automatic), screenruler:amd64 (0.960+bzr41-1.2), ruby-cairo-gobject:amd64 (3.2.4-1, automatic), ruby-gobject-introspection:amd64 (3.2.4-1, automat
ic), ruby-locale:amd64 (2.1.2-1, automatic), ruby-pango:amd64 (3.2.4-1, automatic), ruby-gdk-pixbuf2:amd64 (3.2.4-1, automatic), ruby-gio2:amd64 (3.2.4-1, automatic), ru
by-glib2:amd64 (3.2.4-1, automatic)
End-Date: 2019-02-02  00:06:05

Start-Date: 2019-02-03  12:42:15
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 90177564 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp040fwp67
Requested-By: bradrar (1000)
Install: libwayland-egl1:amd64 (1.16.0-1ubuntu1.1~18.04.1, automatic), libllvm7:amd64 (1:7-3~ubuntu0.18.04.1, automatic), libllvm7:i386 (1:7-3~ubuntu0.18.04.1, automatic
), linux-headers-4.15.0-45:amd64 (4.15.0-45.48, automatic), linux-modules-extra-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic), linux-modules-4.15.0-45-generic:amd64 
(4.15.0-45.48, automatic), linux-headers-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic), linux-image-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic)
Upgrade: poppler-utils:amd64 (0.62.0-2ubuntu2.5, 0.62.0-2ubuntu2.6), libgles2-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), irqbalance:amd64 (1.3.0-0.1,
 1.3.0-0.1ubuntu0.18.04.1), update-manager-core:amd64 (1:, 1:, linux-headers-generic:amd64 (,, libdrm-nouveau2:amd64 (2.4.
91-2, 2.4.95-1~18.04.1), libdrm-nouveau2:i386 (2.4.91-2, 2.4.95-1~18.04.1), linux-libc-dev:amd64 (4.15.0-43.46, 4.15.0-45.48), libapt-inst2.0:amd64 (1.6.6, 1.6.8), libeg
l-mesa0:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libcairo-gobject2:amd64 (1.15.10-2, 1.15.10-2ubuntu0.1), update-notifier-common:amd64 (, 3.192
.1.5), grub-common:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), linux-image-generic:amd64 (,, apt:amd64 (1.6.6, 1.6.8), libavahi-glib1:amd64 (0.7
-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.3, 9.26~dfsg+0-0ubuntu0.18.04.4), libkmod2:amd64 (24-1ubuntu3.1, 24-1ubuntu3.2), libglapi-mesa
:i386 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libglapi-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libasound2-data:amd64 (1.1.3-5ubuntu0.1
, 1.1.3-5ubuntu0.2), snapd:amd64 (2.34.2+18.04, 2.37.1+18.04), libavahi-common-data:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libavahi-common-data:i386 (0.7-3.1ubuntu1
.1, 0.7-3.1ubuntu1.2), libavahi-common3:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libavahi-common3:i386 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), google-chrome-stable:amd6
4 (71.0.3578.98-1, 72.0.3626.81-1), libxatracker2:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), grub2-common:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), libeg
l1-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), network-manager-gnome:amd64 (1.8.10-2ubuntu1, 1.8.10-2ubuntu2), libapt-pkg5.0:amd64 (1.6.6, 1.6.8), gir
1.2-nmgtk-1.0:amd64 (1.8.10-2ubuntu1, 1.8.10-2ubuntu2), kmod:amd64 (24-1ubuntu3.1, 24-1ubuntu3.2), libgbm1:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libw
ayland-client0:amd64 (1.14.0-2, 1.16.0-1ubuntu1.1~18.04.1), libdrm-amdgpu1:amd64 (2.4.91-2, 2.4.95-1~18.04.1), libdrm-amdgpu1:i386 (2.4.91-2, 2.4.95-1~18.04.1), libtiff5
:amd64 (4.0.9-5, 4.0.9-5ubuntu0.1), libtiff5:i386 (4.0.9-5, 4.0.9-5ubuntu0.1), grub-efi-amd64-bin:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), python3-distupgrade:amd64 (1
:18.04.29, 1:18.04.30), python3-update-manager:amd64 (1:, 1:, ubuntu-release-upgrader-core:amd64 (1:18.04.29, 1:18.04.30), avahi-daemon:amd64 (0.7-3
.1ubuntu1.1, 0.7-3.1ubuntu1.2), tar:amd64 (1.29b-2, 1.29b-2ubuntu0.1), firefox-locale-en:amd64 (64.0+linuxmint2+tessa, 65.0+linuxmint1+tessa), libavahi-core7:amd64 (0.7-
3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libwayland-egl1-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libdrm2:amd64 (2.4.91-2, 2.4.95-1~18.04.1), libdrm2:i386 
(2.4.91-2, 2.4.95-1~18.04.1), libnma0:amd64 (1.8.10-2ubuntu1, 1.8.10-2ubuntu2), ghostscript:amd64 (9.26~dfsg+0-0ubuntu0.18.04.3, 9.26~dfsg+0-0ubuntu0.18.04.4), apt-utils
:amd64 (1.6.6, 1.6.8), ghostscript-x:amd64 (9.26~dfsg+0-0ubuntu0.18.04.3, 9.26~dfsg+0-0ubuntu0.18.04.4), libgl1-mesa-dri:i386 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~1
8.04.1), libgl1-mesa-dri:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), grub-efi-amd64:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), libosmesa6:amd64 (18.0.5-0ub
untu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libosmesa6:i386 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libgs9-common:amd64 (9.26~dfsg+0-0ubuntu0.18.04.3, 9.26~dfsg
+0-0ubuntu0.18.04.4), avahi-autoipd:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libasound2:amd64 (1.1.3-5ubuntu0.1, 1.1.3-5ubuntu0.2), libasound2:i386 (1.1.3-5ubuntu0.1,
:Remove: libllvm6.0:i386 (1:6.0-1ubuntu2)
End-Date: 2019-02-03  13:53:35

Start-Date: 2019-02-03  13:54:56
Commandline: apt-get install --reinstall mint-meta-cinnamon cinnamon cinnamon-common
Requested-By: bradrar (1000)
Reinstall: mint-meta-cinnamon:amd64 (2018.06.08), cinnamon:amd64 (3.8.9+tara), cinnamon-common:amd64 (3.8.9+tara)
End-Date: 2019-02-03  13:55:10

Start-Date: 2019-02-03  13:58:12
Commandline: apt-get remove --purge -y linux-*-4.15.0-43*
Requested-By: bradrar (1000)
Purge: linux-headers-4.15.0-43:amd64 (4.15.0-43.46), linux-modules-4.15.0-43-generic:amd64 (4.15.0-43.46), linux-headers-4.15.0-43-generic:amd64 (4.15.0-43.46), linux-modules-extra-4.15.0-43-generic:amd64 (4.15.0-43.46), linux-image-4.15.0-43-generic:amd64 (4.15.0-43.46)
End-Date: 2019-02-03  13:58:52

Start-Date: 2019-02-03  14:06:51
Commandline: aptdaemon role='role-remove-packages' sender=':1.136'
Remove: bleachbit:amd64 (2.0-2)
End-Date: 2019-02-03  14:06:56

Start-Date: 2019-02-03  14:07:30
Commandline: aptdaemon role='role-remove-packages' sender=':1.136'
Remove: inkscape:amd64 (0.92.3-1)
End-Date: 2019-02-03  14:07:36

Can anyone help me? This is my update history and system info. Thanks.

EDIT: after my update last February 2, when I start my computer again, I am stuck with a login loop . But it was fixed with this thread viewtopic.php?t=274362. That's when I noticed it began to slow down.

User avatar
Level 21
Level 21
Posts: 14870
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)

Re: My PC become noticeably slow

Post by Pjotr »

A root partition that's filled for 93 %. And a /home that's filled for 92 %. :shock:

Create free space there. A lot of it. No Linux partition should ever be filled for more than 75-80 %, in order to prevent file fragmentation:
https://easylinuxtipsproject.blogspot.c ... 1.html#ID4
(item 4)
Tip: 10 things to do after installing Linux Mint 19.3 Tricia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
All in all, horse sense simply makes sense.

Level 2
Level 2
Posts: 54
Joined: Sun Aug 19, 2018 2:48 am

Re: My PC become noticeably slow

Post by bradrar »

Pjotr wrote:
Wed Feb 06, 2019 2:08 pm
A root partition that's filled for 93 %. And a /home that's filled for 92 %. :shock:

Create free space there. A lot of it. No Linux partition should ever be filled for more than 75-80 %, in order to prevent file fragmentation:
https://easylinuxtipsproject.blogspot.c ... 1.html#ID4
(item 4)

I read the item 4 part, It says that the partition should have 20% free space but it doesn't say how. So I went and read the item 5 and followed the instruction there. My home is now 88% but still not enough. Any thoughts how to make my root below 80%

Level 4
Level 4
Posts: 463
Joined: Sat May 18, 2013 5:13 pm

Re: My PC become noticeably slow

Post by hcentaur13 »

When shrinking is not enough:

buy another disk or ssd.
create partitions on it that are able the hold enough free space after moving a directory tree from its curtrent place to it.
move a complete tree into its root
recreate the moved directory with its old name
mount the partition in it

use the documentation in a terminal
man mountpoint
man mount
man umount
man fstab

You needs a temporary mountpoint to have access to both, the new partition and the old directory to move its content from its old location into the new one. Thereafter there is no need foir the temporary mountpoint but a new one withe the name of the moved directory. Because the mountpoint itself stunds for the name of the old directory.

Each directory can be eithe a simple directory that contains its content or a mnountpoit that points to its content whereever it is located now.

While a directory tree is moved nothing else should hgave access to it. In question you have to boot into your live system, move the data there and modifiy /etc/fstab of the installed system! from there. The fstab of the installed system is NOT the fstab of the live system!

Post Reply

Return to “Newbie Questions”