Audible static in headphones from front audio jack.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Audible static in headphones from front audio jack.

Post by Smeejo1 »

On my pc I have 2 audio ports. One in the back of the computer that my desktop speakers are plugged in to and another on the front of my computer that I have my headphones plugged in to. In order to use one or the other I have to go into sound preferences in the output section and tell it to use either Line out or Headphones.


When I use my desktop speakers through Line out everything is fine. However when I use my headphones the sound works great with the exception of some static noise that I can hear in the headphones. It's not consistent and happens at random intervals. It happens most often when I'm playing a game but sometimes it will happen when I'm browsing the internet as well.

I posted the issue to reddit and someone there suggested I try adding
options snd-hda-intel model=dell-headset-multi
to
/etc/modprobe.d/alsa-base.conf
to fix it but it did not help.

I was also asked to run
lspci -nnk | grep -iA2 audio
the output of that was
00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] Subsystem: Micro-Star International Co., Ltd. [MSI] SBx00 Azalia (Intel HDA) [1462:f641] Kernel driver in use: snd_hda_intel

01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fbc] (rev a1) Subsystem: eVga.com. Corp. Device [3842:3753] Kernel driver in use: snd_hda_intel

PC Specs:
Os: Linux Mint 19.1 Tessa 64-bit
Kernel: Linux 4.15.0-46-generic x86_64
De: MATE 1.20.1
Cpu: AMD FX4300
Gpu: Nvidia GTX 750 TI
Driver: 390.116-0ubuntu0.18.04.1
Ram: 16GB DDR3 1333
Headphones: Skullcandy Hesh 2

The output of inxi -Fxz is
System:
Host: ******-MS-7641 Kernel: 4.15.0-46-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic
Machine:
Type: Desktop Mobo: MSI model: 760GM-P23(FX) (MS-7641) v: 3.0
serial: <filter> BIOS: American Megatrends v: 17.13 date: 12/14/2012
CPU:
Topology: Quad Core model: AMD FX-4300 bits: 64 type: MCP arch: Bulldozer
L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 30399
Speed: 1799 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1799 2: 1799
3: 1778 4: 1580
Graphics:
Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: eVga.com.
driver: nvidia v: 390.116 bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116
direct render: Yes
Audio:
Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 00:14.2
Device-2: NVIDIA vendor: eVga.com. driver: snd_hda_intel v: kernel
bus ID: 01:00.1
Sound Server: ALSA v: k4.15.0-46-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: 2.3LK-NAPI port: e800
bus ID: 02:00.0
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 47.38 GiB (10.2%)
ID-1: /dev/sda vendor: Toshiba model: DT01ACA050 size: 465.76 GiB
Partition:
ID-1: / size: 441.69 GiB used: 47.38 GiB (10.7%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
Sensors:
System Temperatures: cpu: 35.1 C mobo: N/A gpu: nvidia temp: 38 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:
Processes: 201 Uptime: 15d 16h 22m Memory: 15.66 GiB
used: 3.69 GiB (23.6%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0
Shell: bash v: 4.4.19 inxi: 3.0.27

rene
Level 14
Level 14
Posts: 5288
Joined: Sun Mar 27, 2016 6:58 pm

Re: Audible static in headphones from front audio jack.

Post by rene »

There's a fair chance it's simple interference; frontpanel audio ground sharing some other ground such as USB's for example. In that case it would be the same in Windows and I would suggest first of all trying that. No need to go hunt down obscurities when it's an electrical issue.

For what it's worth, on especially older computers being able to hear IRQs fire through headphones was fairly common. Sometimes experimenting with some homemade shielding did help, sometimes it didn't.

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

If it works clearly in Windows, there's a decent chance the static is being caused by loopback mixing being enabled. To disable that, type alsamixer in the terminal and when it opens you may need to press F6 to select the non-nvidia card. You use the right arrow key to move to the Loopback Mixing column then the down arrow until it says Disabled.

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

rene wrote:
Sun Apr 14, 2019 12:26 pm
There's a fair chance it's simple interference; frontpanel audio ground sharing some other ground such as USB's for example. In that case it would be the same in Windows and I would suggest first of all trying that. No need to go hunt down obscurities when it's an electrical issue.

For what it's worth, on especially older computers being able to hear IRQs fire through headphones was fairly common. Sometimes experimenting with some homemade shielding did help, sometimes it didn't.
It's not the same in windows. I never had this issue until I switched to Linux so I doubt it's a ground issue.
MrEen wrote:
Sun Apr 14, 2019 3:05 pm
If it works clearly in Windows, there's a decent chance the static is being caused by loopback mixing being enabled. To disable that, type alsamixer in the terminal and when it opens you may need to press F6 to select the non-nvidia card. You use the right arrow key to move to the Loopback Mixing column then the down arrow until it says Disabled.
Loopback is already disabled.

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

Okay. Give this a shot:
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Users of 19 and later versions of Mint type this in the terminal: xed admin:///etc/pulse/default.pa
Find the line that says load-module module-udev-detect and change it to load-module module-udev-detect tsched=0
Save the file, then run pulseaudio -k in the terminal and test your sound

rene
Level 14
Level 14
Posts: 5288
Joined: Sun Mar 27, 2016 6:58 pm

Re: Audible static in headphones from front audio jack.

Post by rene »

The difference back/front interferes with most general suggestions unfortunately. At the moment the only thing I can think of is a possibly automute setting for front audio on alsamixer. Have you tried everything there?

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

MrEen wrote:
Sun Apr 14, 2019 7:38 pm
Okay. Give this a shot:
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Users of 19 and later versions of Mint type this in the terminal: xed admin:///etc/pulse/default.pa
Find the line that says load-module module-udev-detect and change it to load-module module-udev-detect tsched=0
Save the file, then run pulseaudio -k in the terminal and test your sound
Not only did that not fix it, I now have no audio at all

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

Never seen that happen before. Just change it back. Sorry!

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

MrEen wrote:
Sun Apr 14, 2019 8:16 pm
Never seen that happen before. Just change it back. Sorry!
I'd love to but I don't remember what it said before. It had an ending to it that was .something

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

The line should have originally had load-module module-udev-detect. No .something added if it was still the default setting.

Also, the loss of audio may have been from not restarting the browser/player after running pulseaudio -k.

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

Ok so the problem I seem to be having now (no audio at all) seems to be related to sound preferences.

Before in sound preferences under output my default was Built-in Audio Analog Stereo and I would click the drop down box at Connector: and change it between Line Out and Headphones.

Now for some reason I have Built-in Audio Digital Stereo (IEC985) listed there along with the Analog and the Digital Stereo keeps getting set as Default even after I change it to the other one.

I've corrected the missing .something. Turns out it was a seperate line that said
#.else

I've restored
load-module module-udev-detect
back to default and tried changing it to
load-module module-udev-detect tsched=0
load-module module-udev-detect tsched=1
load-module module-udev-detect tsched=yes

None of those have stopped the static and since changing everything back to default settings I still have no sound because sound preferences keeps setting things back to
Built-in Audio Digital Stereo (IEC985)
no matter what I do.

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

Install and run PulseAudio Volume Control. On the Configuration tab, make sure the Digital Option is not selected if it's on the same Profile as the Analog. Then on the Output Devices tab, click on the check mark next to the Port that has Speakers/Headphones so that it is highlighted.

That should cure the default issue.

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

When I install and run pavucontrol I can get sound back in firefox but not in my game. When I close my game I no longer have audio at all again and digital is reset to the default even in pulseaudio.

At this point I'm about ready to say screw it and switch to a different distro. This is so frustrating.

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

See if deleting the files in /home/YourUserName/.config/pulse then running pulseaudio -k in the terminal stops this crud from happening. The files will get recreated with a fresh set after pulseaudio -k has been run. You need to restart Firefox again after that.

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

On the static issue, have you ensured the detachable cord is properly/fully seated in the headphones?

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

Didn't fix it, cord is properly set/plugged in

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

Start a song or video, then run pacmd list-sinks in the terminal. Paste the output it gives along with the output of pacmd list-cards please.

This is really strange. I'm hoping one of those will help figure it out.

Also, is the game running under Linux, or some other way?

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

Another possibility, check the Playback tab of PulseAudio VC when the game is playing. It may be defaulting to the Digital and you can change it there to Analog.

Smeejo1
Level 1
Level 1
Posts: 18
Joined: Sun Nov 25, 2018 12:28 am

Re: Audible static in headphones from front audio jack.

Post by Smeejo1 »

MrEen wrote:
Sun Apr 14, 2019 9:57 pm
Start a song or video, then run pacmd list-sinks in the terminal. Paste the output it gives along with the output of pacmd list-cards please.

This is really strange. I'm hoping one of those will help figure it out.

Also, is the game running under Linux, or some other way?
All games are run via steam

pacmd list-sinks output
2 sink(s) available.
* index: 1
name: <alsa_output.0.iec958-stereo>
driver: <module-alsa-sink.c>
flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: RUNNING
suspend cause:
priority: 9038
volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 24.90 ms
max request: 4 KiB
max rewind: 64 KiB
monitor source: 2
sample spec: s16le 2ch 48000Hz
channel map: front-left,front-right
Stereo
used by: 1
linked by: 1
configured latency: 25.00 ms; range is 0.50 .. 341.33 ms
module: 10
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "ALC887-VD Digital"
alsa.id = "ALC887-VD Digital"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "1"
alsa.card = "0"
alsa.card_name = "HDA ATI SB"
alsa.long_card_name = "HDA ATI SB at 0xfcff4000 irq 16"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:14.2"
sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
device.bus = "pci"
device.vendor.id = "1002"
device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
device.product.id = "4383"
device.product.name = "SBx00 Azalia (Intel HDA)"
device.form_factor = "internal"
device.string = "iec958:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "iec958-stereo"
device.profile.description = "Digital Stereo (IEC958)"
device.description = "Built-in Audio Digital Stereo (IEC958)"
alsa.mixer_name = "Realtek ALC887-VD"
alsa.components = "HDA:10ec0887,1462f641,00100302"
device.icon_name = "audio-card-iec958-pci"
index: 4
name: <alsa_output.pci-0000_00_14.2.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9039
volume: front-left: 35466 / 54% / -16.00 dB, front-right: 35466 / 54% / -16.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 7
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
card: 1 <alsa_card.pci-0000_00_14.2>
module: 8
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "ALC887-VD Analog"
alsa.id = "ALC887-VD Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA ATI SB"
alsa.long_card_name = "HDA ATI SB at 0xfcff4000 irq 16"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:14.2"
sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
device.bus = "pci"
device.vendor.id = "1002"
device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
device.product.id = "4383"
device.product.name = "SBx00 Azalia (Intel HDA)"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analog Stereo"
device.description = "Built-in Audio Analog Stereo"
alsa.mixer_name = "Realtek ALC887-VD"
alsa.components = "HDA:10ec0887,1462f641,00100302"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)
properties:

analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
active port: <analog-output-headphones>
pacmd list-cards outut
2 card(s) available.
index: 0
name: <alsa_card.pci-0000_01_00.1>
driver: <module-alsa-card.c>
owner module: 7
properties:
alsa.card = "1"
alsa.card_name = "HDA NVidia"
alsa.long_card_name = "HDA NVidia at 0xfebf8000 irq 19"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:01:00.1"
sysfs.path = "/devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1"
device.bus = "pci"
device.vendor.id = "10de"
device.vendor.name = "NVIDIA Corporation"
device.product.id = "0fbc"
device.string = "1"
device.description = "HDA NVidia"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: no)
output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: no)
output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: no)
output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: no)
output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: no)
output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: no)
off: Off (priority 0, available: unknown)
active profile: <off>
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
index: 1
name: <alsa_card.pci-0000_00_14.2>
driver: <module-alsa-card.c>
owner module: 8
properties:
alsa.card = "0"
alsa.card_name = "HDA ATI SB"
alsa.long_card_name = "HDA ATI SB at 0xfcff4000 irq 16"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:14.2"
sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
device.bus = "pci"
device.vendor.id = "1002"
device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
device.product.id = "4383"
device.product.name = "SBx00 Azalia (Intel HDA)"
device.form_factor = "internal"
device.string = "0"
device.description = "Built-in Audio"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
input:analog-stereo: Analog Stereo Input (priority 60, available: no)
output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5560, available: unknown)
off: Off (priority 0, available: unknown)
active profile: <output:analog-stereo>
sinks:
alsa_output.pci-0000_00_14.2.analog-stereo/#4: Built-in Audio Analog Stereo
sources:
alsa_output.pci-0000_00_14.2.analog-stereo.monitor/#7: Monitor of Built-in Audio Analog Stereo
ports:
analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-input-microphone"
analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-input-microphone"
analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
properties:

analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)
properties:

analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
properties:

User avatar
MrEen
Level 18
Level 18
Posts: 8116
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audible static in headphones from front audio jack.

Post by MrEen »

I'm afraid this is my last post for the night.

In the terminal enter xed admin:///etc/pulse/default.pa and when the file opens, scroll to the bottom and add this line:

Code: Select all

set-default-sink alsa_output.pci-0000_00_14.2.analog-stereo
Save the file then run pulseaudio -k

That should make sure the proper sink stays as the default.

I'll check back in the morning to see where we stand.

Post Reply

Return to “Hardware Support”