[SOLVED] Sound stopped working, pulse audio access denied

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stopped working, pulse audio access denied

Post by MrEen » Sat Jun 08, 2019 2:18 pm

The fault is not there. This is a sneaky little critter, but we'll find it!

Let's see cat /etc/pulse/default.pa along with ls -la ~/.config/pulse and ls -la ~/.config and ls -la ~/.config/autostart and ls -la /etc/xdg/autostart/ please.

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 1:52 am

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ cat /etc/pulse/default.pa
#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/freedesktop/stereo/bell.oga
#load-sample-lazy pulse-hotplug /usr/share/sounds/freedesktop/stereo/device-added.oga
#load-sample-lazy pulse-coldplug /usr/share/sounds/freedesktop/stereo/device-added.oga
#load-sample-lazy pulse-access /usr/share/sounds/freedesktop/stereo/message.oga

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
#load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

# X11 modules should not be started from default.pa so that one daemon
# can be shared by multiple sessions.

### Load X11 bell module
#load-module module-x11-bell sample=x11-bell

### Register ourselves in the X11 session manager
#load-module module-x11-xsmp

### Publish connection data in the X11 root window
#.ifexists module-x11-publish.so
#.nofail
#load-module module-x11-publish
#.fail
#.endif

### Make some devices default
#set-default-sink output
#set-default-source input

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 1:55 am

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ ls -la ~/.config/pulse
total 104
drwx------  2 jugular jugular  4096 Jun 10 06:47 .
drwxr-xr-x 32 jugular jugular  4096 Jun  7 20:09 ..
-rw-------  1 jugular jugular   256 Jun 10 06:47 cookie
-rw-r--r--  1 jugular jugular 20480 Jun 10 06:48 fb3a613ee5294cf3b69a3ebddfd5405a-card-database.tdb
-rw-r--r--  1 jugular jugular    43 Jun 10 06:47 fb3a613ee5294cf3b69a3ebddfd5405a-default-sink
-rw-r--r--  1 jugular jugular    42 Jun 10 06:47 fb3a613ee5294cf3b69a3ebddfd5405a-default-source
-rw-r--r--  1 jugular jugular 12288 Jun 10 06:48 fb3a613ee5294cf3b69a3ebddfd5405a-device-volumes.tdb
-rw-r--r--  1 jugular jugular   696 Jun 10 06:47 fb3a613ee5294cf3b69a3ebddfd5405a-stream-volumes.tdb

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 2:07 am

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ ls -la ~/.config
total 252
drwxr-xr-x 32 jugular jugular  4096 Jun  7 20:09 .
drwx------ 44 jugular jugular 12288 Jun 10 07:05 ..
drwxrwxr-x  2 jugular jugular  4096 Sep 14  2018 autostart
drwxr-xr-x  2 jugular jugular  4096 Sep 14  2018 caja
drwxrwxr-x  2 jugular jugular  4096 Jun  7 20:09 catfish
drwx------  2 jugular jugular  4096 Jan 28 16:55 comix
drwx------  3 jugular jugular  4096 Jan 27 10:52 compiz-1
drwxrwxr-x  2 jugular jugular  4096 Jun 10 07:02 dconf
drwx------  2 jugular jugular  4096 Oct  6  2018 enchant
drwx------  2 jugular jugular  4096 May 31 06:55 gtk-2.0
drwx------  2 jugular jugular  4096 Jun 10 07:02 gtk-3.0
drwxr-xr-x  3 jugular jugular  4096 May 19 11:27 hexchat
drwxr-x--x  7 jugular jugular  4096 Mar  6 08:25 inkscape
-rw-------  1 jugular jugular   392 Jan 26 23:15 kdeglobals
-rw-------  1 jugular jugular  5638 Jan 27 00:35 kdenliverc
-rw-------  1 jugular jugular   378 Mar  6 08:24 ktuberlingrc
drwxrwxr-x  3 jugular jugular  4096 Sep 14  2018 libreoffice
drwx------  3 jugular jugular  4096 Sep 14  2018 metacity
-rw-rw-r--  1 jugular jugular  2035 Jun  5 19:25 mimeapps.list
-rw-rw-r--  1 jugular jugular    89 May 21 13:07 pavucontrol.ini
drwxr-xr-x  2 jugular jugular  4096 May 28 07:24 pix
drwx------  4 jugular jugular  4096 Jun 10 07:03 PrivateInternetAccess
drwx------  2 jugular jugular  4096 Jun 10 07:04 pulse
-rw-rw-r--  1 jugular jugular   104 Jan 26 23:14 QtProject.conf
drwxrwxr-x  2 jugular jugular  4096 Mar  6 08:24 session
drwx------  4 jugular jugular  4096 May  6 21:23 spotify
drwx------  2 jugular jugular  4096 Sep 14  2018 Thunar
drwxrwxr-x  4 jugular jugular  4096 Oct  6  2018 tomboy
drwxr-xr-x  5 jugular jugular  4096 Feb  2 18:40 transmission
-rw-r--r--  1 jugular jugular  5608 Sep 14  2018 Trolltech.conf
drwx------  2 jugular jugular  4096 Sep 14  2018 upstart
-rw-------  1 jugular jugular   632 Sep 14  2018 user-dirs.dirs
-rw-rw-r--  1 jugular jugular     5 Sep 14  2018 user-dirs.locale
drwxrwxr-x  2 jugular jugular  4096 May  7 15:43 vlc
drwxr-xr-x  2 jugular jugular  4096 Oct 13  2018 xed
drwx------  2 jugular jugular  4096 May 18 08:59 xfburn
drwxrwxr-x  7 jugular jugular  4096 Apr  7 09:00 xfce4
drwx------  2 jugular jugular  4096 May  8 20:16 xfce4-session
drwx------  2 jugular jugular  4096 Jun  7 20:14 xplayer
drwx------  2 jugular jugular  4096 Oct 28  2018 xreader
drwx------  2 jugular jugular  4096 Apr  6 13:29 xviewer

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 2:08 am

Code: Select all

ls -la ~/.config/autostart
total 44
drwxrwxr-x  2 jugular jugular 4096 Sep 14  2018 .
drwxr-xr-x 32 jugular jugular 4096 Jun  7 20:09 ..
-rw-rw-r--  1 jugular jugular  235 Jan 28 16:32 dropbox.desktop
-rw-rw-r--  1 jugular jugular  169 Apr 23 17:16 pia_manager.desktop
-rw-r--r--  1 jugular jugular  188 May  8 20:17 xfce-autostart-wm.desktop

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 2:10 am

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ ls -la /etc/xdg/autostart/
total 136
drwxr-xr-x  2 root root 4096 Jun  7 20:10 .
drwxr-xr-x 10 root root 4096 Mar  6 08:06 ..
-rw-r--r--  1 root root  202 Feb 25  2016 at-spi-dbus-bus.desktop
-rw-r--r--  1 root root  339 Mar 19  2017 blueberry-obex-agent.desktop
-rw-r--r--  1 root root  311 Jun 24  2017 blueberry-tray.desktop
-rw-r--r--  1 root root  286 Apr  4  2016 caribou-autostart.desktop
-rw-r--r--  1 root root  485 Nov  1  2015 gnome-keyring-pkcs11.desktop
-rw-r--r--  1 root root  478 Nov  1  2015 gnome-keyring-secrets.desktop
-rw-r--r--  1 root root  445 Nov  1  2015 gnome-keyring-ssh.desktop
-rw-r--r--  1 root root  302 Aug 22  2016 gnome-settings-daemon.desktop
-rw-r--r--  1 root root  279 Nov 27  2015 gsettings-data-convert.desktop
-rw-r--r--  1 root root  262 Jan 20  2017 indicator-application.desktop
-rw-r--r--  1 root root 2445 Dec 21  2015 light-locker.desktop
-rw-r--r--  1 root root  231 May 21  2017 mint-ctrl-alt-backspace.desktop
-rw-r--r--  1 root root  219 Oct  9  2017 mintinstall-update-flatpak.desktop
-rw-r--r--  1 root root  220 Mar 22  2017 mintupdate.desktop
-rw-r--r--  1 root root  169 Apr 26  2017 mintwelcome.desktop
-rw-r--r--  1 root root  350 May 11  2017 nm-applet.desktop
-rw-r--r--  1 root root  285 Jun 10  2016 nvidia-prime.desktop
-rw-r--r--  1 root root  309 Oct 10  2017 onboard-autostart.desktop
-rw-r--r--  1 root root  301 Apr  8  2016 orca-autostart.desktop
-rw-r--r--  1 root root  358 Nov 21  2014 polkit-gnome-authentication-agent-1.desktop
-rw-r--r--  1 root root  375 Mar  8  2016 print-applet.desktop
-rw-r--r--  1 root root 4474 May  2  2018 pulseaudio.desktop
-rw-r--r--  1 root root  213 Mar 22 22:37 snap-userd-autostart.desktop
-rw-r--r--  1 root root  322 Sep 14  2018 user-dirs-update-gtk.desktop
-rw-r--r--  1 root root  445 Sep 14  2018 vino-server.desktop
-rw-r--r--  1 root root 5182 Jul 14  2016 xfce4-power-manager.desktop
-rw-r--r--  1 root root  223 Feb 22  2015 xfce4-volumed.desktop
-rw-r--r--  1 root root 2280 May 14  2015 xfsettingsd.desktop
-rw-r--r--  1 root root 4818 May 26  2015 xscreensaver.desktop

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Mon Jun 10, 2019 2:11 am

Sorry it's a bit late, I was away for the weekend.

Anything in those readouts?

User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stopped working, pulse audio access denied

Post by MrEen » Mon Jun 10, 2019 7:08 am

I think I know what's wrong. In Menu > Settings > Session and Startup > Application Autostart tab click on the checkbox next to the Pulseaudio Sound System entry so that it is UNchecked. Now close this window.

Now in the terminal run sudo cp /etc/xdg/autostart/pulseaudio.desktop ~/.config/autostart followed by sudo chown -Rc $USER:$USER $HOME

The last command should show that it changed that file from root:root to jugular:jugular (and maybe other files as well.) Go back to Menu > Settings > Session and Startup > Application Autostart tab and see if there is a new Pulseaudio Sound System entry that has the box already checked.

Reboot and pulseaudio should be running under your user again.

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Tue Jun 11, 2019 2:10 am

Hey, thanks!

Before I reboot, here's the readout, because it doesn't look right:
changed ownership of '/home/jugular/.pia_manager/log/openvpn.pid' from root:jugular to jugular:jugular

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Tue Jun 11, 2019 2:23 am

After running the first line I checked the Application Autostart and there was a pulseaudio entry with the box now checked. I don't know if it's a new entry, as there's still only one pulseaudio entry- to me it looks like the same one I just unchecked but with the box checked.

I gave you the readout for the second line, which changed one of my vpn files but not a pulseaudio file.

After rebooting sound was not working :(

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

aplay: main:722: audio open error: Connection refused

User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stopped working, pulse audio access denied

Post by MrEen » Tue Jun 11, 2019 6:55 am

Well this is getting weirder. Let's see the output of cat ~/.config/autostart/pulseaudio.desktop now. If there's no error, also ls -la ~/.config/autostart/pulseaudio.desktop

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Tue Jun 11, 2019 3:10 pm

Code: Select all

~ $ cat ~/.config/autostart/pulseaudio.desktop
[Desktop Entry]
Version=1.0
Name=PulseAudio Sound System
Name[as]=PulseAudio শব্দ ব্যৱস্থা
Name[bn_IN]=PulseAudio শব্দ ব্যবস্থা
Name[ca]=Sistema de so PulseAudio
Name[cs]=Zvukový systém PulseAudio
Name[de]=PulseAudio Sound System
Name[de_CH]=PulseAudio Sound System
Name[el]=Σύστημα ήχου PulseAudio
Name[es]=Sistema de Sonido PulseAudio
Name[fi]=PulseAudio-äänijärjestelmä
Name[fr]=Système de son PulseAudio
Name[gu]=PulseAudio સાઉન્ડ સિસ્ટમ
Name[he]=מערכת הקול PulseAudio
Name[hi]=पल्सऑडियो ध्वनि तंत्र
Name[hu]=PulseAudio hangrendszer
Name[id]=Sistem Suara PulseAudio
Name[it]=Sistema sonoro PulseAudio
Name[ja]=PulseAudio サウンドシステム
Name[kn]=PulseAudio ಧ್ವನಿ ವ್ಯವಸ್ಥೆ
Name[ko]=펄스오디오 사운드 시스템
Name[ml]=PulseAudio സൌണ്ട് സിസ്റ്റം
Name[mr]=PulseAudio आवाज प्रणाली
Name[nl]=PulseAudio geluidssysteem
Name[or]=PulseAudio ଧ୍ୱନି ତନ୍ତ୍ର
Name[pa]=ਪਲਸਆਡੀਓ ਸਾਊਂਡ ਸਿਸਟਮ
Name[pl]=System dźwięku PulseAudio
Name[pt]=Sistema de Som PulseAudio
Name[pt_BR]=Sistema de som PulseAudio
Name[ru]=Звуковая система PulseAudio
Name[sk]=Zvukový systém PulseAudio
Name[sr]=PulseAudio звучни систем
Name[sr@latin]=PulseAudio zvučni sistem
Name[sv]=PulseAudio ljudsystem
Name[ta]=பள்ஸ் ஆடியோ ஒலி கணினி
Name[te]=PulseAudio శబ్దపు సిస్టమ్
Name[tr]=PulseAudio Ses Sistemi
Name[uk]=Звукова система PulseAudio
Name[zh_CN]=PulseAudio 声音系统
Name[zh_TW]=PulseAudio 音效系統
Comment=Start the PulseAudio Sound System
Comment[as]=PulseAudio শব্দ ব্যৱস্থা আৰম্ভ কৰা হ'ব
Comment[bn_IN]=PulseAudio শব্দ ব্যবস্থা আরম্ভ করা হবে
Comment[ca]=Inicialitza el sistema de so PulseAudio
Comment[cs]=Spustit zvukový systém PulseAudio
Comment[de]=Das PulseAudio Sound System starten
Comment[de_CH]=Das PulseAudio Sound System starten
Comment[el]=Έναρξη του συστήματος ήχου PulseAudio
Comment[es]=Iniciar el Sistema de Sonido PulseAudio
Comment[fi]=Käynnistä PulseAudio-äänijärjestelmä
Comment[fr]=Démarrer le système de son PulseAudio
Comment[gu]=PulseAudio સાઉન્ડ સિસ્ટમને શરૂ કરો
Comment[he]=התחל את מערכת הקול PulseAudio
Comment[hi]=पल्सऑडियो ध्वनि तंत्र प्रारंभ करें
Comment[hu]=A PulseAudio hangrendszer elindítása
Comment[id]=Memulai Sistem Suara PulseAudio
Comment[it]=Avvia il sistema sonoro PulseAudio
Comment[ja]=PulseAudio サウンドシステムを開始
Comment[kn]=PulseAudio ಧ್ವನಿ ವ್ಯವಸ್ಥೆಯನ್ನು ಆರಂಭಿಸಿ
Comment[ko]=펄스오디오 사운드 시스템을 시작합니다
Comment[ml]=PulseAudio സൌണ്ട് സിസ്റ്റം ആരംഭിക്കുക
Comment[mr]=PulseAudio आवाज प्रणाली सुरू करा
Comment[nl]=Start het PulseAudio geluidssysteem
Comment[or]=PulseAudio ଧ୍ୱନି ତନ୍ତ୍ରକୁ ଆରମ୍ଭ କରନ୍ତୁ
Comment[pa]=ਪਲਸਆਡੀਓ ਸਾਊਂਡ ਸਿਸਟਮ ਚਲਾਓ
Comment[pl]=Uruchomienie systemu dźwięku PulseAudio
Comment[pt]=Inciar o Sistema de Som PulseAudio
Comment[pt_BR]=Iniciar o sistema de som PulseAudio
Comment[ru]=Запуск звуковой системы PulseAudio
Comment[sk]=Spustenie zvukového systému PulseAudio
Comment[sr]=Покрени PulseAudio звучни систем
Comment[sr@latin]=Pokreni PulseAudio zvučni sistem
Comment[sv]=Starta ljudsystemet PulseAudio
Comment[ta]=பள்ஸ் ஆடியோ ஒலி கணினியை துவக்கவும
Comment[te]=PulseAudio శబ్దపు సిస్టమ్‌ను ప్రారంభించుము
Comment[tr]=PulseAudio Ses Sistemini Başlat
Comment[uk]=Запустити звукову систему PulseAudio
Comment[zh_CN]=启动 PulseAudio 声音系统
Comment[zh_TW]=啟動 PulseAudio 音效系統
Exec=start-pulseaudio-x11
Terminal=false
Type=Application
Categories=
GenericName=
X-GNOME-Autostart-Phase=Initialization
X-KDE-autostart-phase=1
NoDisplay=true

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Tue Jun 11, 2019 3:11 pm

Code: Select all

~ $ ls -la ~/.config/autostart/pulseaudio.desktop
-rw-rw-r-- 1 jugular jugular 4474 Jun 11 07:17 /home/jugular/.config/autostart/pulseaudio.desktop

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Tue Jun 11, 2019 3:27 pm

I don't know if it helps to mention this again, but this all started when I wanted to record computer playback on audacity, and blindly following instructions, I think I did this: $ snap install pulseaudio

It all seemed to work, but it was on the next reboot that my sound stopped working. And now I know that pulseaudio is just the default audio thingy on Linux Mint, surely installing another one on top must have messed it up somehow?

User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stopped working, pulse audio access denied

Post by MrEen » Tue Jun 11, 2019 6:09 pm

Well. That's far too logical! I must have skimmed over that previously and didn't pay enough heed.

Although I don't think it could interfere unless you ran snap pulseaudio or something like that.

Let's see what these return:
sudo fuser -v /dev/snd*
which pulseaudio
pulseaudio --version

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Wed Jun 12, 2019 11:34 am

I think I might have run snap pulseaudio! Though I can't remember

Code: Select all

jugular@jugular-ThinkPad-T60 ~ $ which pulseaudio
/usr/bin/pulseaudio
jugular@jugular-ThinkPad-T60 ~ $ pulseaudio --version
pulseaudio 8.0
jugular@jugular-ThinkPad-T60 ~ $ 

User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound stopped working, pulse audio access denied

Post by MrEen » Wed Jun 12, 2019 1:39 pm

Oops, one more that I'll get right this time: sudo fuser -v /dev/snd/*

This one should have your username in front of the pulseaudio entries. When you first boot up though, I'm sure it says root.

I'm still trying to think of what I've missed to get this corrected.

One other thing we can look at is snap list. If pulseaudio is there, we can remove it with sudo snap remove pulseaudio. I'm thinking it's not going to be there though. Like me, you have an ancient version of pulseaudio (8.0) that came with the 18.x versions of Mint. I think the 19.x versions have pulseaudio 12.0.

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: Sound stopped working, pulse audio access denied

Post by jugular » Thu Jun 13, 2019 2:43 am

This was done after a boot up, ie before killing pulseaudio as sudo and then starting it again to make the sound work.

Code: Select all

~ $ sudo fuser -v /dev/snd/*
[sudo] password for jugular: 
                     USER PID ACCESS COMMAND
/dev/snd/controlC0:  root       1595 F.... pulseaudio

jugular
Level 1
Level 1
Posts: 26
Joined: Mon Jun 03, 2019 2:58 am

Re: [SOLVED] Sound stopped working, pulse audio access denied

Post by jugular » Thu Jun 13, 2019 2:50 am

It was in the snap list! Removed it, rebooted, and.... SOUND!!!

Thanks so much, is there anything I can do in kind? Happy to send you something so you can get yourself a drink on me.

User avatar
MrEen
Level 15
Level 15
Posts: 5527
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Sound stopped working, pulse audio access denied

Post by MrEen » Thu Jun 13, 2019 6:43 am

Hey, I'm just glad you're fixed! If you stick with Mint, consider donating to the project here: https://linuxmint.com/donors.php

I can't afford to donate myself, so I help here where I can as my way of paying back to the team.

Have fun. And remember to be a little more careful about blindly following instructions. If unsure, you can always ask on the forum. Although sometimes I think it's better to just make the mistake and try to figure out how to solve it. Faciendo Discimus (by doing we learn.)

P.S. Thanks for the reminder about the snap install. I'd have gone in circles for weeks without it.

Post Reply

Return to “Sound, Multimedia, & Codecs”