[SOLVED] Constant crackling noise in Kernel 5.0

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

[SOLVED] Constant crackling noise in Kernel 5.0

Post by Benoît »

Hello Linux Mint!

I'm writing to you today because I'm having a weird sound problem with the Kernel 5.0. I hear a intermittent crackling noise. I'm not sure but I think it's related to something that was happening at start up only when I use the Kernel 4.18.

Here is a video of that start up noise I had before when using 4.18.
https://www.dropbox.com/s/9gqfs6185ws3c ... 5.mp4?dl=0
It only happens once the computer booted, but nothing else after.

Now here is a video of that "new" noise using 5.0
https://www.dropbox.com/s/34g2cenjr7q16 ... 0.mp4?dl=0
As you can hear, the noise is now almost constant. The one time noise of the start up is still there, but it now continues after the login screen. It's very annoying.
Weirdly, when i go to the sound settings, it stops and when I leave the sound settings, it starts again after 10 or so seconds. Annoying and sneaky!

It's not the first time I'm trying to fix this. I've tried something that concerned my card going sleeping mode. I try few other solutions found on the net, but so far no success.

Here is the result of "inxi -Fxz" (while using sill 4.18)

Code: Select all

System:
  Host: i-35 Kernel: 4.18.0-21-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: alldocube product: i35 v: N/A serial: <filter> 
  Mobo: alldocube model: i35 serial: <filter> UEFI: American Megatrends 
  v: 5.12 date: 03/31/2017 
Battery:
  ID-1: BAT0 charge: 33.0 Wh condition: 50.0/50.0 Wh (100%) 
  model: Intel SR 1 SR Real Battery status: Discharging 
  Device-1: hid-0018:04F3:2373.0002-battery model: 04F3200A:00 04F3:2373 
  charge: N/A status: N/A 
CPU:
  Topology: Dual Core model: Intel Core m3-7Y30 bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12864 
  Speed: 800 MHz min/max: 400/2600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 3000x2000~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 615 (Kaby Lake GT2) 
  v: 4.5 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Realtek 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.18.0-21-generic 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 
  bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 20.67 GiB (8.7%) 
  ID-1: /dev/sda model: SATA SSD size: 238.47 GiB 
Partition:
  ID-1: / size: 45.58 GiB used: 20.60 GiB (45.2%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 3.43 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 206 Uptime: 24m Memory: 7.69 GiB used: 2.63 GiB (34.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
Here is the journal when using 5.0:
https://www.dropbox.com/s/3100kk6hcq2tp ... sages?dl=0

I'm not a pro of linux, but I'm not totally stupid neither :)
What more information should I post here for my post to be as informative as it should?
Many many thanks in advance!
Last edited by Benoît on Wed Jul 03, 2019 2:32 pm, edited 1 time in total.

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Sound problem with kernel 5.0

Post by deepakdeshp »

AFAIK the kernel problems can't be attended at this level and it's only by trial and error that you find the most suitable kernel series for yourself. Say you find that 4.15 suits you, then go on upgrading to the latest level of 4.15. That's what I do. Somebody else may have a better answer and will elaborate here.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: Sound problem with kernel 5.0

Post by Benoît »

Hello deepakdeshp,

Thanks for your reply. If I may ask, what forum do you advice to post on?
I'm indeed still using 4.18 and it's fine by me. I was just anticipating :)
I'm of course open to any advice and guidance.

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problem with kernel 5.0

Post by MrEen »

Hi Benoît.

In the terminal run alsamixer then you may need to press F6 to select the appropriate card. Navigate with the right arrow key to the column named Loopback Mixing and then press the down arrow key until it says Disabled. Does that stop the noise?

EDIT: Just listened to the sounds and I don't think that's going to help. Give me a few minutes.

If rmmod pcspkr stops it, we can make that permanent with echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf

Actually, as you're back on 4.18, just use the last command then reboot to see if that stopped it.

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: Sound problem with kernel 5.0

Post by Benoît »

Hello MrEen!

Thanks a lot for your suggestion and sorry for this late reply. Here is the result of the

Code: Select all

rmmod pcspkr

Code: Select all

administrator@i-35:~$ sudo rmmod pcspkr
[sudo] password for administrator:            
rmmod: ERROR: Module pcspkr is not currently loaded
So unfortunately, it's not my pc speaker to blame :(
Out of the blue, do you think it could be linked to my card going to sleep mode and right after going back to normal mode?
What other information can I give you to thinker this out?
I've tried to plug some earphones, but the noise remains and it comes from the pc speaker. Each time I've plugged the jack, I hear one "crack noise"

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problem with kernel 5.0

Post by MrEen »

Benoît wrote:
Tue Jul 02, 2019 12:27 pm
Hello MrEen!

Thanks a lot for your suggestion and sorry for this late reply. Here is the result of the

Code: Select all

rmmod pcspkr

Code: Select all

administrator@i-35:~$ sudo rmmod pcspkr
[sudo] password for administrator:            
rmmod: ERROR: Module pcspkr is not currently loaded
So unfortunately, it's not my pc speaker to blame :(
Out of the blue, do you think it could be linked to my card going to sleep mode and right after going back to normal mode?
What other information can I give you to thinker this out?
I've tried to plug some earphones, but the noise remains and it comes from the pc speaker. Each time I've plugged the jack, I hear one "crack noise"
We can test for power saving causing it with this:
In the terminal enter xed admin:///etc/modprobe.d/alsa-base.conf then enter your password and ignore the warnings. Scroll to the bottom of the file and add this new line:

Code: Select all

options snd_hda_intel power_save=0 power_save_controller=N
Save the file then reboot and test.

If that makes no difference, let's see the output of aplay -l while I try to come up with other ideas. If you recognize which card # is the default sound card that you're using from that output go ahead and add the output of amixer -c# replacing # with the number of the card. If there's only one card, amixer by itself will be enough.

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: Sound problem with kernel 5.0

Post by Benoît »

Hello again.

It was the power saving mode. Adding the line to alsa-base.conf did the trick. Now the constant noise is gone after reboot. I still get the one time noise at start up though, but it is back to where I was before :)
Any idea on how I could make that noise disappear on start up?

A huge thanks to you MrEen!

In the meanwhile, I'll add a more precise title to the threat and a solved prefix.


Here was the result of the commands you asked:

Code: Select all

administrator@i-35:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
administrator@i-35:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 63 [72%] [-18.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 39 [62%] [12.00dB] [on]
  Front Right: Capture 39 [62%] [12.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
administrator@i-35:~$ 

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

I have 2 suggestions. I don't know if either will help, but I believe them to be worth a shot. In the terminal enter alsamixer. There should be a column named Capture. Use the right arrow key to get there, then lower the volume to zero with the down arrow key (it's at 62% right now.) Reboot and see if that stopped it. Assuming no, do the same with the Speaker column. If that works, I can give you instructions to raise the Speaker volume 10 seconds after booting up, so we avoid the noise and you wont have to manually change it either.

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by Benoît »

I try to lower the volumes of both "Capture" and "Speaker" in alsamixer but no success. The noise is still there at start up and when I shut the computer. Just a one time crackling noise each time.
Is there something that touches the sleep mode of the sound card during start up or shutdown else than alsa-base.conf?
Thanks again for any tips or advice you can give1

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by trytip »

i was looking for this result about crackling sound. the crackling would stop if i open sound settings from the volume icon.
i came up with this:

Code: Select all

sudo touch /etc/modprobe.d/snd_hda_intel.conf
sudo nano /etc/modprobe.d/snd_hda_intel.conf
paste this: options snd_hda_intel power_save=0

not sure the diff between using alsa-base.conf or snd_hda_intel.conf but since the crackling has stopped i'll stay with snd_hda_intel.conf see how that works.
Image

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

I had hoped with no volume there'd be no noise. The Capture was just in case it was feedback related or similar.

I'm thinking this may not be any more fixable without opening the case. Seems like when the machine applies power to the card, you get the noise, and a repeat at the end when power is removed.

Some users have added shielding inside for similar issues, but I have no experience with that.

One other thing worth trying. In alsamixer, disable Auto-Mute Mode by selecting it then using the down arrow until it says Disabled. I found some ancient Ubuntu threads that mentioned this. The downside if this works, plugging in headphones will no longer automatically mute the speakers.

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

trytip wrote:
Thu Jul 04, 2019 12:45 pm
i was looking for this result about crackling sound. the crackling would stop if i open sound settings from the volume icon.
i came up with this:

Code: Select all

sudo touch /etc/modprobe.d/snd_hda_intel.conf
sudo nano /etc/modprobe.d/snd_hda_intel.conf
paste this: options snd_hda_intel power_save=0

not sure the diff between using alsa-base.conf or snd_hda_intel.conf but since the crackling has stopped i'll stay with snd_hda_intel.conf see how that works.
It's the same. ALSA reads all .conf files in that dir upon starting. You could have named the file stupid-file-name.conf and it would have done the same thing.

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by trytip »

i'm guessing the kind of speakers used is also relative. ATM i'm using https://www.amazon.com/OontZ-Angle-Ultr ... B073BVWRSP but a 10W model, plugged into the front headphone jack

i see there are a few ways to connect it, with bluetooth, or back panel speaker output. maybe i'll buy two of the 14W and it says you can have one speaker play left and the other right channel

great portable speakers in anycase at reasonable price and enough battery for 20 nonstop hours
Image

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

Found another old post that suggests tlp might be causing it. IF you have tlp installed and running, here's the contents of the post that may help:
For me on Dell xps13 9333 with tlp installed the solution was to edit my tlp settings (in /etc/default/tlp), setting: SOUND_POWER_SAVE_ON_AC=0 SOUND_POWER_SAVE_ON_BAT=0 SOUND_POWER_SAVE_CONTROLLER=N

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by Benoît »

trytip wrote:
Thu Jul 04, 2019 12:45 pm
i was looking for this result about crackling sound. the crackling would stop if i open sound settings from the volume icon.
i came up with this:

Code: Select all

sudo touch /etc/modprobe.d/snd_hda_intel.conf
sudo nano /etc/modprobe.d/snd_hda_intel.conf
paste this: options snd_hda_intel power_save=0

not sure the diff between using alsa-base.conf or snd_hda_intel.conf but since the crackling has stopped i'll stay with snd_hda_intel.conf see how that works.
Hello trypip!

Unlike alsa-base.conf, snd_hda_intel.conf is empty on my end. I guess both solution would stop the constant crackling noise. But it does not stop the "one time noise" at start up or shut down. (even Win10 makes the same noise when i switch off the laptop)
MrEen wrote:
Thu Jul 04, 2019 2:04 pm
Found another old post that suggests tlp might be causing it. IF you have tlp installed and running, here's the contents of the post that may help:
For me on Dell xps13 9333 with tlp installed the solution was to edit my tlp settings (in /etc/default/tlp), setting: SOUND_POWER_SAVE_ON_AC=0 SOUND_POWER_SAVE_ON_BAT=0 SOUND_POWER_SAVE_CONTROLLER=N
Unfortunately, nothing appear in tlp, so I guess I don't have it installed.
MrEen wrote:
Thu Jul 04, 2019 1:08 pm
I had hoped with no volume there'd be no noise. The Capture was just in case it was feedback related or similar.

I'm thinking this may not be any more fixable without opening the case. Seems like when the machine applies power to the card, you get the noise, and a repeat at the end when power is removed.

Some users have added shielding inside for similar issues, but I have no experience with that.

One other thing worth trying. In alsamixer, disable Auto-Mute Mode by selecting it then using the down arrow until it says Disabled. I found some ancient Ubuntu threads that mentioned this. The downside if this works, plugging in headphones will no longer automatically mute the speakers.
I'll try to Auto-Mute Mode in a few minutes and report back!

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by Benoît »

Unfortunately the Auto-Mute did not change anything.

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

Yeah, I think we've done just about everything we can at this point. If you want to fiddle a bit more we can see what happens with this:

Code: Select all

sudo rmmod snd-hda-intel
followed by:

Code: Select all

sudo modprobe snd-hda-intel
I am thinking you'll hear the noise after each command. The first one may fail though, and if it does, don't do the second one. If that's the case, try them first thing after a reboot and see if that changes anything.

If by some miracle they run properly and DON'T produce the noise, we can try doing the first command before shutting down/rebooting to see if that stops the noise on shutdown/reboot. We'll need to make a couple small changes to see if we can also get the bootup noise gone as well.

Benoît
Level 1
Level 1
Posts: 39
Joined: Tue May 30, 2017 4:24 am
Location: Belgium - Brussels

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by Benoît »

MrEen wrote:
Fri Jul 05, 2019 2:52 pm
Yeah, I think we've done just about everything we can at this point. If you want to fiddle a bit more we can see what happens with this:

Code: Select all

sudo rmmod snd-hda-intel
followed by:

Code: Select all

sudo modprobe snd-hda-intel
I am thinking you'll hear the noise after each command. The first one may fail though, and if it does, don't do the second one. If that's the case, try them first thing after a reboot and see if that changes anything.

If by some miracle they run properly and DON'T produce the noise, we can try doing the first command before shutting down/rebooting to see if that stops the noise on shutdown/reboot. We'll need to make a couple small changes to see if we can also get the bootup noise gone as well.
Hello again MrEen!

Sorry for the delayed answer...
Here is the result of the first command. It did not produce a noise. I can't tell if the result is proper or not:

Code: Select all

administrator@i-35:~$ sudo rmmod snd-hda-intel
[sudo] password for administrator:            
rmmod: ERROR: Module snd_hda_intel is in use
Verdict?

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Constant crackling noise in Kernel 5.0

Post by MrEen »

Yeah, I was afraid that's what it would say. Did you try that first thing after booting up? I was hoping that if it was tried before trying to play any sound it might successfully remove. Then the followup command would reinstall it however I'm expecting it'll crackle when it does.

Post Reply

Return to “Software & Applications”