Remmina: Have to allow remote desktop public connections to connect to local computer?

Chat about just about anything else
Post Reply
Netherprovinc3
Level 3
Level 3
Posts: 192
Joined: Mon Feb 04, 2019 9:29 pm

Remmina: Have to allow remote desktop public connections to connect to local computer?

Post by Netherprovinc3 » Sat Jun 22, 2019 11:19 pm

Linux Mint 19.1 Cinnamon 64 bit

I used Remmina, RDP setting to connect to a local Windows 8.1 computer. The only way that I could get the connection to work is when I set the firewall to allow remote desktop through the firewall for both private and public. I would have thought that private means local network only, and so that alone would have been sufficient. I also don't want to have the computer available on the open web for remote desktop connections right now.

The IP address that I used to connect to the Windows 8.1 computer seems to be a local IP address (it starts with 192.168., it's the IPv4 address that shows when I type "ipconfig").
Linux Mint 19.1 Cinnamon

xoverlord6
Level 1
Level 1
Posts: 8
Joined: Wed Nov 27, 2013 6:18 am

Re: Remmina: Have to allow remote desktop public connections to connect to local computer?

Post by xoverlord6 » Thu Jul 11, 2019 1:03 am

Generally your router should protect you here. Most consumer routers won't expose computers on the local network to the public internet unless you change a setting on the router to expose it - i.e. port forwarding, DMZ host, etc.

I'm assuming you're talking about the Windows firewall. When you first establish a connection to a network, Windows will ask you whether it's private (home), work, or public (i.e. a wifi hotspot in a cafe), and then designate it as such. If you had to open the port on "public" it would seem you must have told Windows that the network you're connected to is "public", even though it is your private network.

gm10
Level 19
Level 19
Posts: 9775
Joined: Thu Jun 21, 2018 5:11 pm

Re: Remmina: Have to allow remote desktop public connections to connect to local computer?

Post by gm10 » Thu Jul 11, 2019 5:30 am

Windows firewall gives you the possibility to create fully custom rules, too, which allows you to exactly specify the scope of the rule using e.g. only the specific IP of your Linux Mint computer or a range of IPs or network mask matching your entire local network.

This would have been better asked in a Windows support forum by the way, or at least not in the Linux Mint support section for it has got nothing to do with Linux Mint.
Last edited by gm10 on Thu Jul 11, 2019 11:18 am, edited 1 time in total.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

User avatar
karlchen
Level 20
Level 20
Posts: 11428
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Remmina: Have to allow remote desktop public connections to connect to local computer?

Post by karlchen » Thu Jul 11, 2019 11:15 am

<mod>
Moved the thread from Linux Mint Main Edition to Open Chat. Reason: The reported problem is clearly on the Windows 8.1 side, not on the Linux Mint side. As a result this thread is about Windows, not about Linux Mint.
</mod>
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Post Reply

Return to “Open chat”