[SOLVED] Wireless initially worked from USB, after install WiFi card not detected from add install OR USB image?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

[SOLVED] Wireless initially worked from USB, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 12:35 am

I'm new to linux mint, I used Ubuntu several years ago for a year or two, but im a noob still. So my laptop died recently and with no money and desperate need of a computer I bought an old HP 8000 elite. I wasn't sure if the machine had some built in WiFi or something, but I couldn't see a WiFi card so I plugged in my old tp link WN881ND (UN) 1.0

I installed linux mint cinnamon onto USB flash drive and booted it on the HP. WiFi worked straight off the bat. I booted it 2 more times, once to check my old 2tb hdd, and once to check my old ssd and grab any files I wanted off it before installing mint (over my old windows 7 on ssd) and WiFi worked the 3 first boots. I was surprised because all I've ever had is trouble with linux and WiFi, its what kept me from using linux on my last computer.

I selected install proprietary drivers when I installed.

Then I booted from the ssd, and there's no wifi available, the network icon only says wired connection unplugged. When I go to driver manager it says "no proprietary drivers installed.". Then I disconnected the ssd, thinking that I'd run the USB version again and find out what the driver is. But now WiFi doesn't work from the USB either.

So I reflashed the USB, tried again, still not working. So I figure the install process has changed something in bios, so reset bios defaults, still not working. This computer doesn't appear to have secure boot either, which I know is causing some people problems.

I'm on my phone now, but plan on heading up to my Mums where I can connect via Ethernet. (I use WiFi hotspot from my phone at home). So I can't post any results of commands, I've done inxi -Fxz and no wifi device shows up. I've done rfkill list and nothing happens. It's as though the install has disabled or broken my WiFi card. This is a desktop computer, I don't think it has a hard switch for WiFi. Ive searched the bios menus can't see an option to enable it.

Thanks in advance for your help, I'm very perplexed how it stopped working from even USB after install to ssd. Sorry if I broke any rules in new here, I did search through other posts, none seem to match mine exactly.
Last edited by joejoejr on Sun Jul 21, 2019 4:08 am, edited 1 time in total.

User avatar
kc1di
Level 14
Level 14
Posts: 5335
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by kc1di » Sat Jul 20, 2019 4:32 am

Hello and welcome to Linux Mint Forums.

Please run these two commands in a terminal and post the outputs here.

Code: Select all

inxi -Nn
and

Code: Select all

rfkill list
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 7:13 am

Hi and thanks for responding to my question!

inxi -Nn

Network:
Device-1: Intel 82567LM-3 Gigabit Network driver: e1000e
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 00:0f:fe:c9:91:9b


rfkill list

Returns nothing.

ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 00:0f:fe:c9:91:9b brd ff:ff:ff:ff:ff:ff


lspci

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.2 IDE interface: Intel Corporation 4 Series Chipset PT IDER Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JDO (ICH10DO) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801JD/DO (ICH10 Family) SATA AHCI Controller (rev 02)



lshw -short

H/W path Device Class Description
=================================================================
system HP Compaq 8000 Elite SFF P
/0 bus 3646h
/0/1 memory 128KiB BIOS
/0/5 processor Intel(R) Core(TM)2 Duo CPU
/0/5/6 memory 128KiB L1 cache
/0/5/7 memory 6MiB L2 cache
/0/3c memory System Memory
/0/3c/0 memory 1GiB DIMM DDR3 Synchronous
/0/3c/1 memory 1GiB DIMM DDR3 Synchronous
/0/3c/2 memory 1GiB DIMM DDR3 Synchronous
/0/3c/3 memory 1GiB DIMM DDR3 Synchronous
/0/3d memory Flash Memory
/0/3d/0 memory 4MiB Chip FLASH Non-volati
/0/0 memory
/0/2 memory
/0/100 bridge 4 Series Chipset DRAM Cont
/0/100/2 display 4 Series Chipset Integrate
/0/100/2.1 display 4 Series Chipset Integrate
/0/100/3 communication 4 Series Chipset HECI Cont
/0/100/3.2 storage 4 Series Chipset PT IDER C
/0/100/3.3 communication 4 Series Chipset Serial KT
/0/100/19 enp0s25 network 82567LM-3 Gigabit Network
/0/100/1a bus 82801JD/DO (ICH10 Family)
/0/100/1a/1 usb3 bus UHCI Host Controller
/0/100/1a/1/2 input USB Receiver
/0/100/1a.1 bus 82801JD/DO (ICH10 Family)
/0/100/1a.1/1 usb4 bus UHCI Host Controller
/0/100/1a.2 bus 82801JD/DO (ICH10 Family)
/0/100/1a.2/1 usb5 bus UHCI Host Controller
/0/100/1a.7 bus 82801JD/DO (ICH10 Family)
/0/100/1a.7/1 usb1 bus EHCI Host Controller
/0/100/1a.7/1/1 scsi8 storage TOSHIBA USB DRV
/0/100/1a.7/1/1/0.0.0 /dev/sda disk 31GB TOSHIBA USB DRV
/0/100/1a.7/1/1/0.0.0/0 /dev/sda disk 31GB
/0/100/1a.7/1/1/0.0.0/0/2 /dev/sda2 volume 15EiB Windows FAT volume
/0/100/1b multimedia 82801JD/DO (ICH10 Family)
/0/100/1c bridge 82801JD/DO (ICH10 Family)
/0/100/1c.1 bridge 82801JD/DO (ICH10 Family)
/0/100/1d bus 82801JD/DO (ICH10 Family)
/0/100/1d/1 usb6 bus UHCI Host Controller
/0/100/1d.1 bus 82801JD/DO (ICH10 Family)
/0/100/1d.1/1 usb7 bus UHCI Host Controller
/0/100/1d.2 bus 82801JD/DO (ICH10 Family)
/0/100/1d.2/1 usb8 bus UHCI Host Controller
/0/100/1d.7 bus 82801JD/DO (ICH10 Family)
/0/100/1d.7/1 usb2 bus EHCI Host Controller
/0/100/1e bridge 82801 PCI Bridge
/0/100/1f bridge 82801JDO (ICH10DO) LPC Int
/0/100/1f.2 storage 82801JD/DO (ICH10 Family)
/0/3 scsi2 storage
/0/3/0.0.0 /dev/cdrom disk CDDVDW TS-H653R
/1 power High Efficiency

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 7:35 am

kc1di wrote:
Sat Jul 20, 2019 4:32 am
Hello and welcome to Linux Mint Forums.

Please run these two commands in a terminal and post the outputs here.

Code: Select all

inxi -Nn
and

Code: Select all

rfkill list
Not sure if I replied in the right way.

Hi and thanks for responding to my question!

inxi -Nn

Network:
Device-1: Intel 82567LM-3 Gigabit Network driver: e1000e
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 00:0f:fe:c9:91:9b


rfkill list

Returns nothing.

ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 00:0f:fe:c9:91:9b brd ff:ff:ff:ff:ff:ff


lspci

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.2 IDE interface: Intel Corporation 4 Series Chipset PT IDER Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JDO (ICH10DO) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801JD/DO (ICH10 Family) SATA AHCI Controller (rev 02)


lshw -short

H/W path Device Class Description
=================================================================
system HP Compaq 8000 Elite SFF P
/0 bus 3646h
/0/1 memory 128KiB BIOS
/0/5 processor Intel(R) Core(TM)2 Duo CPU
/0/5/6 memory 128KiB L1 cache
/0/5/7 memory 6MiB L2 cache
/0/3c memory System Memory
/0/3c/0 memory 1GiB DIMM DDR3 Synchronous
/0/3c/1 memory 1GiB DIMM DDR3 Synchronous
/0/3c/2 memory 1GiB DIMM DDR3 Synchronous
/0/3c/3 memory 1GiB DIMM DDR3 Synchronous
/0/3d memory Flash Memory
/0/3d/0 memory 4MiB Chip FLASH Non-volati
/0/0 memory
/0/2 memory
/0/100 bridge 4 Series Chipset DRAM Cont
/0/100/2 display 4 Series Chipset Integrate
/0/100/2.1 display 4 Series Chipset Integrate
/0/100/3 communication 4 Series Chipset HECI Cont
/0/100/3.2 storage 4 Series Chipset PT IDER C
/0/100/3.3 communication 4 Series Chipset Serial KT
/0/100/19 enp0s25 network 82567LM-3 Gigabit Network
/0/100/1a bus 82801JD/DO (ICH10 Family)
/0/100/1a/1 usb3 bus UHCI Host Controller
/0/100/1a/1/2 input USB Receiver
/0/100/1a.1 bus 82801JD/DO (ICH10 Family)
/0/100/1a.1/1 usb4 bus UHCI Host Controller
/0/100/1a.2 bus 82801JD/DO (ICH10 Family)
/0/100/1a.2/1 usb5 bus UHCI Host Controller
/0/100/1a.7 bus 82801JD/DO (ICH10 Family)
/0/100/1a.7/1 usb1 bus EHCI Host Controller
/0/100/1a.7/1/1 scsi8 storage TOSHIBA USB DRV
/0/100/1a.7/1/1/0.0.0 /dev/sda disk 31GB TOSHIBA USB DRV
/0/100/1a.7/1/1/0.0.0/0 /dev/sda disk 31GB
/0/100/1a.7/1/1/0.0.0/0/2 /dev/sda2 volume 15EiB Windows FAT volume
/0/100/1b multimedia 82801JD/DO (ICH10 Family)
/0/100/1c bridge 82801JD/DO (ICH10 Family)
/0/100/1c.1 bridge 82801JD/DO (ICH10 Family)
/0/100/1d bus 82801JD/DO (ICH10 Family)
/0/100/1d/1 usb6 bus UHCI Host Controller
/0/100/1d.1 bus 82801JD/DO (ICH10 Family)
/0/100/1d.1/1 usb7 bus UHCI Host Controller
/0/100/1d.2 bus 82801JD/DO (ICH10 Family)
/0/100/1d.2/1 usb8 bus UHCI Host Controller
/0/100/1d.7 bus 82801JD/DO (ICH10 Family)
/0/100/1d.7/1 usb2 bus EHCI Host Controller
/0/100/1e bridge 82801 PCI Bridge
/0/100/1f bridge 82801JDO (ICH10DO) LPC Int
/0/100/1f.2 storage 82801JD/DO (ICH10 Family)
/0/3 scsi2 storage
/0/3/0.0.0 /dev/cdrom disk CDDVDW TS-H653R
/1 power High Efficiency

User avatar
kc1di
Level 14
Level 14
Posts: 5335
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by kc1di » Sat Jul 20, 2019 7:37 am

I do not see any wifi card listed in your output. Are you sure it's connected?
If so do you know which card and chipset it's using?
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

athi
Level 6
Level 6
Posts: 1460
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by athi » Sat Jul 20, 2019 8:10 am

Output not showing the TP Link TL-WN881ND. Maybe the card got unseated while you were working on the PC.

Have you try reseating or moving the wifi card to another PCIe x1 or x16 slot?
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 8:44 am

kc1di wrote:
Sat Jul 20, 2019 7:37 am
I do not see any wifi card listed in your output. Are you sure it's connected?
If so do you know which card and chipset it's using?
Yeah, its not detecting it. But it worked for the first 3 boots from USB. I plugged it in and out several times in both pci slots, the led is not on. That's why I suggested it had been disabled during the install, but there's no switch, nowhere in bios to turn on wifi.

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 8:49 am

athi wrote:
Sat Jul 20, 2019 8:10 am
Output not showing the TP Link TL-WN881ND. Maybe the card got unseated while you were working on the PC.

Have you try reseating or moving the wifi card to another PCIe x1 or x16 slot?
Yeah I tried reseating it in both slots, several times. Is the x16 slot the longer one? I didn't know you could plug it into them. Ill try.

User avatar
kc1di
Level 14
Level 14
Posts: 5335
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by kc1di » Sat Jul 20, 2019 8:53 am

It could be the card went also. maybe time for a new one :(
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sat Jul 20, 2019 8:58 am

kc1di wrote:
Sat Jul 20, 2019 4:32 am
Hello and welcome to Linux Mint Forums.

Please run these two commands in a terminal and post the outputs here.

Code: Select all

inxi -Nn
and

Code: Select all

rfkill list
I just reinstalled on SSD, Now wifi card at least appears to be showing up!

inixi -Nn

Network:
Device-1: Intel 82567LM-3 Gigabit Network driver: e1000e
IF: enp0s25 state: down mac: 00:0f:fe:c9:91:9b
Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k
IF: wls2 state: down mac: 90:f6:52:6a:50:d6

rekill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


Still no wifi networks show up, but Im pretty stoked after a day and a half of trying.

User avatar
kc1di
Level 14
Level 14
Posts: 5335
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by kc1di » Sat Jul 20, 2019 10:28 am

Ok now that we know the wireless card. The driver I believe is the correct one that is being used for that card.
But there was a problem with it's conf. file. that may be corrected like this.

in a terminal do this.

Code: Select all

xed admin:///etc/modprobe.d/ath9k.conf
once that opens copy and paste this line at the bottom of that file.

Code: Select all

options ath9k nohwcrypt=1
save the file and reboot. See if wifi is working.
good luck.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

joejoejr
Level 1
Level 1
Posts: 8
Joined: Fri Jul 19, 2019 11:19 pm

Re: Wireless initially worked from USB flash drive, after install WiFi card not detected from add install OR USB image?

Post by joejoejr » Sun Jul 21, 2019 4:02 am

kc1di wrote:
Sat Jul 20, 2019 10:28 am
Ok now that we know the wireless card. The driver I believe is the correct one that is being used for that card.
But there was a problem with it's conf. file. that may be corrected like this.

in a terminal do this.

Code: Select all

xed admin:///etc/modprobe.d/ath9k.conf
once that opens copy and paste this line at the bottom of that file.

Code: Select all

options ath9k nohwcrypt=1
save the file and reboot. See if wifi is working.
good luck.
Thanks Kc1di, I just booted up today for the first time and it is all working now. Last night it showed wifi but no networks to connect to,
tonight it just works. In my searching I did read someone saying that the driver ath9k is not very good. Hopefull it stays working.

Thanks so much for your help and to everyone who commented on this thread, I'm very appreciative.

Post Reply

Return to “Wireless”