Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Locked
MarkusMintus
Level 1
Level 1
Posts: 17
Joined: Sat Jan 29, 2011 3:07 pm

Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by MarkusMintus »

Dear Linux-Mint Forum,
I recently upgraded my laptop from an old Thinkpad T420s to a Thinkpad E495 and will try to get Windows 10 and Linux Mint 19.2 running on it. I will post my experience with this machine, any troubles I ran into and which solutions worked (if there where any :wink: ) in the hope to help others with similar issues.

Some personal opinion about the system. The build quality is very good. The chassis feels solid and does not bend. Keyboard is also good, but not as good as on my old T420s. Touchpad is much better, but I am a trackpoint lover, so I will not use it. Screen has good viewing angles and contrast, but brightness is not great, but for indoor work acceptable. Screen has a warm-yellowish tint (in WIN and Linux), even with icc color profile loaded which is supposedly at 6500K Color Temperatur (solved - see below).
All in all I am very impressed with the E495 (Studendprice €520) plus upgrade to 1TB nvme and 16G RAM which brings the price to €650 in total. Which is very good value for that price range.

1.) Info about the system:
markus@E495:~$ inxi -Fxz
System:
Host: E495 Kernel: 5.2.7-050207-generic x86_64 bits: 64 compiler: gcc
v:9.1.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
base: Ubuntu 18.04 bionic

Machine:
Type: Laptop System: LENOVO product: 20NEA001GE v: ThinkPad E495
serial: <filter>
Mobo: LENOVO model: 20NEA001GE serial: <filter> UEFI: LENOVO
v: R11ET25W (1.05 ) date: 04/04/2019

Battery:
ID-1: BAT0 charge: 29.6 Wh condition: 46.1/45.7 Wh (101%)
model: Celxpert 01AV448 status: Discharging

CPU:
Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33538
Speed: 1222 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1222 2: 1223
3: 1224 4: 1225 5: 1308 6: 1243 7: 1323 8: 1332

Graphics:
Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0
Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati
unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.7-050207-generic LLVM 8.0.0)
v: 4.5 Mesa 19.0.2 direct render: Yes

Audio:
Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 05:00.1
Device-2: AMD vendor: Lenovo driver: N/A bus ID: 05:00.5
Device-3: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 05:00.6
Sound Server: ALSA v: k5.2.7-050207-generic

Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000
bus ID: 04:00.0
IF: wlp4s0 state: down mac: <filter>

Drives:
Local Storage: total: 931.51 GiB used: 166.02 GiB (17.8%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB

Partition:
ID-1: / size: 86.51 GiB used: 10.04 GiB (11.6%) fs: ext4 dev: /dev/nvme0n1p5
ID-2: /home size: 732.36 GiB used: 77.98 GiB (10.6%) fs: ext4
dev: /dev/nvme0n1p6
ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0
Sensors:
System Temperatures: cpu: 43.5 C mobo: 0.0 C gpu: amdgpu temp: 43 C
Fan Speeds (RPM): cpu: 0

Info:
Processes: 256 Uptime: 11m Memory: 13.63 GiB used: 1.12 GiB (8.2%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.32


2.) Info about OS-Installation
Win 10 with build 1903 from USB worked without issues. Lenovo Vantage pulled all drivers. The LCD color-temp can be changed in the radeon display drivers, so no more yellow tint in windows.

LINUX-MINT install: 19.2 Cinnamon installation via usb worked in so for that I got a working system, but with a few issues. Some of which I managed to solve on my own, for some I will need your help dear forum :D


3.) Issues and solutions:
- Issue: Some function key, for example LCD brightness adjust does not work
Solution: Install new kernel 5.2.7 with ukuu kernel update utility (also recommended for Ryzen 3 support)

- Issue: Trackpad works nice, Trackpoint is way to quick! Setting in the mouse/touchpad section of the system settings don't seem to work.
Solution: removal of the xorg-input-libinput via apt remove xserver-xorg-input-libinput and installing apt install xserver-xorg-input-evdev. Now the Trackpoint has a normal speed.

- Issue: Yellow/Warm Display color:
Solution: Since i used redshift on my old machine, and since it is pre installed on Mint 19.2, I just set it manually to higher kelvin levels during the day, and in the evening the warm color is anyway preferable. To set it to 8000K use: redshift -O 8000

- Issue: Trackpad in bios/uefi and in system settings disabled, but in nemo 4.2.2 ONLY (no other application so far) it kind of still works: No mouse pointer movement but it seems it registers mouse clicks from time to time, which is very annoying since while using the trackpoint my right palm sometimes touches it.
Solution Installing the synaptics driver for the touchpad solved the issue:

markus@E495:~$ apt install xserver-xorg-input-synaptics
markus@E495:~$ grep -i "Using input driver" /var/log/Xorg.0.log
[ 5585.488] (II) Using input driver 'evdev' for 'Power Button'
[ 5585.519] (II) Using input driver 'evdev' for 'Video Bus'
[ 5585.520] (II) Using input driver 'evdev' for 'Power Button'
[ 5585.522] (II) Using input driver 'evdev' for 'Sleep Button'
[ 5585.525] (II) Using input driver 'evdev' for 'Integrated Camera: Integrated C'
[ 5585.527] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 5585.528] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 5585.616] (II) Using input driver 'evdev' for 'TPPS/2 Elan TrackPoint'
[ 5585.621] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'




I hope this post is on the right forum and in the right style, otherwise dear moderators please move it to an more appropriate place.
I will update any further issues and solutions.
Kind regards,
Markus

deepakdeshp
Level 17
Level 17
Posts: 7561
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by deepakdeshp »

Thank you for being helpful, sharing the issues and solutions. It will be useful for someone with the same model.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Testermanamd
Level 1
Level 1
Posts: 1
Joined: Sun Aug 25, 2019 6:04 pm

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by Testermanamd »

Can you put your idle average power usage in Windows and Linux ?
In Linux you can see it with sudo powertop with min brightness and 0 open apps
In Windows the almost the same not with powertop but hwinfo( inside the app go to sensors and find battery) with mom brightness and 0 open apps

Other thing is the output of cpupower idle-info p
Pls and thank you so much

sa3paleasm
Level 1
Level 1
Posts: 6
Joined: Wed Dec 09, 2009 1:28 pm
Location: Egypt

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by sa3paleasm »

Usage Events/s Category Description
2.0 ms/s 264.5 kWork dbs_work_handler
100.0% Device Audio codec hwC0D0: ATI
100.0% Device Audio codec hwC1D0: Conexant
108.9 ms/s 48.1 Process [PID 1049] /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
14.0 ms/s 76.3 Process [PID 5750] /usr/bin/mate-terminal
5.0 ms/s 81.4 Process [PID 4961] /usr/lib/firefox/firefox
23.8 ms/s 64.8 Process [PID 4910] /usr/lib/firefox/firefox
4.0 ms/s 68.3 Process [PID 4917] /usr/lib/firefox/firefox
4.5 ms/s 55.8 Process [PID 5451] /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 7569 -prefMapSize 202725 -parentBuildID 201
3.6 ms/s 41.7 Process [PID 4970] /usr/lib/firefox/firefox
3.7 ms/s 31.8 Process [PID 1522] marco
42.5 ms/s 19.1 Process [PID 5447] /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 7569 -prefMapSize 202725 -parentBuildID 201
186.1 µs/s 34.9 kWork flush_to_ldisc
10.7 ms/s 20.5 Process [PID 4962] /usr/lib/firefox/firefox
542.9 µs/s 24.9 Process [PID 60] [kworker/2:1]
4.6 ms/s 19.9 Process [PID 5063] /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 6069 -prefMapSize 202725 -parentBuildID 201
1.5 ms/s 16.6 Timer tick_sched_timer
1.2 ms/s 13.2 Timer hrtimer_wakeup
1.6 ms/s 9.8 Process [PID 1566] /usr/lib/mate-applets/mate-netspeed-applet
396.0 µs/s 9.1 Process [PID 1504] /usr/lib/at-spi2-core/at-spi2-registryd --use-gnome-session
0.7 ms/s 5.8 Process [PID 1735] /opt/xdman/jre/bin/java -Xmx1024m -jar /opt/xdman/xdman.jar -m
5.9 ms/s 3.7 Process [PID 6195] powertop
3.2 ms/s 3.4 Interrupt [7] sched(softirq)
179.0 µs/s 4.4 Process [PID 518] [irq/74-iwlwifi:]
66.9 µs/s 4.1 kWork gc_worker
53.1 µs/s 3.8 Process [PID 8] [rcu_sched]
227.7 µs/s 2.4 Process [PID 5077] /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 6069 -prefMapSize 202725 -parentBuildID 201
31.6 µs/s 2.1 Interrupt [74] iwlwifi: default queue
0.7 ms/s 1.0 Process [PID 5002] /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 202725 -parentBuildID 201909
427.8 µs/s 1.0 Process [PID 1540] mate-panel
450.0 µs/s 0.9 Process [PID 5148] /opt/xdman/jre/bin/java -Xmx1024m -jar /opt/xdman/xdman.jar -m
95.7 µs/s 1.0 Process [PID 5018] /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 202725 -parentBuildID 201909
314.9 µs/s 0.8 Process [PID 1518] /usr/bin/mate-settings-daemon
7.5 µs/s 0.9 Timer sched_rt_period_timer
71.4 µs/s 0.7 Process [PID 1586] nm-applet
1.6 ms/s 0.00 Interrupt [32] xhci_hcd
16.1 µs/s 0.6 kWork vmstat_shepherd
42.0 µs/s 0.5 Process [PID 5166] /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 6869 -prefMapSize 202725 -parentBuildID 201
40.1 µs/s 0.5 Process [PID 5006] /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 202725 -parentBuildID 201909
272.6 µs/s 0.4 Process [PID 5151] /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 6869 -prefMapSize 202725 -parentBuildID 201
111.3 µs/s 0.4 Process [PID 1868] /opt/xdman/jre/bin/java -Xmx1024m -jar /opt/xdman/xdman.jar -m
20.1 µs/s 0.4 Process [PID 821] /lib/systemd/systemd-logind
1.5 µs/s 0.4 kWork console_callback
592.9 µs/s 0.10 Process [PID 1736] mintmenu
157.5 µs/s 0.25 Process [PID 233] [kworker/u32:4]
2.3 µs/s 0.3 kWork blk_mq_requeue_work
25.5 µs/s 0.25 Timer it_real_fn
16.7 µs/s 0.25 Process [PID 341] [jbd2/nvme0n1p7-]
0.0 µs/s 0.25 kWork call_usermodehelper_exec_work
59.5 µs/s 0.20 Process [PID 1885] /opt/xdman/jre/bin/java -Xmx1024m -jar /opt/xdman/xdman.jar -m
57.9 µs/s 0.20 Interrupt [3] net_rx(softirq)

sa3paleasm
Level 1
Level 1
Posts: 6
Joined: Wed Dec 09, 2009 1:28 pm
Location: Egypt

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by sa3paleasm »

i`ve same problem
Attachments
Screenshot at 2019-09-23 09-20-08.png

sa3paleasm
Level 1
Level 1
Posts: 6
Joined: Wed Dec 09, 2009 1:28 pm
Location: Egypt

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by sa3paleasm »

dosn`t work with 5.3.1 and 2.7 too
Attachments
Screenshot at 2019-09-23 09-49-24.png
Screenshot at 2019-09-23 09-43-12.png

Endriux
Level 1
Level 1
Posts: 2
Joined: Sun Nov 03, 2019 7:27 pm

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by Endriux »

Same problem of not working brightness keys on my Lenovo Thinkpad X395, AMD Ryzen 5 Pro 3500U, IPS FHD display, Linux Mint 19.2 with XFCE.
Solved with the installation of 5.2.7 kernel.
Thank you very much!

Erich K
Level 1
Level 1
Posts: 1
Joined: Sat Nov 09, 2019 3:08 pm

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by Erich K »

I am having WIFI issues with my E495. WIFI generally works with Linux, but never manages to connect on the first attempt. (So it's just an annoying issue, not a showstopper) Has anybody the same problem?

User avatar
kato181
Level 5
Level 5
Posts: 779
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by kato181 »

Erich K wrote:
Sat Nov 09, 2019 3:13 pm
I am having WIFI issues with my E495. WIFI generally works with Linux, but never manages to connect on the first attempt. (So it's just an annoying issue, not a showstopper) Has anybody the same problem?
You need to start a separate post outlining you problems in the appropriate section for others to help.

User avatar
karlchen
Level 21
Level 21
Posts: 12624
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Mint 19.2 on Thinkpad E495 (AMD Ryzen 5 3500U)

Post by karlchen »

<Mod> crazywipe's post about LM in Virtualbox on Thinkpad E495 split off into a new thread here: viewtopic.php?f=49&t=315327 </Mod>
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Locked

Return to “Hardware Support”